Xperia 10 iii can't enable mobile data on talkmobile use the same settings used on my XA2 Plus

REPRODUCIBILITY: 100% now. Recurs after a restart.
OS VERSION: 4.4.0.68 (Android 11_4.19_v9a_lena)
HARDWARE: 10 iii
UI LANGUAGE: English
REGRESSION: Yes - Mobile data tested before and after device flashing. Seems to have happened in last few days - difficult to be precise as I WFH with wifi. Mobile data on the same sim still works fine on my old XA2 Plus running 4.4.0.64.

DESCRIPTION:

Using exactly the same System>Mobile network settings as in my XA2 Plus.
n.b. except the “4G calling (beta)” feature which i don’t think is foud on the old phone.

System>Sim sees the talkmobile card

but the top items is greyed out (shown below):
[unticked] talkmobile.co.uk
User SIM card “SIM1 | Talkmobile”

If i leave the phone on
[ticked] Select network automatically

Then the bit beneath is greyed out:
Network “Searching…”

If i click on “Select network automatically” to manually select, then i see:
"Talkmobile
GB15"

But if I attempt to click on it to select it then i get a top notification saying:
“Connection Error”

PRECONDITIONS:

STEPS TO REPRODUCE:

Insert Sim, turn on

EXPECTED RESULT:

Get a connection

ACTUAL RESULT:

Don’t get a connection

MODIFICATIONS:

None, clean install on a new device.
Mobile data tested as working before and after flashing earlier this week.

ADDITIONAL INFORMATION:

Photos attached showing working settings on my XA2 Plus

Part 2 of this problem:

Now have a new sim, that works fine in the old phone. But does not recognise mobile data in the new!

SW_binaries_for_Xperia_Android_11_4.19_v9a_lena.img



I have a similar problem. Maybe it’s the same.
Could you please try it with the APN protocol setting “Dual” and watch the journal log while turning on the mobile data.

You can enable live view of the journal log with the following command in terminal:
devel-su journalctl -f

Or after turning on mobile data with:
devel-su journalctl -u connman

Does the entry “DUAL no IPv4 address set” appear there?

1 Like

Update - tried the Sim card in Sim2 slot and i’m back to where I started originally in the first bug report:

I can make calls, but have no mobile data and the Mobile Settings report “Limited connectivity”.

Since I got this far, i tried your suggestion:

tried the above, got lots of scrolling text, but nothing among it looked like:
“DUAL no IPv4 address set”

Also did devel-su ifconfig and the rmet_data1 link encap stuff lists an addr for both inet6 and inet.

Thank you.

Have you tried my (dirty) workaround to get mobile data with SIM slot 2?

1 Like

thanks, will give it a go.

I experimented a bit more and found the following workaround for using mobile internet with SIM slot 2:
By switching the network mode to “2G only”, the connection is re-established and “Connected” is now displayed under “Mobile network”.
If you then switch back to the “4G preferred” network mode, the mobile data connection remains “Connected” and the mobile Internet connection works correctly with 4G.

I tried this, and after switching to “2G only” it does say [enabled] (tho no mobile data of course), but when i switch it to “4G Preferred” the phones switches back to [limited connectivity].

Also find that when i restart the phone with the sim card inside it updates the Mobile Network > MMS Access Point Settings from what is shown in the screenshot to:
Connection Name = talkmobile.co.uk (minus the “payg.” prefix)
Authentication = “None” (rather than “PAP or CHAP” + “wap/wap”
Proxy address = “212.183.137.012” (they added a zero in the fourth character group)

Settings which still don’t work.