Unable to use mobile data on Sony Xperia 10 III

Apologies if you’ve tried this already…
I’m in France atm and not having live traffic for satnav was a major pain (we drove into several whopping jams).
I’ve just tried moving my sim into slot2 and mobile data worked instantly.

Now of course I’ve got nowhere to put my sd card (which has various things on it including backup maps, phone backup, years of photos & other such ephemera).

But anyway, it.does.work (for me anyhow).
I’ve got various annoying niggles that means I’ll think about upgrading the Android version, particularly irritating as downgrading Android initially was a major pain (I don’t have Windows for a start)
HTH & good luck with it all

Thank you for your trial, but it’s a no go for me. I won’t use a mobile phone without a memory card.

1 Like

I’m having the same problem: Mobile data stops working for no apparent reason.

  • SFOS installed over Android 11 (tried both 62.0.A.3.17 and 62.0.A.3.109, same result)
  • SIM card works in Android 11 (I went back to Android several times => same phone same card work in 5G under android)
  • Operator: Free Mobile (France)
  • VoLTE disabled (Xperia 10III not supported by Free Mobile)
  • No SDCard
  • SIM card in slot 1 or 2 won’t make a difference.
  • Connection set to IP/IPV6 etc doesn’t make a difference
  • Same SIM works fine in XperiaX dual sim.

A sequence similar to what DrYak described above , but with disabled SIM2 - worked once after reboot. Mobile Data worked fine until next reboot.

Can’t reproduce the “working” pattern since (yet it did work - I installed mail app, calendar, etc - and I have not set any WIFI network)

I noticed it takes long to shut down/reboot - the red led remains on for around 20-30 seconds before reboot/shutdown

At this stage, my Xperia 10 III is unusable with SFOS and my operator , reverting to my old Xperia X.


Welcome to the brick club.
The lack of any follow up by Jolla for such a serious problem is making me doubt heavily about the future of the platform.

Haven’t tested this feature yet as I am roaming from my Xperia SIM … I better get on it :o:

i’d swear that mobile data worked on first boot, but i’ve not been able to getting working since despite re-flashes, new sim card, swapping sim slots, etc:

Well, lets not go quite over the top here:

My £325 toy is a joy to behold, and brings me much pleasure to look at as I go about my daily business with my mobile phone** in hand.

** my old XA2 Plus! :smiley:

1 Like

i’d swear that mobile data worked on first boot, but i’ve not been able to getting working since despite re-flashes, new sim card, swapping sim slots, etc

First time I flashed SFOS on the 10III (over 62.0.A.3.109), the 4G data worked - this matches somewhat your experience. Working 4G data survived multiple reboots, etc.
Then at a moment I can’t easily point it stopped. Past this moment I tried:

  • swapping SIM1/2 emplacement, enabling disabling sim slots ( at all the stages below)
  • restarting ofono and the other steps here: https://forum.sailfishos.org/t/unable-to-use-mobile-data-on- sony-xperia-10-iii-4-4-0-64/11560?u=rtr2001 → fail
  • re-flashing SFOS over SFOS → fail
  • flashing Android 62.0.A.3.109 then SFOS → fail
  • flashing Android 62.0.A.3.17 then SFOS . I got 4G working once - after enable/disable SIM slots and rebooting. But next reboot got me back in the loop. Actual status → fail

I will try later today to flash Android 12 then SFOS and will report here.


Flashed Android12 ( 62.1.A.0.617 ) with newflasher (on linux). Firmware downloaded with xperifirm.
SIM is in SIM1, haven’t tried SIM2
Mobile data ok in android (5G, 4G…).
Then flashed SFOS and Mobile Data worked with default settings (IP: Dual) since 1st boot.
Survived several reboots, toggling SIM1/2 activation, restarting ofono.
Then after one more reboot it stopped. Can’t figure out what breaks it.


Its beyond of our knowledge. Just waste of time and frustration. So I will try to call @flypig @Jolla, will you give us any input about this bug?


In my case SIM1 doesn’t work(t-mobile NL) and I have to use SIM2. That means i’m unable to use SDcard(that is since the III has 128GB internal not a problem at all).
Other then that, it’s running fantastic. My old 10 I was incredibly slow on some websites, and the III’s battery lasts at least 2x longer.

Yes indeed i totally agree with your conclusion, i had the same problem on my XA2 Ultra, tried several options and ended up deciding to go back to andy, but even that was not easy in my case.
Now i m using Lineage 19.1 with android 12 on this old xa2, sofar so good.
II was supriced sfos still had vey annoying bugs on basic functions even after 8 years , so guess ill wait another 8 for sfos is matured lol.

1 Like

Actually it’s getting worse. The current version of SFOS on XA2 has some serious bugs, including Android support that hangs when panning the map on navigation apps or connectivity that fails when switching from WiFi to mobile data and vice versa.

The XA2 behavior is off topic here…


Yep u are right , sorry only mentioned the bugs that are similar to the 10 III also on the latest build and still not solved by Jolla, so it was worth to mention , thank u.

After being hit by the no data issue on my new Xperia 10iii, i did some experiments and now the phone is connecting ok to the network, with data.
I think the main change is to use the SW binaries for Xperia version v8a instead of the latest, but could not confirm doing only that will fix the issue since i did much more. If someone wants to try on a phone with the issue, just download SW_binaries_for_Xperia_Android_11_4.19_v8a_lena.img on Sony developper websie and flash it in fastboot mode with command: fastboot -s HQ618J3443 flash oem_a ./SW_binaries_for_Xperia_Android_11_4.19_v8a_lena.img

Here is the complete process i did:
Flash with emma to restore to version 62.0. A.3.109 (Android 11)
Check the phone is connecting ok in Android.
Do a factory reset in Android to remove all data/settings
Turn off the phone
Do a wipe data in recovery mode (Vol- + Power to start the phone)
At this point, i assume the phone is in a ‘fresh’ state.
Flash Sailfish with the v8a SW binaries. I had to modify flash-config.sh and md5.lst.
Reboot the phone once install is done.
Make sure both SIMs are enabled (if i disable the non used one, the network connection is lost)
Phone was connecting ok on boot, but after finishing the installation, i flashed again the SW binaries one more time.
From that, phone is working ok, network is connecting ok even after several reboot.

Hope it can help


Sadly, but following your way and after instering SD card to slot 2, doesnt work anymore, even flashing binaries. Mobile data survived only 2 reboots. FYI now i tried wiping data in recovery mode, reflashing sailfish os (without reflashing android from emma) didnt help, flashing biniaries either.

1 Like

Some followup:
The following sequence

  • Android 12 ( 62.1.A.0.617, newflasher) => SFOS (Mobile data ok till self broken) => same android 12 (newflasher) => SFOS
    brought the mobile data back in SFOS. It worked fine starting with 1st SFOS boot, survived several reboots. I had no WIFI configured during this time. Then after a while it stopped - see below.

(I mention the sequence because I also tried Android 11 => SFOS (mobile data broken) => Android 11 with EMMA (mobile data ok) => SFOS - but that did not get Mobile data back)

In all cases the phone shows 4G connection, with data “enabled”. The data symbols in the status are ok (they don’t display unless data truly works).

So: after reflashing, it worked ok until rebooting the day after => then back to the repeated Unexpected data call status 4100 from ofonod with no mobile data.
It ceased working a bit before taking off so left it like that => after landing, surprise! It started working just fine once abroad with roaming enabled (4G, Vodafone RO).
At some point it auto switched to Orange RO, worked a while then got stuck in 3G with the same error. I could force it back to Vodafone RO - and it kept working ever since.

I will try to structure a bug report - but aside telling that in some circumstance it reliably breaks itself, I don’t know what to describe. I can provide ofono/system logs as well.
As opposed to other reports:

  • it works ok starting with boot (while it lasts) with Dual IP (default settings)
  • Once broken, switching slots, IP setup, etc - won’t help
  • VoLTE is NOT activated so no interference.
1 Like

Could you please enable only 3G and switch Dual mode to IPv4 only. Use SIM1 slot.
And then enable Flight mode and disable in a 5 seconds.

It seems you lost the data after adding the SD card. I forgot to mention that i put the SIM card in slot1 and SDcard while in android mode, and never touched them again.
Also i did not change SIM settings (enable/disable) after getting the data as i saw some weird behavior before: when disabling SIM2, i still have a network icon, (top right of the screen) but no connection at all. If i disable SIM1 and enable SIM2 i do not have any network icon on the top right.
Not sure if it is related, so far not touching anything related to SIM or network, the phone has still data (i can turn the wifi on and off keeping the connection), so i am not making any new experiment.