Unable to use mobile data on Sony Xperia 10 III

try upgrade from to seems to have fixed the ip6 routing issue for me.

I am already on No problem anyway, it does not work any more.

1 Like

I guess there is some serious issue with the SIM slot management. I have a single SIM in slot 1 and an SD card in slot 2. If I have both slots on, I get the 4G indication but no data connectivity. If I turn off slot 2, 4G goes off even if slot 1 is still on. Turning slot 2 on again, 4G comes back.

1 Like

Anyway, it’s seven months I have purchased this damned phone and I still cannot use it. I think solving this f*cking issue should be priority number one. At least, providing some damn way to restore the phone to the initial networking state short of flashing it. It took me one month to reinstall everything on it and I am not flashing it again, I’ll rather throw it out of the window and get a Nokia X21 when it comes out. Please provide a way to use this device.


You are not alone, been waiting so long, purchased immediately licence and im still not able to use phone. The worst thing, there is no response from Jolla about this. Its god damn basic feature, mobile data! Nowadays you can throw your phone out of window without it.


Same problem.

10 ii is currently a SFOS toy, and I have gone back to my XA2 Plus as my ‘phone’:

Before throwing the device out of the window, I decided to use it to carry out some tests.
Same SIM in other devices: works (of course).
Other SIM in same device: does not work (but can get some kind of connection since the other provider, unlike Vodafone, provides an IPv4 address).
Same SIM in same device on Android: works.
Downgraded to, then upgraded again to does not work.
Reflashed to latest Android 11, then to SFOS again: does not work.
Upgraded SFOS to does not work.

Can reproduce one thing, its 100%. Flash Android (62.0.A.3.109), then flash Sailfish ( or - no matter), mobile data works till first reboot, then not anymore. Tested this on fresh install, aswell as installing apps, configuring and restoring data from backup. No matter, so its not problem with 3rd part applications or mess from backup. For me it should be easy fix, as there is light in tunnel, confirmed it works. (no problem with SIM, provider, settings etc.)


I am 99.999% certain that mobile data worked when i did the first boot of .68 on a 10iii, and that it was some (unspecified - after a reboot?) point later where i noticed that i didn’t have mobile data:

It’s for sure some stupid setting, anyway we are in 3rd quarter 2022, the X10III has been discontinued months ago and still it’s not in a usable state. Testing an OS is fine, staying with an unusable brick with no fix in sight is entirely another matter.

Similar problem and yet another workaround:

Maybe it will help someone else too, at least until the final bugfix.

1 Like

Apologies if you’ve tried this already…
I’m in France atm and not having live traffic for satnav was a major pain (we drove into several whopping jams).
I’ve just tried moving my sim into slot2 and mobile data worked instantly.

Now of course I’ve got nowhere to put my sd card (which has various things on it including backup maps, phone backup, years of photos & other such ephemera).

But anyway, it.does.work (for me anyhow).
I’ve got various annoying niggles that means I’ll think about upgrading the Android version, particularly irritating as downgrading Android initially was a major pain (I don’t have Windows for a start)
HTH & good luck with it all

Thank you for your trial, but it’s a no go for me. I won’t use a mobile phone without a memory card.

1 Like

I’m having the same problem: Mobile data stops working for no apparent reason.

  • SFOS installed over Android 11 (tried both 62.0.A.3.17 and 62.0.A.3.109, same result)
  • SIM card works in Android 11 (I went back to Android several times => same phone same card work in 5G under android)
  • Operator: Free Mobile (France)
  • VoLTE disabled (Xperia 10III not supported by Free Mobile)
  • No SDCard
  • SIM card in slot 1 or 2 won’t make a difference.
  • Connection set to IP/IPV6 etc doesn’t make a difference
  • Same SIM works fine in XperiaX dual sim.

A sequence similar to what DrYak described above , but with disabled SIM2 - worked once after reboot. Mobile Data worked fine until next reboot.

Can’t reproduce the “working” pattern since (yet it did work - I installed mail app, calendar, etc - and I have not set any WIFI network)

I noticed it takes long to shut down/reboot - the red led remains on for around 20-30 seconds before reboot/shutdown

At this stage, my Xperia 10 III is unusable with SFOS and my operator , reverting to my old Xperia X.


Welcome to the brick club.
The lack of any follow up by Jolla for such a serious problem is making me doubt heavily about the future of the platform.

Haven’t tested this feature yet as I am roaming from my Xperia SIM … I better get on it :o:

i’d swear that mobile data worked on first boot, but i’ve not been able to getting working since despite re-flashes, new sim card, swapping sim slots, etc:

Well, lets not go quite over the top here:

My £325 toy is a joy to behold, and brings me much pleasure to look at as I go about my daily business with my mobile phone** in hand.

** my old XA2 Plus! :smiley:

1 Like

i’d swear that mobile data worked on first boot, but i’ve not been able to getting working since despite re-flashes, new sim card, swapping sim slots, etc

First time I flashed SFOS on the 10III (over 62.0.A.3.109), the 4G data worked - this matches somewhat your experience. Working 4G data survived multiple reboots, etc.
Then at a moment I can’t easily point it stopped. Past this moment I tried:

  • swapping SIM1/2 emplacement, enabling disabling sim slots ( at all the stages below)
  • restarting ofono and the other steps here: https://forum.sailfishos.org/t/unable-to-use-mobile-data-on- sony-xperia-10-iii-4-4-0-64/11560?u=rtr2001 → fail
  • re-flashing SFOS over SFOS → fail
  • flashing Android 62.0.A.3.109 then SFOS → fail
  • flashing Android 62.0.A.3.17 then SFOS . I got 4G working once - after enable/disable SIM slots and rebooting. But next reboot got me back in the loop. Actual status → fail

I will try later today to flash Android 12 then SFOS and will report here.


Flashed Android12 ( 62.1.A.0.617 ) with newflasher (on linux). Firmware downloaded with xperifirm.
SIM is in SIM1, haven’t tried SIM2
Mobile data ok in android (5G, 4G…).
Then flashed SFOS and Mobile Data worked with default settings (IP: Dual) since 1st boot.
Survived several reboots, toggling SIM1/2 activation, restarting ofono.
Then after one more reboot it stopped. Can’t figure out what breaks it.