[Release notes] Vanha Rauma 4.4.0.68

Many thanks to you our active contributors for your feedback and proposals.

Special thanks to Kees van Niftrik for allowing us to use his beautiful photo of old Rauma at the OS update page in Settings.

Table of content

Table of content

Update version history

  • 2022-03-17: OS version 4.4.0.58 was released to Early Access subscribers as an over-the-air update. No support for Xperia 10 III, yet.
  • 2022-03-29: OS version 4.4.0.58 was released to all users as an over-the-air update. No support for Xperia 10 III, yet.
  • 2022-05-18: OS version 4.4.0.64 was released to all users as an over-the-air update. Support for Xperia 10 III added.
  • 2022-07-13: OS version 4.4.0.68 was released to all users as an over-the-air update. VoLTE beta support added for Xperia 10 II.

Stop release

Yes, 4.4.0.68 is a stop release .

– Is 4.4.0.68 also a stop release?
– Yes. We will switch the rpm compression from xz to zstd on 4.5.0. As the prerequisite, we have enabled zstd in deltarpm and related tools in the 4.4.0 release.

So far, all Sailfish 4 releases have been stop releases. Because of this, if there is a reason to “reset” an Xperia device, please do not do it with “device reset” but, instead, re-install Sailfish - see the comparison .

Jolla Blog

The blogs about Vanha Rauma and Meet the Xperia 10 III with Sailfish OS .

Device models supported by Sailfish X

The supported Sailfish X devices are listed in this article .

Sailfish OS is available for Xperia 10 III starting from 4.4.0.64 .

The instructions for installing Sailfish OS to Sony Xperia X, Xperia XA2, Xperia 10, Xperia 10 II (mark 2), Xperia 10 III (mark 3) devices are here - covering Windows, Linux, and macOS computers.

Read this , please, to learn about the Sailfish X licence.

Release highlights

The list below contains examples of new features (and some bug fixes) added to Sailfish OS, compared to the previous public release 4.4.0.64. The release notes of 4.4.0.64 can be found here .

Phone

  • VoLTE enablers integrated for Xperia 10 II. It is disabled by default. VoLTE provider support list is here
  • Toggle added to Settings → System → Mobile network to easily enable VoLTE
  • Fix incoming voice calls not getting rejected / hangup. Both ofono-ril-plugin and ofono-binder-plugin are fixed. Thank you Damien Caliste for the ofono-ril-plugin fix

Connectivity

  • Connman security vulnerability fixes
  • Fix the issue of mobile data in some cases not working or working inconsistently with VoLTE
  • Set WLAN regdomain (country code) based on timezone if no SIM card inserted

Accounts

  • Sign-in views changed to use Gecko WebView
  • Google account created on Browser
  • ‘Update sign-in credentials’ always visible for Google account

Gecko WebView

  • Avoid sending orientation signal on scene changes
  • Fix virtual keyboard margin calculation
  • And other bug fixes

Browser

  • Programmatic preferences are written once (e.g. layout.css.devPixelsPerPx can now be changed)
  • Update google search engine opensearch xml. Find tips from the pull request

Device specific improvements

Xperia 10 II

  • VoLTE enablers integrated for Xperia 10 II. It is disabled by default. VoLTE provider support list is here

Sailfish OS Forum: issues reported by the community fixed in this update

Technical changes

The detailed changelog is here

Updating your device

Your device must be connected to the Internet and signed into your Jolla account.

Start the update from “Settings > Sailfish OS updates”. Avoid running updates on the command line, please.

We warmly recommend making some 3-4 GB of free space to the internal storage of your device ( /home ) before starting the update. Processing an OS update of almost 1 GB requires a good amount of work area. Move your pictures and videos to the SD card (or to your PC or cloud service).

This is the usual drill before attempting to update your devices:

Take a backup of your data before attempting to update your device and save the backup to an SD card or to some other off-device location (PC, your cloud service). Note that videos and images are not included in cloud-based backups. Do not reboot the device while the update is in progress. Do keep the phone connected to a battery charger during the whole process. The device screen may blank out during the update process; you may waken the display by a short press on the power key to monitor the progress.

For detailed instructions on updating software, read our help article in Zendesk.

NOTE 1:

Sailfish OS does not support downgrading. Never try to downgrade the OS as this would break your device.

NOTE 2:

After downloading an update and selecting “Install” in the pulley menu, the device runs a restart first. In the case of a device with the user-space encrypted, you will need to type the security code before the actual installation can start.

Notification concerning apps from Open Repos

The apps below have been reported to cause problems when installing the previous OS updates. We recommend that you uninstall them before proceeding to the OS update. At least, read the recent comments on those apps.

  • GetiPlay has caused problems to some users - see this post.
  • If you’ve previously installed the RIME input engine from Open Repos, please remove both that and its version of libyaml-cpp before upgrading, as the latter will cause the upgrade to fail
  • If you use Privoxy , be sure to disable it before downloading the update, especially if you have configured the https-inspection. The latest update is from September. There is no information about compatibility with Sailfish OS. See autho’s instructions .
  • If you use Aliendalvik Control , see the author’s instructions . There is no confirmation if this app is compatible with Sailfish OS 4.n. Also, there is no 64-bit version.
  • If you use Storeman, please update it to a recent version before upgrading Sailfish OS. Storeman Installer ≥ 1.2.6 and Storeman ≥ 0.3.0 have been confirmed to work fine on Sailfish OS 4.4.0. Further information is available at the OpenRepos Storeman page.
  • If you use Phonehook be careful. The latest update (32-bit) is from October 2020. The 64-bit version (Xperia 10 II) was published in May 2021.
  • If you use OKBoard (a.k.a. Magic Keyboard) , update it first to version 0.6.34 which has the fix for “Installation not complete” error. Also, read the author’s advice , please.

Known issues

Same known issues as with the previous release.

Known issues - generic

  • If VoLTE doesn’t register (Xperia 10 II & Xperia 10 III) when enabling it for the very first time, please try to reboot your device

How did the upgrade go?

  • I had no issues during the upgrade process
  • I had small issues but was able to handle them
  • I got into serious trouble when upgrading my device (please help!)

0 voters

16 Likes

Default search engine has changed on my side even DuckDuckGo is set as default one. I fixed it choosing Google, searching something and setting DuckDuckGo back.

@rainemak, these instructions for Storeman are outdated:

As the current maintainer of Storeman and Storeman Installer, I suggest to update this paragraph with recent information and links, because the current paragraph is rather misleading (content and web-links).
This is an updated version of the paragraph about Storeman, please insert it into the release notes above:

If you use Storeman, please update it to a recent version before upgrading Sailfish OS. Storeman Installer ≥ 1.2.6 and Storeman ≥ 0.3.0 have been confirmed to work fine on Sailfish OS 4.4.0. Further information is available at Storeman Installer | OpenRepos.net — Community Repository System.

4 Likes

I would like to say: Thank you Jolla! Great Job. I hope people will gain more confidence in Jolla’s commitment to supporting hardware as long as possible.

4 Likes

My phone doesn’t work anymore directly after the update. Keeps hanging on decryption unlock. I will need to reflash.

That happened to me too.
After about 2 times of shutting it down and doing cool boots I managed to login.

I suggest you try the above at least 10 times and if unsuccessful try booting into recovery mode.

I just updated it and went well. Yeiiiii, first update on the Xperia 10 III :slight_smile: :slight_smile:

Curiously, during the process, the backlighting of the screen is gone to minimum so that is very difficult to see the progress bar or the decryption unlock dialogue if you are in a well lit environment.
The same problem appears when showing the Sailfish OS logo during the restart after the update process. However, in this case the unlock dialogue is normally lit.

After the restart everything runs smooth.

2 Likes

But would that new instruction hold up for an upcoming 4.5/5.0 with unknown Storeman compatibility?
If so, the great! If not i guess they’d want/need a more generic/foolproof instruction.

Update process was flawless, thanks!

I have the same thins on Xperia 10 III. Really dimmed light on the texts during update and then the dialogues.

2 Likes

Sony Xperia X Compact: Update works flawlessly.

Sony Xperia XA2: Needs a second try to update.

Both Devices had previously 4.4.0.64 installed, both updates were performed OTA.

For the upcoming 4.5 Release i plan to reflash both Units.

1 Like

The “getting stuck at 100%” bug reappeared for me on my XA2 Ultra.
I experienced this when I updated to 4.2.0 ([Release notes] Verla 4.2.0 - #201 by Simerax).

Basically the Progress gets stuck at 100% forever. Restarting the device worked back on 4.2.0 and also seems to work on 4.4.0.68

I did not experience this problem in any release between those two.

Edit: The Device got updated from 4.4.0.64 to 4.4.0.68

3 Likes

Since I don’t see it mentioned above, has the Bluetooth connection issue with Xperia 10 III been fixed?

The installation got stuck at “100%” for me, too. I waited some time, and then force-rebooted it. Everything was fine, and then running sfos-upgrade updated two more packages:

Download (2 packages)
 - harbour-foilauth;1.1.1-1.5.1.jolla;aarch64;sailfishos-chum
 - harbour-nettiradio;1.9.2-2;noarch;store

I guess the installer got stuck on those? I do have Chum installed, and I did have a custom build of Nettiradio installed, I guess that has something to do with the hang? Should I open a bug report about this? I still have an non-updated device I can use to test any theories that come up from this idea.

For me sfos-upgrade --verify said that my system is up to date and that there are no updates. I guess it gets stuck even when the installer really did update all packages.

1 Like

I voted as having no troubles with the update, but the phone did appear to bootloop just twice then the device started.
I don’t see any menu in Settings, but then I do not have a SIM inserted, so I guess that’s why.

XA2 Ultra, no problems of any kind, not even any conflicting packages suggested for removal by the update (for the first time ever). Preparations for the update: disabling all patches in Patchmanager, removing all repos in Storeman.

Same here. But to speak of things that are great, now the VoLTE works with Telenor in Norway, it did not register using the terminal commands; now it shows true on SMS and voice :+1:

2 Likes

Update worked fine on 2 Xperia 10 from 4.4.0.64 to 68. No problems.
Another X10, after update from 4.4.0.58 to 4.4.0.68, it bootlooped 3 or 4 times, but then also went OK.

Chum doesn’t find any apps at the moment.

On the Volla phone, tried to update by cli, but no updates found yet.

edit: one day later, update on the Volla worked like a charm.
Thank you so much, to all dev’s and porters!!

What do you want to say with this?
It is like this every time, and for very natural reasons.

@attah , with all due respect, while this may be “like this” every time and for very natural reasons, this may not be as obvious for all of us, even for some Sailfish 1 veterans like myself. I myself played with community ports lately, but I am still puzzled as to how they get updates and what work exactly a porter has to accomplish to be able to offer such an OTA update. Is there some short writeup or article which could explain this to interested audience like me?

2 Likes