Beta VoLTE on the Xperia 10 III, disabled by default

I’m not aware that there’s been any announcement about VoWiFi support. You could ask about it at the community meeting, which is usually a good way to get specific answers to specific questions like this. However, since VoLTE is still beta functionality, I wouldn’t expect anything too concrete as an answer at this stage.

2 Likes
  • deleted, because obsolet -

I hope the XA2 will get the VoLTE support. Otherwise I’ll be forced to ditch Sailfish after all these years.

2 Likes

Wouldn’t it be easier to just ditch that ancient phone instead?

4 Likes

I ran the command, it did not register, did several reboots and have had it enabled for a day or so.

Using Telenor in Norway, it was working with Android

GetProperties returns:

method return time=1655818535.547857 sender=:1.11 -> destination=:1.535 serial=4508 reply_serial=2
   array [
      dict entry(
         string "Registered"
         variant             boolean false
      )
      dict entry(
         string "Registration"
         variant             string "auto"
      )
      dict entry(
         string "VoiceCapable"
         variant             boolean false
      )
      dict entry(
         string "SmsCapable"
         variant             boolean false
      )
   ]
1 Like

Thanks for reporting, if you don’t mind updating the Wiki with your findings so all info is in one place? VoLTE provider support

Do some people have collected experience with VoLTE mobility? Do thinks like call handover or fallback to 2G work reliable? Did people experience smooth calls when driving around with VoLTE enabled and so on?

2 Likes

I had some issues connecting to VoLTE. In the end I removed the SIM card and plugged it back in and after 4h of failing to register it worked immediately. I did try rebooting and other things before it. So if anyone has issues connecting, try removing the SIM tray for a few seconds.

I have the same message.
Using Tele2 provider in Lithuania.

First of all: My experience is somewhat ‘mixed’: It was not plain sailing to enable VoLTE support. As there is a setting in the mobile network section to enable ‘4G calling (beta)’, some questions came up:

  • why is it named ‘4G calling’ only, and no mention of VoLTE which is the one thing everybody looks for in that case? I’m okay with 4G calling in general, but why omit the official name of the standard behind it, especially when here and in official release notes it is always communicated as VoLTE-support? Such sudden naming changes or variations doesn’t make any sense and only lead to confusion in the general public.
  • I don’t remember if this setting in the mobile network section has been introduced in the previous version 4.4.0.64 already, but it is not mentioned in this thread here, which still is the official resource to enable the beta VoLTe functionality. And here we see commands to be issued in the terminal requiring dev-mode to be turned on. So, I asked myself: What is the actual way to enable it now? settings menu or the command?
  • In fact I did both: first enabled the setting in the menu, then enabled dev-mode and issued the command. In addition it wasn’t told that you have to do this as root, which caused some more time to figure out, since only one user mentioned it here in the end of this thread (sigh).
  • Results: I can receive calls and it seems to be via VoLTE or ‘4G calling’, as the indication in the upper right stays on ‘4G’ → which is quite good at my place. However, 2G is not. And when I initiate a call, there is always a switch to 2G, still. However, this is not usable for me at the moment because of a loss of audio during calls when established using 2G. (see: Loss of audio during phone calls [Xperia 10 iii])

So in a nutshell: Yes, it works (partly) but the way to get to this status could have been better ‘paved’. The result is fine as long as its called ‘beta’ but still: Can anyone explain why it only works when I’m being called and not when I initiate the call?

1 Like

Probably because VoLTE is the technical way of saying it, the user can not be expected to remember every complicated name :slight_smile: for example you have the option to choose 2G, 3G and 4G not GSM, EDGE, UMTS and LTE.

Was mentioned here in the 4.4.0.68 version.

The settings menu is the preferred way to go, if you have the Xperia 10 II you
can look in the VoLTE on the Xperia 10 II - filling in the gaps thread, if you want to enable VoLTE now, this does NOT apply for the 10 III explained here.

1 Like

Hi Every body does some one .know how to connect my xperia 10 iii “shh” with putty.
I try to connect with the usb cable plugged . I enable developer mode and distant connexion
I save a password.
I setup an ip adresse for usb.
When i try to connect by ssh by the address i defined before login: “admin” and i wrote my password i s the login user admin? It doesn’t work
Thank you

This is not the thread to ask that kind of questions, this is about VoLTE.

I have created one for you here: How to connect my Xperia 10 iii with putty?

1 Like

Okay, since I have a 10 iii device, what to do then, if I have such ‘one way 4G calling (VoLTE)’ as described?
My operator (o2 germany) is listed as successfully tested in the thread about vendor/operator compatibility.

1 Like

MMS is not functioning with T-Mobile

Hi @nerd7473. Would you be able to give a little more detail please? E.g. country, device, your VoLTE status, MMS settings, a link to your operator’s stated MMS settings, etc. It might help to know if others are experiencing the same.

Is it alright if I provide more info after work?

United States,
T-Mobile,
Xperia 10 iii
SailfishOS 4.4.0.68

FYI, There’s one on TM now.

Thanks. Got it watchlisted.