Announcing new installer for Storeman

Strange, just opened Storeman, everything looks as it should, sorry, false alarm, if I encounter it again, I’ll be sure to grab a screenshot.

Yes, it looks like I wrote inaccurately. The installer adds the OBS repository for Storeman.

@mentaljam - I got it, open Storeman, pull down and select search, search for something.

Not something what you could fix, but still a problem:
No integrity protection for the download:

[repositories-release]
mentaljam-obs = http://repo.merproject.org/obs/home:/mentaljam/%(release)_%(arch)/

I think either signed rpm packages, or at least an HTTPS-protected download are absolutely necessary for daily usage.

2 Likes

After I saw Storeman 1.0.0 in OpenRepos I uninstalled my previous version of Storeman, installed and ran Storeman-Installer which installed Storeman 0.2.9 and ran pkcon refresh.

Storeman says it’s still on Version 0.2.9, it shows Storeman 1.0.0 but claims that Storeman wasn’t installed, hence it doesn’t offer an update. Selecting Install from the pulley menu is followed by a never ending rotating doughnut with the text Installing but nothing happens until I restart Storeman which in return still claims that Storeman wasn’t installed.

“Storeman” page at OpenRepos now contains only the installer package which now is 1.0.1. The last version of Storeman is 0.2.9 while I’m writing this comment. The installer cannot be installed if Storeman is already istalled.

I have renamed the OpenRepos page to “Storeman Installer” to make it more clear. Also I will check why Storeman itself shows you the “Install” menu entry for the installer.

4 Likes

It looks like 4.2 EA broke ‘Storeman Installer’, the installer runs but fails silently. :frowning:

Thank you for the report, I’ll check it

3 Likes

Should be fixed now. Just run the installer, no need to reinstall it

2 Likes

Thanks @mentaljam - running the installer worked correctly, Storeman now installed and running nicely on Xperia 10 ii ~ SFOS 4.2.0.19 EA

Hello,

I’m a newcomer to Sailfish, and I have no idea how to “install the installer”.

Why is it not in the Jolla Store? Does Jolla charge for that?

Jolla Store has several strict limitations about the apps it accepts, therefore many (most) apps are only available on the 3-rd party Openrepos software repository. Storeman is a client for Openrepos (although you could access Openrepos via web browser, download apk packages and install them, Storeman makes things easier adding a Store-like interface). This is not a Jolla project and Jolla, of course, does not charge anything for it.

2 Likes

The charge question was about inclusion in the the official store, not the Storeman (Installer) itself. Ok, so there are some other reasons (for the absence of Storeman Installer in the official store).

Now how do I install it?

Hi,

To install the installer you need to:

  • enable installation of untrusted software in settings app (sorry, I don’t know the exact name of the entry in English),
  • download the installer RPM from OpenRepos,
  • open the downloaded RPM and accept the installation.

Then you can disable the untrusted software again.

@jameson gave a good answer about presence of Storeman and its installer in the official store. In short, they are not allowed due to use of restricted APIs.

Awesome!

The setting is System → Security → Untrusted software.

I launched the phone’s web browser, typed in “https://openrepos.net” (typing anything on a touchscreen makes me barf in my mouth so I didn’t type the whole URL-Path to the Installer), located the search form (with the help of a desktop browser, lol), fumbled through to the package page, tapped the noarch.rpm link, and it was smooth sailing from there.

For others: just follow the link in @mentaljam’s comment and tap the noarch.rpm link, it’s quite a ways down the page below the blurb and screenshots.

Now the question is: what did I miss, and can you make it harder to miss? I was clearly supposed to know the bit about untrusted software, and I was supposed to know that the default browser has a handler for rpm files. Before your help I feared that I had to use the terminal and add the repo with zypper… I have no problems using a shell, but typing on the touchscreen makes me want to jump from a window…

1 Like

About OpenRepos | OpenRepos.net — Community Repository System still links to https://openrepos.net/content/osetr/storeman .

1 Like

Fixed, thank you for pointing!

Do you think Storeman Installer | OpenRepos.net — Community Repository System is the wrong place to mention the setting or even briefly describe the install process so newbies like myself don’t have to search the web for hints? Something like this would have given me all the answers I was looking for and this whole subthread would not exist:

To install Storeman Installer, enable “System → Security → Untrusted software” in the phone settings, visit this page using the phone’s browser, and tap the harbour-storeman-installer-$version.jolla_.noarch.rpm link further down the page.

I get it, I’m the first one to complain so what’s the issue, right? :slight_smile: Could it be that I’m the first isolated newcomer in a long time, and all other installs are done by longtime users? I mean, Sailfish is not exactly a mainstream phone OS, I wouldn’t be surprised if 97+% of its users used it since Jolla 1 or earlier and the rest were their spouses, kids, and converted colleagues.

To add a bit more light from another angle: I do have some GNU/Linux knowledge; I wrote extensive tooling around zypper while I worked in SUSE and it still didn’t occur to me that the browser would default to installing the downloaded rpm. As I hinted earlier, I expected the installer to be in the official store, and when that turned out to be false and there was no info and the page includes run “devel-su pkcon refresh” in the terminal app, it seemed I was expected to type zypper ar https://repo.sailfishos.org/obs/home:/mentaljam/4.2.0.19_armv7hl/home:mentaljam.repo into the phone and that’s clearly ridiculous… Another reason I didn’t expect the rpm link to be the install procedure is that the OpenRepos webui I get on my XA2 with Sailfish 4.2 is clearly not meant for phones.

Long story short: it is not obvious (to everyone) and the fix is a short sentence, please add the blockquote above the the Storeman Install page, ok? :slight_smile:

Anyway, thanks for the software, and your attitude. When I was researching what to install the contrast in approaches to users between the LineageOS XA2 port maintainer in XDA forums and your writing here and elsewhere drove me to Sailfish. They owe you a chunk of that 50EUR. :smiley:

OMG, “the computer” treats links to OpenRepos as spam and hides messages that include them. :frowning:

You are definitely right! I’m so used to using Sailfish that I didn’t think about newbies. I’ve added a section about installation process to OpenRepos. Thanks again for pointing such obvious things :slight_smile:

4 Likes