S-pankki app doesn't work with Vanha Rauma update

I downloaded the Vanha Rauma Sailfish OS update today. After that, when I was checking all the apps are working properly, I stumbled with the S-pankki bank app. First, it suggested to download the new version of the app in order to use it. Did that, and when tried again, the app opened a website that said:

"Etkö saa S-mobiilia auki?

Onko käytössäsi mobiililaite, jonka käyttöjärjestelmää on muokattu alkuperäisestä valmistajan laitteeseen asentamasta versiosta?

Mitä käyttöjärjestelmän muokkaaminen tarkoittaa?

Sovelluskehittäjän työkaluilla mobiililaitteen asetuksia ja järjestelmää on mahdollista muokata syvemmältä, kuin yleisten asetusten kautta. Tätä kutsutaan myös laitteen roottaamiseksi. Käytännössä tämä tarkoittaa sitä, että laitteen käyttöjärjestelmän suojaus on purettu. Jos käyttöjärjestelmän suojaus on purettu, laite on alttiina käyttöjärjestelmän sisäisille hyökkäyksille. S-mobiili sisältää S-Pankin palveluita ja pankkisalaisuuden alaista tietoa. Turvallisuussyistä S-mobiilia ei voi käyttää, jos laitteen käyttöjärjestelmän suojaus on purettu.

Miten saan S-mobiilin käyttööni?

Saat S-mobiilin käyttöösi, kun palautat mobiililaitteeseen käyttöjärjestelmän suojauksen tai otat S-mobiilin käyttöön toisella laitteella, jossa käyttöjärjestelmää ei ole muokattu."

To put it simply, the app recognizes I’m using a rooted device, and won’t let me use the app. OP-mobiili bank app works fine. My options? I could use an old Android phone with this app (and others with same issue), but this feels a bit dumb. Is there a way to hide the rooted device, so the app won’t recognize it?

1 Like

I have the same problem with the latest S-Mobiili 2.14.0 version. Few days ago I downgraded to S-Mobiili 2.12.1 and it worked for a while, but now that version has started to require updating too. Running in Xperia 10 II.

It has not worked for me on 4.2 either since S-mobiili’s update in November. I don’t think there’s anything we can do at the moment. OP has opt to just warn about the root access but have not implemented same security measures as S-pankki.

XA2 (32-bit, update - didn’t work after updating to EA, works now)

64-bit Community port with Waydroid: Volla/GS 290 and Pinephone, fresh install

10 II (64-bit, fresh install)

The rooted phone check was implemented this year, so updates and fresh installs might behave differently.

1 Like

Can comfirm, it does seem to work now - I’m also on XA2 with Interesting, I don’t see that there had been any update to S-mobiili app and the latest (afaik about the version) didn’t work after I updated Sailfish, as it didn’t before the update either…but now it works after I reinstalled the app. Nice!

Uninstalled S-mobiili and then re-installed it. Still doesn’t work… Green screen, then redirects to website with message about rooted device mentioned above. I have Xperia 10 Dual SIM.

What Sailfish version are you using?

Vanha Rauma

Just sent a message to S-Group telling that I’ve now deleted S-Mobiili, and asked them to contact me if they some day happen to fix it, but in no other case.

I mean theoretically it should work since SFOS 4.3 in which a signed Android rom was introduced; and now it seems to work in practice as well, but I can’t really think anything crucial that I did which made S-mobiili work. I’ll try to walk back the actions I took but I don’t remeber them precisely and they just seem too random/unordered/wichcrafty to be a solution, if I’m honest.

Ok, a far fetched idea:

  1. Install an older version of the app from aptoid, 2.11.0 or maybe even older (I think I installed 2.11.0).
  2. Run the app; it will nag about an update and will not go further.
  3. Uninstall it.
  4. Install the newest one and launch.

My reasoning is that what if the app doesn’t actually check for rooted phone after it has first encountered it but reads only the state from a file that rooting was found previously and sticks with that. I suspect that uninstalling leaves relevant data which perhaps the old version overwrites because there’s no rooted phone check (prior to 2.12.0 or 2.12.1) and thus doesn’t care about the information. Of course alternatively one could try to locate all the remnant files left by the app after uninstall and delete those.

This is just a theory, but it is what I did among other random and imho irrelevant things like changing the dev password from the settings, going into the terminal, deleting everything about another nagging android app (Ticktick), logging in as devel-su and saving logs.

Hmm…well, that doesn’t really fit with my theory, now does it.

Tried it, didn’t work. :frowning:

Damn, well, it was a long shot anyways :slight_smile:

For the record, S-mobiili no longer works on my plain Android Pixel 3a either, since they got super aggressive in their check-for-root logic: even with a stock ROM which passes SafetyNet Basic integrity checks, it refuses to start if the bootloader on the device is unlocked.

For some reason the app doesn’t work for me either anymore; it just hangs on the blank green screen. I’ll check the logs (hopefully) later in the week. This has been the case despite reinstalling.

Hmm…actually it started to work again when I switched off ‘Disable AAS system Package verification’ from the settings > Android App Support. I did some testing and it seems to affect the app, can’t launch if I switch it on again. Though again switching it off and launching the app fails.

edit: managed to launch when I used wifi instead of the cell data. And now I can launch with cell data as well. Peculiar.

Just to emphasize that my issue has been that it doesn’t nag about rooting but just hangs on the screen splash screen (no logos or anything); I’ve assumed that it has been about the rooting but it might (also) be about internet connection - which seems to be a known issue.

Edit 2: I have not noticed the connection issue with any other android app though.

1 Like

It took several tries (green screen then crashing) but after disabling and enabling Android support, S-mobiili started working again on the XA2 with microG and updated S-mobiili.

The non-working 10 II has the same microG settings but both the Android image in /opt/alien and installed S-mobiili are 64-bit (the apk supports arm, arm64, x86 and x86_64).

Thanks for the report, bug created.

S-mobiili has had problems with their updates before. The November update mentioned didn’t seem to work for a lot of people (not just Jolla users). I’m hoping that they will roll back this super aggressive move as well. Have personally reverted to using S-mobiili on my work phone (Android) but it’s a pain. In general I think it’s outrageous that publishers of critical software for users like this (if the app is not working, there’s no way to do your banking at all as it’s needed for signing on to online bank as well) are essentially forcing users’ choices on devices.