[Release notes] Struven ketju

Many thanks to you our active contributors for your feedback and proposals.

Table of content

Table of content

Version history of the OS release

  • 2023-02-02: OS version was released to Early Access subscribers as an over-the-air update.
  • 2023-02-09: OS version was released to all users as an over-the-air update. Installable images are available in the Jolla Shop
  • 2023-02-16: OS version was released to all users as an over-the-air update.
  • 2023-03-20: OS version was released to all users as an over-the-air update. Installable images are available in the Jolla Shop

Stop release

This release is a stop release .

– Is also a stop release?
– Yes. We have switched the rpm compression from xz to zstd on 4.5.0. In addition, 4.5.0 moves AppSupport to Android 11 API Level. replaces and as stop releases.

So far, all Sailfish 4 releases have been stop releases. Because of this, if there is a reason to reset an Xperia device, please do not do it with “device reset” but, instead, re-install Sailfish - see the comparison .

Important notice

Please read about the upgrade of Android AppSupport before you start the OS update. This concerns users updating from 4.4.0 (or earlier) releases only.

Jolla Blog

Read the new blog about this 4.5.0 OS release, please. It contains not only technical details but also some background for the strange nickname of this release, “Struven ketju”.

Device models supported by Sailfish X

The supported Sailfish X devices are listed in this table.

The instructions for installing Sailfish OS to Sony Xperia X, Xperia XA2, Xperia 10, Xperia 10 II (mark 2), and Xperia 10 III (mark 3) devices are here - covering Windows, Linux, and macOS computers.

Read this, please, to learn about the Sailfish X licence.

Release highlights

The list below contains examples of new features and bug fixes added to Sailfish OS, compared to the previous public release All Sailfish OS release notes can be found here.

  • CLAT added to ‘connman’. This should make mobile data work in IPv6-based networks. Technical details in this post..
  • Ensured that AppSupport starts during the phone restart (if that option is enabled in the settings)
  • On a phonebook contact, tapping the birthday opens up the Calendar app to the next instance of the birthday
  • Robustness of installing apps from Jolla Store improved

Device-specific changes

  • Gemini: The button for the alphanumeric keypad added to the landscape position of a locked device
  • Xperia 10 III: a bunch of fixes to the kernel to eliminate device crashes

Sailfish OS Forum: issues reported by the community fixed in this update

Technical changes

The detailed changelog is here.

Updating your device

Android AppSupport is upgraded to Android 11

OS release 4.5.0 contains a major upgrade of the AppSupport, from Android 10 to Android 11. This upgrade brings in modified and relocated app launchers, different access rights for the data directory of the apps, optimized apps, new app icons, and other changes.

When the phone has rebooted at the end of the OS update, AppSupport will start running a migration script transforming the Android apps for Android 11. While the script is running there are no Android app icons on the app grid. This is not a defect.

If there are plenty of Android apps installed on the phone, the migration process may last for several minutes.

NOTE: If you have updated your phone to or already then the migration has been done previously.

Please wait patiently.

As soon as the new Android icons appear on the app grid, the migration is complete.

Note that it is important to keep the AppSupport installed and enabled over the OS update. Only then can the migration script do its job correctly.

If you have accidentally turned the phone off during the migration, simply turn the phone on again. The migration process should resume automatically.

OS release 4.5.0 is a stop release. This release cannot be skipped over when updating a phone from an earlier release to a more recent one.

The usual update process

Your device must be connected to the Internet and signed into your Jolla account.

Start the update from “Settings > Sailfish OS updates”. Avoid running updates on the command line, please.

We warmly recommend making some 3-4 GB of free space for the internal storage of your device ( /home ) before starting the update. Processing an OS update of almost 1 GB requires a good amount of work area. Move your pictures and videos to the SD card (or to your PC or cloud service).

This is the usual drill before attempting to update your devices:

Take a backup of your data before attempting to update your device and save the backup to an SD card or to some other off-device location (PC, your cloud service). Note that videos and images are not included in cloud-based backups. Do not reboot the device while the update is in progress. Do keep the phone connected to a battery charger during the whole process. The device screen may blank out during the update process; you may wake the display with a short press of the power key to monitor the progress.

For detailed instructions on updating software, read our help article in Sailfish OS Documentation.


Sailfish OS does not support downgrading. Never try to downgrade the OS as this would break your device.


After downloading an update and selecting “Install” in the pulley menu, the device runs a restart first. You will need to type the security code before the actual installation can start. A horizontal progress bar appears on a black background, under the Sailfish OS logo. As soon as the other end of the bar has been reached the phone will restart automatically. If it doesn’t, please wait for 15 minutes. If it is still stuck at the 100% point of the progress bar it is time to perform forced power off. Next, turn the phone on with the power key and check the OS version at “Settings > About product”.


The Jolla Shop has the images of the latest OS release only. Keep the previously downloaded images stored on your computer if you might want to reflash one of them for some reason later on.

Notification concerning apps from Open Repos

The apps below have been reported to cause problems when installing the previous OS updates. We recommend that you uninstall them before proceeding to the OS update. At least, read the recent comments on those apps.

  • GetiPlay has caused problems to some users - see this post.
  • If you’ve previously installed the RIME input engine from Open Repos, please remove both that and its version of libyaml-cpp before upgrading, as the latter will cause the upgrade to fail
  • If you use Privoxy, be sure to disable it before downloading the update, especially if you have configured the HTTPS-inspection. The latest update is from September. There is no information about compatibility with Sailfish OS. See author’s instructions .
  • If you use Aliendalvik Control, see the author’s instructions . It says there “Application has no support for SFOS 4 and later”
  • If you use Phonehook be careful. The latest update (32-bit) is from October 2020. The 64-bit version (Xperia 10 II) was published in May 2021.
  • If you use OKBoard (a.k.a. Magic Keyboard), update it first to version 0.6.34 which has the fix for the “Installation not complete” error. Also, read the author’s advice , please.

Known issues

We have relocated the known issues to a table in Sailfish OS documents.

How did the upgrade go?

  • I had no issues during the upgrade process
  • I had small issues but was able to handle them
  • I got into serious trouble when upgrading my device (please help!)

0 voters

Help articles

The Sailfish OS help articles, previously kept in Zendesk, have been moved to Sailfish OS Documents repository.


Will it be released as flashable image in Jolla store? Will test it and report back

Yes. We forgot. Flashable images are available.


Great. Update was flawless and fast. A friend with another 10 III also went through the process with no problems. CLAT ist just great.
Thanks to all the folks who implemented it. Especially @abranson
Great work!


It seems that the annoying Bluetooth boot-up bug that is present since has not yet been fixed. Has it been acknowledged or even worked on by Jolla?


Great release! My hotspot is working again on my 10III and Android apps now work with mobile data (KPN network) :smile:

Xperia 10 iii, no issues.
Hotspot is working (congstar)

Xperia 10III with Italian Vodafone SIM, smooth update, all the rest works very well, but the mobile data issue is still not solved :frowning_face: I want to really thank the developers from my heart for their tremendous effort, which I acknowledge, but I am still unable to use mobile data. I’ll post technical details on the relevant thread


Have you also switched your mobile data to only ip6? Had to update the access point accordingly

Same here. Tried that as well: didn’t work either. :frowning:

Thanks! What a nice surprise to get fixes to Xperia 10 III suddenly

1 Like

Update doesn’t start at all on my Xperia 10 III. I did download it once but only triggered the installation one or two days later.
After rebooting, the phone immediately reported that the update cannot be processed and there was a restart button flickering in the lower third of the display. With that, the current installation came up again flawlessly.
So I just thought, to download the update again. However, that doesn’t work now:
It is detected, that is available but when I want to trigger the download via the pulley menu, it says ‘waiting for connection’ and that’s it.
It stops waiting after a minute or so and then nothing happens. I can only check for updates using the other pulley menu option (which seems to work, since the timestamp of the notification below changes to ‘just now’), but that doesn’t help with the download at all.
Internet connection is fine as you can see this post, which has been created right after a new download attempt.
Any suggestions?


  1. See If it keeps failing section and do the: Cleaning up section
  2. Try the update again, if it fails do the clean up section again.
  3. If step 3 is successfull do the: Final clean up

Have Xperia 10 II Dual SIM XQ-AU52 running

When repeatedly checking for SFOS updates today, I steadily just get the message that the phone is updated.

Have I misunderstood – that the rather doesn’t apply to Xperia I0 II’s but only applies to 10 III’s?

  • or why does my phone now still report that it is updated when it is running the .18 version?

Yes, the update is also for the 10II and other devices.

Search on the forum for command line update.
Perhaps you can find some way to get more info on what is going on with yours.



Updated from 4.4 a couple of days ago. Installation didn’t complete – left it 20 mins and rebooted.

MobaXterm’s SFTP no longer works properly. All files uploaded have 0 bytes. Downloading works. I updated MobaXterm, no joy. This is my main way to transfer files (and do terminal stuff) due to lack of our own Windows tool.

Tried FileZilla on port 21 – doesn’t evern find the phone, which is an XA2 single SIM.

Enable SSH in Developer settings, and use the login with port 22 in Filezilla.

I won’t work. You have to use Site Manager (Ctr+S) and set Protocol as SFTP. Set Host only, Port field leave empty.

On trying to install ‘Textractor’ from Storeman, it didn’t install (eternal spinning wheel) and reported:

Nichts stellt ‘tesseract-language >= 3.02’ bereit, welches von the to be installed tesseract-ocr.3.05.00-1-164.1.aarch64 benötigt wird

(really this denglish words)
What can I do? SFOS / Volla

edit: tried to install tesseract manually, got this error msg:

[root@VollaPhone defaultuser]# pkcon install tesseract-ocr
Änderungen werden getestet                                                                                                                 
Schwerwiegender Fehler: nichts stellt 'tesseract-language >= 3.02' bereit, das vom zu installierenden tesseract-ocr-3.05.00-1.164.1.aarch64 benötigt wird
[root@VollaPhone defaultuser]# 

edit: got help by private mail…
pkcon install harbour-textractor command did work. Problem solved, many thanks!