VoLTE provider support

I tested Iliad in Italy on my 10 II XQ-AU52, using the new toggle in, and I cannot get it to register.

EDIT: it seems Iliad does not offer VoLTE yet, even for Android devices.

T-Mobile Poland. I have so called “Tandem” SIM cards (twin SIM cards that one can insert into two devices and use interchangeably) and I’ve just been told by T-Mobile customer support that they do not activate VoLTE and VoWiFi services for those cards. The only solution is to change those Tandem cards to a normal single SIM card, which is what I am not going to do anytime soon because I very much enjoy the freedom of being able to switch easily switch between two phones without having to swap the cards. So no VoLTE or WoWiFi for me in the nearest future.

P.S. This must be some “political” decision without any real technical background, because on various forums there are reports from people having those Tandem cards who somehow managed to have VoLTE and VoWiFi activated on them. To me, the customer support person told “I’m sorry, I really cannot do this”, which sounded more like “Sorry, I am not allowed to do this” rather than that it is not possible technically. I’ve asked him if they still offer those Tandem cards and he confirmed that they are still being normally offered, which means that they sell a product/service which is incompatible with other services of theirs.

Knowing how some call-centers operate it may help to call them a few times asking the very same question until someone activates this for you not knowing he/she is not supposed to do that :slight_smile:

1 Like

Yeah, I’ve already tried twice, no luck so far. But I’ll keep trying. I also used to have a couple of friends working in local T-Mobile shops, so it might be a good idea to check if they’re still working there. I’ve learned that T-Mobile Poland now started offering so called eSIM’s (for a monthly fee), so this is probably the only reason why they’re blocking the Tandem service (which was free of charge) from having VoLTE activated.

1 Like

I got a T-Mobile SIM today for bring-your-own-phone in USA and tried my Xperia 10 II with that. Like @sa found,

getprop persist.vendor.somc.cust.modem0



and the blinky 4G calling light . . .

@robthebold @sa
Please do the following:

mkdir -p /vendor/oem/modem-config/S264.6/
mkdir -p /vendor/oem/modem-config/S264.8/
echo -n 'mcfg_sw/generic/euro/dtelekom/vlvw/de/mcfg_sw.mbn' > /vendor/oem/modem-config/S264.6/modem.conf
echo -n 'mcfg_sw/generic/euro/dtelekom/vlvw/de/mcfg_sw.mbn' > /vendor/oem/modem-config/S264.8/modem.conf

then reboot and enable 4g calling from the Cellular settings page.

T-Mobile and US Mobile will register on the Xperia 10 II. Phone calls now work. SMS and MMS works.

To get MMS working use the following:

  • T-Mobile

    • MMS APN
    • Messages App → Settings → SMS Message Center Address: “+1206313004”,145
  • US Mobile

    • MMS APN
    • Messages App → Settings → SMS Message Center Address: “+1206313004”,145



A German config works in the US?? How many different ones did you try? Is it just generic enough?

It does indeed. I tried two total. I was using the Deutsche Telekom (German owned T-Mobile) config for NL originally and that partially works. The DE one works due to the configuration being identical for the essential IMS services I pulled from a mbn extracted from a Microsoft Lumia 950 which does register to IMS services correctly on T-Mobile here in the US.


Did you try any of the generic configs? I think we’d stand a chance of getting those merged upstream, but I doubt they’d agree with configs from other countries. Fetching configs off other phones and operating systems sounds like a lot of fun :wink:

Country: FR
Provider: RED By SFR
Device: Xperia 10 II (XQ-AU52)
Registered: ✓
Voice in: ✓
Voice out: ✓
SMS in: ✓
SMS out: ✓

In order to have it work you need to copy the modem config file of SFR (S12.1) to RED By SFR (S6.3)

mkdir  /vendor/oem/modem-config/S6.3/
cp /vendor/oem/modem-config/S12.1/modem.conf /vendor/oem/modem-config/S6.3/modem.conf

Reboot the device and voila the VoLTE work!


I would like to update this comment. Volte started working after flashing stock rom, getting volte and flashing sail again.
Country: PL
Provider: T-Mobile
Device model: 10 II
Registered: ✓
Voice in: ✓
Voice out: ✓
SMS in: ✓
SMS out: ✓

Great. I’ve tried it and it registers. One of the benefits of these MMS settings is now they can be downloaded when connected to a VPN/Wifi which will make this bug far less of a problem for me.

Thank you

1 Like

YOOOOO. works for me! on T-Mobile USA on Xperia 10 III (no need to change modem config on the mark3, just using the proxy + mmsc)

thank you @hackman238, and @sa for pointing it out!!!
<3 <3 <3


Glad it worked for you.

I circled back and tried the anysim generic for global and it did not work for T-Mobile USA.

Agreed on the mdn. It’s probably possible for me to create these mbn ELFs… but I would need to go digging for all the parameters to do it. Probably would need to figure out how to do the signature and attestation part. Might even be blocked by the need for a signing cert. I’ll research a bit.

Did you try the one that’s pointed to by the S9999 config? I think the anysim one is non-ims so VoLTE disabled.

I didn’t. I’ll give it a try.

1 Like

I’m not sure anyone’s tried that one yet, but really it must be the first one to try.

Thank you, my Sony Xperia 10 II is not “denied” network in the US anymore, with T-Mobile service. I am assuming the phone and OS are utilizing VoLTE.

It took me a multiple tries to get the ‘flashing’ “4G Calling (beta)” option [within Settings > “Cellular network” page] to be solid, and “Registered” as shown below the option wordings.

First, I did re-image Sony Xperia 10 II, and the T-Mobile SIM card didn’t register with the 4G Calling (beta) option, which I assume this option translates ‘turn on’ VoLTE perhaps,?

Second, I did replace the SIM card with another T-Mobile SIM that is already activated, and not have been used yet, and with a different number; that did help to get “4G Calling (beta)” [is that VoLTE option?] with solid and not flashing light, and phone (modem?) “Registered” to be displayed.

I suspect that the first SIM card got 'blacklisted by T-Mobile; and I say this, because the phone did place and receive phone calls and MMS messages for an hour or so, without enabling or working on anything to enable VoLTE within Saifish OS, and then all went down, with message “denied” under Select Network Automatically option under “Cellular network” page.

However, for the good of me, I am not able to get this menu on the SailFish OS; where is it at, and how to get there?

A side note, on SSH to complete the task.

I did follow the steps to create folders and so forth within Sony Xperia 10 II, via SSH with USB IP address, as the instructions in a post on this forum was greatly helpful.

SSH How-to: type CLI terminal commands into your phone from your Linux computer

However, as I was able to SSH from another PC into the Xperia 10 II SailFish OS, I didn’t know how to sudo, or be root user on the phone. It happened to be to issue this command to come from ‘defaultuser’ to ‘root’:

$ devel-su

And thus when prompted to enter root account password, enter the already set password at “Developer tools” for “Remote connection”.

And then followed your wonderful instructions, and rebooted; changed the MMS input (not sure if before or after reboot); and all is well; the phone works!

Thank you


The screen you aren’t finding isn’t part of Sailfish. It’s an application “NetMon VoLTE Checker”. It can be installed using Storeman.