Sailfish in the USA

You won’t use IP addresses, setting up APNs is a bit like a VPN. If you’re using T-Mobile or any MVNOs for them, you’ll usually be using fast.t-mobile.com or epc.t-mobile.com for the APN host. For Mint and several others, they use an APN host simply titled wholesale.
The MMSC address will usually be http://mms.msg.eng.t-mobile.com/mms/wapenc or http://wholesale.mmsmvno.com/mms/wapenc and some people will usually find IPv6 best for that.

Unfortunately right now isn’t a good time to be using Sailfish in the US as a resident or traveler. Yesterday T-Mobile shut down the last of the 3g networks here and so all Sailfish phones except the 10 iii lost voice/sms/mms service. LTE enabled shellfish devices should still be able to have data access so using an android voip app may be a work around (but still don’t allow you to receive calls or texts on your primary number).

10 iii drawbacks: no band 12 support so, limited coverage outside of urban metro areas. MMS isn’t working for some people.

Or a SailfishOS voip app if you don’t have Android. :slightly_smiling_face:

Maybe, as a temporary work around, one could set up call forwarding to a VoIP number but I don’t know how this may work with texts.

Forwarding from your primary number to a voip number might work. Not sure. Linphone might help but it is android.

You mean the SIP service behind linphone.org?
That should work with any sip client (including native Sailfish apps) not just Android.

FYI all, VoLTE calling, SMS, MMS and Data working on T-Mobile USA and US Mobile using a Xperia 10 ii. See details here: VoLTE provider support - #110 by hackman238

2 Likes

Would this script work for the Xperia 10 iii? I’m considering buying one to tinker with SailfishOS.

Additionally, what is the recommended process to procure SFOS as a US resident? I can’t seem to find a way to acquire it with a US address, but I hear of folks from the US getting it anyway.

Finally, is the US a valid “location” when configuring your device on SFOS?

You can buy SailfishOS using VPN with server located in EU. For example you can use Opera VPN.
There is no restrictions for US in configuration.

1 Like

Thanks @atlochowski

I went ahead and ordered an Xperia 10 iii and picked up a license for Sailfish X. I’m looking forward to giving this a spin.

1 Like

I got rid of my Xperia 10 with SFOS but decided to try it again but this time with an Xperia 10 iii. Had some issues loading but it finally seemed to work, however I am unable to receive texts (sending works) and unable to receive calls (but I can call people, they hear me but I don’t hear them and voicemail is wonky.) Anyone else having these issues and if so know of any fixes?

I’m with T-Mobile and am using the defaults apps the OS came with.

Oh, and I never inserted my SIM to make calls or texts before flashing the phone with SFOS. Didn’t notice that step until afterwards…oops.

I haven’t had those problems so I don’t think I can help. Maybe reflash to Android, make sure it’s the right version of Android, check out all functionality and then reflash to SFOS? Let us know how it goes.

Back on the MMS topic… I just came back from Canada on roaming where MMS worked perfectly, zero problems. Now I’m in the US again and TMobile is still giving me MMS woes. If you have gotten it working can you please post (or DM) a screenshot of your MMS settings screen?

If relevant, I’m still on .64, will upgrade to .68 next weekend or thereabouts. If the update fixed your MMS woes I’d love to hear about it.

2 Likes

You don’t say which device you have, but for me, with a 10 ii, I had the same issue you describe. After installing the .68 update and enabling VoLTE the issue is resolved. To get VoLTE enabled, follow the instructions posted earlier in this thread by @hackman238: VoLTE provider support - #110 by hackman238.

1 Like

Hey @Ras72!

I’m back, after an extended hiatus. I dropped my Xperia XZ2 and shattered it, decided to try something new, which turned out to be a disaster.

Bought a Planet Computers Cosmo Communicator chiefly because of the Black Friday sale, and quickly realized I made a mistake. The Linux support for it is abysmal, Sailfish on it is miserable, and the default Android is experience is hideous.

Fortunately, the Cosmo Communicator blew up. Shoddy workmanship or quality control led to a regulator IC detaching from the PCB and shorting out against the metal chassis, and it caught fire… so much that my only option was to throw it out of the door into the road and wait for the battery to explode. Which it did. I think it was the universe’s way of telling me to come back home to Sailfish.

I found a good deal on an Xperia XZ3, new in sealed box, and it will be delivered today. I’d get a 10iii if I could, but it’s just not in the budget currently, especially with the current state of the world.

At any rate, it’s good to be back… and I’m also pleased that people are still finding value in my posts here.

5 Likes

Update: I flashed SFOS again then enabled 4G beta and talk/text appear to be working now.

1 Like

I’m on a T-Mobile MVNO (Mint) and my MMS works perfectly, but with different settings.

Data protocol: Dual or IPv6, MMS protocol: IPv6. fast.t-mobile.com and epc.tmobile.com both work. The T-Mobile MMS message center should be http://mms.msg.eng.t-mobile.com/mms/wapenc

Those settings worked for me for years before I switched to Mint, and should still work now.

Wow! That was a disaster - almost of evening-news-making proportions!

I’m glad you’re back, though not for the experiences by which prompted the return. Seems like sailors often learn valuable lessons by living through storms on the open waters. :slight_smile:

1 Like

Welcome back, @deprecated, and what an adventure :slight_smile:

I’ve tried these settings and those on @hackman238 's 10ii post but no dice. Here’s the string I am currently getting in the MMS log, which repeats ad nauseum.

[mms-task] Send[84116] READY -> NEED_CONNECTION
[mms-connection-nemo] MMS moden path /ril_0
[mms-ofono] ril_0: not attached
[mms-ofono] Context /ril_0/context1 is active
[mms-ofono] Settings.Interface: rmnet_data1
[mms-ofono] Settings.Method: static
[mms-ofono] Settings.Address: 192.0.0.4
[mms-ofono] Settings.Netmask:255.255.255.224
[mms-ofono] Settings.Gateway: 192.0.0.1
[mms-ofono] Settings.DomainNameServers: 192.0.0.1
[mms-ofono] Interace: rmnet_data1
[mms-ofono] IPv6.Settings.Interface: rmnet_data1
[mms-ofono] IPv6.Settings.Address: 2607:fb90:4e91:6d28:xxxx:xxxx:xxxx:xxxx
[mms-ofono] IPv6.Settings.Gateway: fe80:0000:0000:0000:xxxx:xxxx:xxxx:xxxx
[mms-ofono] IPv6.Settings.PrefixLength:64
[mms-ofono] IPv6.Settings.DomainNameServers:fd00:976a:0000:0000:0000:0000:0000:0009 fd00:976a:0000:0000:0000:0000:0000:0010
[mms-connection-nemo] MMS context /ril_0 context2
[mms-connection-nemo] MessageCenter: http://mmms.msg.eng.t-mobile.com/mms/wapenc
[mms-connection-nemo] Activate /ril_0/context2
[mms ofono] Activating /ril_0/context2
[mms-ofono] ERROR: GDBus.Error:org.ofono.Error.Failed: Operation Failed
[mms-ofono] Giving up on /ril_0_context2

Thoughts? Settings ideas?

1 Like

I just setup an Xperia XZ3 on 4.4.0.68 to test (my first time on SFOS in several months) MMS on Mint (T-Mobile MVNO), and I’m getting what looks like a permissions error:

[mms-ofono] ERROR: GDBus.Error:org.ofono.Error.AccessDenied:
Operation not permitted

I’ll investigate further and see what I can uncover. I’m (historically) pretty adept at resolving MMS issues on SFOS when using US carriers, so I’ll let you know what I turn up.

1 Like