Sailfish in the USA

Thanks @atlochowski

I went ahead and ordered an Xperia 10 iii and picked up a license for Sailfish X. I’m looking forward to giving this a spin.

1 Like

I got rid of my Xperia 10 with SFOS but decided to try it again but this time with an Xperia 10 iii. Had some issues loading but it finally seemed to work, however I am unable to receive texts (sending works) and unable to receive calls (but I can call people, they hear me but I don’t hear them and voicemail is wonky.) Anyone else having these issues and if so know of any fixes?

I’m with T-Mobile and am using the defaults apps the OS came with.

Oh, and I never inserted my SIM to make calls or texts before flashing the phone with SFOS. Didn’t notice that step until afterwards…oops.

I haven’t had those problems so I don’t think I can help. Maybe reflash to Android, make sure it’s the right version of Android, check out all functionality and then reflash to SFOS? Let us know how it goes.

Back on the MMS topic… I just came back from Canada on roaming where MMS worked perfectly, zero problems. Now I’m in the US again and TMobile is still giving me MMS woes. If you have gotten it working can you please post (or DM) a screenshot of your MMS settings screen?

If relevant, I’m still on .64, will upgrade to .68 next weekend or thereabouts. If the update fixed your MMS woes I’d love to hear about it.

2 Likes

You don’t say which device you have, but for me, with a 10 ii, I had the same issue you describe. After installing the .68 update and enabling VoLTE the issue is resolved. To get VoLTE enabled, follow the instructions posted earlier in this thread by @hackman238: VoLTE provider support - #110 by hackman238.

1 Like

Hey @Ras72!

I’m back, after an extended hiatus. I dropped my Xperia XZ2 and shattered it, decided to try something new, which turned out to be a disaster.

Bought a Planet Computers Cosmo Communicator chiefly because of the Black Friday sale, and quickly realized I made a mistake. The Linux support for it is abysmal, Sailfish on it is miserable, and the default Android is experience is hideous.

Fortunately, the Cosmo Communicator blew up. Shoddy workmanship or quality control led to a regulator IC detaching from the PCB and shorting out against the metal chassis, and it caught fire… so much that my only option was to throw it out of the door into the road and wait for the battery to explode. Which it did. I think it was the universe’s way of telling me to come back home to Sailfish.

I found a good deal on an Xperia XZ3, new in sealed box, and it will be delivered today. I’d get a 10iii if I could, but it’s just not in the budget currently, especially with the current state of the world.

At any rate, it’s good to be back… and I’m also pleased that people are still finding value in my posts here.

5 Likes

Update: I flashed SFOS again then enabled 4G beta and talk/text appear to be working now.

1 Like

I’m on a T-Mobile MVNO (Mint) and my MMS works perfectly, but with different settings.

Data protocol: Dual or IPv6, MMS protocol: IPv6. fast.t-mobile.com and epc.tmobile.com both work. The T-Mobile MMS message center should be http://mms.msg.eng.t-mobile.com/mms/wapenc

Those settings worked for me for years before I switched to Mint, and should still work now.

Wow! That was a disaster - almost of evening-news-making proportions!

I’m glad you’re back, though not for the experiences by which prompted the return. Seems like sailors often learn valuable lessons by living through storms on the open waters. :slight_smile:

1 Like

Welcome back, @deprecated, and what an adventure :slight_smile:

I’ve tried these settings and those on @hackman238 's 10ii post but no dice. Here’s the string I am currently getting in the MMS log, which repeats ad nauseum.

[mms-task] Send[84116] READY -> NEED_CONNECTION
[mms-connection-nemo] MMS moden path /ril_0
[mms-ofono] ril_0: not attached
[mms-ofono] Context /ril_0/context1 is active
[mms-ofono] Settings.Interface: rmnet_data1
[mms-ofono] Settings.Method: static
[mms-ofono] Settings.Address: 192.0.0.4
[mms-ofono] Settings.Netmask:255.255.255.224
[mms-ofono] Settings.Gateway: 192.0.0.1
[mms-ofono] Settings.DomainNameServers: 192.0.0.1
[mms-ofono] Interace: rmnet_data1
[mms-ofono] IPv6.Settings.Interface: rmnet_data1
[mms-ofono] IPv6.Settings.Address: 2607:fb90:4e91:6d28:xxxx:xxxx:xxxx:xxxx
[mms-ofono] IPv6.Settings.Gateway: fe80:0000:0000:0000:xxxx:xxxx:xxxx:xxxx
[mms-ofono] IPv6.Settings.PrefixLength:64
[mms-ofono] IPv6.Settings.DomainNameServers:fd00:976a:0000:0000:0000:0000:0000:0009 fd00:976a:0000:0000:0000:0000:0000:0010
[mms-connection-nemo] MMS context /ril_0 context2
[mms-connection-nemo] MessageCenter: http://mmms.msg.eng.t-mobile.com/mms/wapenc
[mms-connection-nemo] Activate /ril_0/context2
[mms ofono] Activating /ril_0/context2
[mms-ofono] ERROR: GDBus.Error:org.ofono.Error.Failed: Operation Failed
[mms-ofono] Giving up on /ril_0_context2

Thoughts? Settings ideas?

1 Like

I just setup an Xperia XZ3 on 4.4.0.68 to test (my first time on SFOS in several months) MMS on Mint (T-Mobile MVNO), and I’m getting what looks like a permissions error:

[mms-ofono] ERROR: GDBus.Error:org.ofono.Error.AccessDenied:
Operation not permitted

I’ll investigate further and see what I can uncover. I’m (historically) pretty adept at resolving MMS issues on SFOS when using US carriers, so I’ll let you know what I turn up.

1 Like

Thanks, keep me posted! Without the deep knowledge of ofono I feel like I’m just stabbing in the dark… I’m happy to learn!

As I mentioned the other day, reflashing seemed to help, until yesterday. I missed 2 calls and several texts but as soon as I put the sim back in my iPhone viola. Hoping this will become a daily driver, someday.

Oh wow, my cosmo experience has been a dumpsterfire but not literal as this, did it happen while charging or just out of the blue? I still carry mine for longer ssh sessions from time to time but might reevaluate if the risk is worth it

2 Likes

@throwaway69
It started happening randomly while the device was on. It would hard shutdown then come back to the Planet Computers splash screen, then hard shutdown again. I went into the recovery menu and booted the stock Android slot, and it came up briefly. At that point I put it in on the supplied charger, with the supplied USB C cable and set it on a table to leave it in peace.

I left the room but had to go back in there for something, and smelled that distinct hot burning plastic smell. The nasty hateful stink… where there’s no question that something bad is happening. I grabbed the Cosmo and disconnected the charger, and it was so hot that it burned my fingertips. I could literally see smoke pouring out of the right hand side USB C port, so I grabbed it with a towel and ran for the front door. I set it on a workbench outside and saw it starting to swell.

The battery swelled so much that the back cover was almost completely free of the clips, so I popped it the rest of the way off with a spudger, in an attempt at disconnecting the battery… hopefully salvaging the device itself. At that point I saw at least two SMD components (three pin, so I think they were regulators) practically welded to the back panel, and smoke was bellowing out of the device, so I cut the (woefully inadequate) battery ribbon cable with shears in an effort to stop the short circuit, but by that time it was too far gone.

I picked it up with a shovel and carried it to the end of the driveway, and gently set it in the street. It erupted a few moments later. Catastrophic failure, one of the worst battery fires I’ve ever seen. There wasn’t much left of it, so naturally Planet Computers won’t do anything for me. $700-ish down the toilet.

I keep thinking about what would have happened if I hadn’t had to go back in that room. It absolutely would have caught fire, and very likely set my house on fire, as it was near curtains, bedding and furniture.

I will never buy or use anything from Planet Computers ever again. I take exquisite care of my devices, and the only one I’ve ever dropped was an XZ2… and that wasn’t even my fault. I stored the Cosmo in a Pelican case with custom foam, even… whenever I was traveling or not charging/using the device. I never dropped it, and it looked brand new.

Hilariously, I’m more upset with their abandonment and abysmal support than I am with the fact that the device spontaneously self destructed.

1 Like

Does not work on my Xperia 10 ii, also could never get MMS working from Mint Mobile… Switched to T-Mobile because of issues getting Mint Mobile to function at all overseas…

Is anyone interested in a SFOS USA meetup? It’s been cool to see so many sailors at the Vienna and Lausanne meetings, perhaps we could do something similar. We’re more spread out than the Europeans but we could either choose a city to meet in person (and rotate to a different region next time) or do a virtual hangout to maximize attendance.

I’m in the NE corridor and could suggest a meetup in NYC or thereabouts. I’m open to other options too. Reply in thread or DM if this sounds interesting.

6 Likes

There’s about thirty of us now in San Antonio, Texas. Two I know of in Indiana. Few people I’ve onboarded in Jersey City too. Only problem is everyone is dispersed all over the US. Maybe some sort of online group to share issues, solutions and ideas to make the platform beter suited to the NA markets.

2 Likes

I wonder if there are any Canadians here (ducks and runs!)

1 Like