Android 13 and SailfishOS on xperia 10 III

I definitely don’t have any weird tint. I probably have the echo; but presumably using a sensible volume level and having my head between the speaker and microphone works quite well (so that net complaints are like one or two). And since it was stated not to affect speaker mode, i really do wonder how people get into the situation.

I’m back on Sailfish OS, and i have also flashed my 10 III with Android 13 and ASOP binaries 11, no echo and no wierd tint on my device…


Well, contrary to you, I did have quite heavy tinting and color banding with Android 11. If updated OTA to the very last Android 11 version (which required locking the bootloader, as otherwise OTA updates are not available on Android and EMMA did not offer those latest A11 versions), those issues were somehow lighter and fixable using e.g. the 10 III Brightness Fix, but if SFOS was flashed on top of the highest Android 11 version available via EMMA, those issues were even stronger and Brightness Fix not always worked.

With Android 13 the problem is completely gone (without any sort of fix), so yes, for me it does the magic.

In my case it required keeping the volume at (or below) 70% or else people were complaining about disturbing echo. With Android 13 there is no echo regardless of volume level (and it is sometimes really helpful to be able to set the volume at 90-100% to properly hear the other person), so also in this case I can’t refrain from praising that benefit of having SFOS running on top of Android 13.

Yeah… so curious what the root cause differences are here :thinking: not sure if there’s any realistic path to finding out.

Depending on new devices compatibility, this problem might or might not fade into oblivion soon. Regardless, SFOS becoming officially “latest (currently A13) available AOSP-tested/compatible” would be nice for those not interested in switching devices.

I stated elsewhere that it’s a hardware issue for those who have it.

There are two different screens for the 10iii and one Android user got a new 10iii when he returned his for this very common issue. The A13 blobs seemingly fix the dodgy screens. I have yet to test this as I was hoping could we could replace the blobs alone.

If I find the thread, I’ll update this post.
[I don’t have the echo issue].


So nobody in this thread who has experienced echo (for callers, and when using to hands-free mode, specifically at high volumes) or seen the colour banding / green tint (especially at low display brightness) when originally using Android 11 as a base for flashing SailfishOS, has used the last Android 12 base (i.e. 62.1.A.0.675) for re-flashing SailfishOS, right? Just nosy, because that is still covered by Jolla’s statement in contrast to Android 13.
Side note: Because no issues became obvious when using an Android 13 base does not imply that there are none.
OTOH, I assume that Jolla is glad that some people test this combination.

Also, AFAICS, nobody has (just out of curiosity) tried utilising the Android 12 binaries (Lena, Kernel 4.19) with SailfishOS, yet?
Note, that one can flash and re-flash Sony’s software binaries at any time without altering an extant SailfishOS installation.
I just wonder if the Android 12 binaries make a difference and if so, for the better or worse (e.g. WRT these issues: [1], [2])?

BTW, I do not own an Xperia 10 III, but maintain this guide, hence my curiosity.


I did try to use Android 12 binaries with SFOS. None worked.

I did not try to flash SFOS over Android 12, simply because it is not offered by EMMA, meaning that it takes too much work to get it (you need to start with Android 11 as offered via EMMA and then make multiple OTA updates to eventually be offered Android 12 update). Moreover, to get OTA updates you need to relock the bootloader. Too much hassle for my liking. So, instead of that, went stright ahead to Android 13 (which is available via EMMA) and found it working just fine.


The thread I mentioned above, I perhaps overinterpreted it.

One Android update largely fixed the problem for maybe half of users. A later one fixed it for everyone. One user never had the problem. So it could have been different screens or it could have been regional variations. Sony presumably figured it out but never explained it. Given Jolla’s relationship with Sony, maybe they could ask them.


OK, so for test I flashed Android 12. Actually, it took flashing Android 11 via EMMA, re-locking the bootloader and then spending several hours applying multiple OTA updates: 3 or 4 Android 11 updates and then 3-4 Android 12 updates up to the highest available Android 12 version (then an update to Android 13 was offered, which I cancelled).

The actual Android 12 version that I have is 62.1.A.0.675 (the latest available).

I’ve called several people and they said that there is no trace of echo, even with max volume level. The display doesn’t exhibit any trace of color banding or tint, either. So those problems seem to have been fixed already in (or before) that Android 12 update. I will keep using it, as in such case there’s apparently no need to use Android 13.

Actually, I haven’t noticed any differences compared to Android 13. Neither advantages, nor problems.

P.S. I’ve used SFOS restored from rootfs/home image made using dd.


Wow, this is much appreciated! I really did not mean to trigger so much effort, but now we know for sure. I will utilise your findings for my install-guide.

Thank you very much.


You’re welcome! I actually did it out of sheer curiosity :smiley: I was also interested in checking if it would have any positive impact on 10 III’s power consumption. Unfortunately, it remains the same.

P.S. I wouldn’t bother to do it if I didn’t have the rootfs and home backup, which allows to fully restore everything with such an ease. Warmly recommended!


After 20 days of use I fully confirm that with Android 12 (62.1.A.0.675) there is no echo and no color banding / yellowish tint. Fingerprint sensor works much better than with any other Android version I’ve ever used on my 10 III.

Additionally, a small update is that both SW_binaries_for_Xperia_Android_12_4.19_v1c_lena and SW_binaries_for_Xperia_Android_12_4.19_v2a_lena binaries seem to work perfectly fine with SFOS flashed on top of Android 12 version 62.1.A.0.675. I’ve been using v2a for a few days and I haven’t encountered absolutely any problems. I think it makes a good match if both the underlying Android OS and the AOSP binaries are of the same version (in this case 12).

P.S. There are also newer Android 12 binaries ( but they do not work for me (no mobile network and no WiFi), just like Android 13 binaries.


Just as a reference, for others to understand what your point is:
Jolla recommends to use for the Xperia 10 III, but they also suggest to use Android 11 as a base for flashing SailfishOS.

The latter clearly turned out to be detrimental, but may be due to caution, because Jolla might have not tested using an Android 12 base well.

1 Like

They say: “Android version 11 (recommended) or Android version 12”. It isn’t clear why Android 11 is the one recommended while Android 12 is also suggested/allowed, without any remarks about any possible issues of using it. I guess that the only reason is that Android 11 has been tested/used by them longer than Android 12, so they keep recommending it even though they found no issues with Android 12.

Sadly, it discourages people from flashing Android 12 as a base for SFOS, which in turn prevents them from taking advantage of no echo and no color banding, both fully fixed by Sony in Android 12. As I wrote earlier, the fingerprint sensor also seems to work much better.

Considering that binaries can be flashed back and forth at literally any time without affecting the installed SFOS, everyone can easily and securely test them and see if they work OK for him, as in case of any problems they can be simply reflashed back to the Jolla recommended ones. It is as easy as

fastboot flash oem_a File_name_of_binaries.img
fastboot reboot

You convinced me. I now flashed A11 v9a → A12 v2a, and

  • everything booted up fine
  • indeed, “tint” is gone - on A11, a weird “paint blob” in any app launcher folder screen background disappeared
  • not sure about echo yet, which I never to my knowledge had (confirmed by call recipients) in A11, I’ll test this later
  • will actively monitor for fingerprint sensor quality improvements - indeed, on A11, it intermittently wouldn’t easily open lock screen, requiring a “screen off, screen on” button press dance first

Thanks for guinea-pigging this for us @wetab73 :pray: :muscle:


I got my replacement for my broken 10 III and this time I tried the latest android 13 offered by Emma (forgot the name) and then I flashed SW_binaries_for_Xperia_Android_12_4.19_v2a_lena binaries.
Let’s see how it behaves this time since I suffered with color banding and echo before!

I’m running the latest SFOS on top of the latest Android 13 and binaries for Android 11, recommended by Jolla. No issues so far.
I tried Android 12 binaries as well, but I was having issues with the camera in Android apps so I reverted back.

@lkraav, do I understand correctly, that you originally flashed SailfishOS over an Android 11 base and used the unzipped for flashing, which resulted in well visible “tint” (»weird “paint blob” in any app launcher folder screen background«) and fingerprint sensor issues (»it intermittently wouldn’t easily [recognise the finger]«)?

Then only by flashing the unzipped SW_binaries_for_Xperia_Android_12_4.19_v2a_lena you resolved these issues (i.e. »“tint” is gone« and »fingerprint sensor quality improvements«)?
I.e. you did not reflash the device to Android 12 and reinstalled / restored SailfishOS, correct?

P.S: Caveat is, it may not be working this way. For any fresh installation (or after having backed up the whole SailfishOS partition (i.e. root & home volume) via dd and additionally all relevant data on file-system level) it is definitely advisable to update an Xperia 10 III to the last Android 12 release before flashing SailfishOS!
Fully independent of that, you can then choose and / or replace at any time a version of Sony’s software binaries as you like.

I.e. you did not reflash the device to Android 12 and reinstalled / restored SailfishOS, correct?

Correct: I skipped full Android 12 flash. Performed only fastboot flash oem_a.

Tint/Blob fixed is 100% confirmed, as it’s easy to tell.

Rest of problem fixes: it’s day 1, bit early to tell. But half-day later, I don’t see any regressions at least.

1 Like

I’ve noticed some missclicks and shutter lag in camera, but no color banding, no echo so far and fingerprint works fine.

Battery looks just as good if not better.

Too soon, but the setup looks promising.