Android 13 and SailfishOS on xperia 10 III

But regarding the binary vendor, you’ve used the same Jolla’s tutorial suggests? So the latest a11 binaries?

I was able to flash SW_binaries_for_Xperia_Android_13_4.19_v2_lena.img AOSP binaries and SFOS booted and worked with them, EXCEPT for that mobile data (and thus also VoLTE) didn’t work. So I keep using Android 11 AOSP binaries (SW_binaries_for_Xperia_Android_11_4.19_v9a_lena.img).

So you did manage to flash a13 binaries but coudn’t get VolTe working and mobile data, while, flashing latest a11 binaries made them work?
I am trying that right now, first flashed latest stock android 13 on the 10 III, then flashing SFOS with a11 binaries :wink:

Mobile data and VoLTE have always worked for me with Android 11 binaries, which are the ones recommended by Jolla. I was actually surprised that SFOS boots and works with SW_binaries_for_Xperia_Android_13_4.19_v2_lena.img, but sadly mobile data did not work with those binaries. So I went back to SW_binaries_for_Xperia_Android_11_4.19_v9a_lena.img.

Regardless of the binaries version, with stock Android 13 I was able to get rid of the echo and color banding issues, so I’m still more than satisfied. Maybe Android 13 based AOSP binaries would bring further improvements, but without functional mobile data using them doesn’t make sense anyway, so I didn’t even bother to further test them.

2 Likes

Well, I’ve tried. Flashing prior to SFOS the latest A13 or the EMMA one from SONY definitely fix the green tint of the screen/banding issue, however, with my mobile provider WindTRE I’ve got Echo, putting on the loudspeaker is one piece of criminality, because it will repeat the latest thing you’ve said and will turn the volume up as crazy. Echo not fixed, but, you can use quite ok with the earpiece. To me flashing A13 binaries make WLAN broke :frowning: have to use the Jolla’s suggested ones

The 10 III echo issue is that during normal calls (via earpiece, not speakerphone) the other party (the person you’re talking to, not you!) hears echo, the stronger the higher volume level you have.

See @flypig’s post from May '22 when Jolla introduced support for the 10 III. It describes some of the issues, including the echo cancellation problem:

With Android 13 it seems to be gone, at least no one I called in the last 4-5 days reported hearing any echo, even though I have call volume set at the max level.

2 Likes

Then yes, maybe has been fixed by later version of binaries from SONY of A13, or even with A12… it has all to be tested. I’ve done some fixes to have mobile data with my italian provider, set to 3G, and I don’t have echo now. All good seems

In my case it is the stock Android OS upgrade that fixes it, not AOSP binaries. I’ve had it on Android 11 but it’s gone on Android 13, with the exact same AOSP binaries…

4 Likes

I understand, well, I’ve got some echo unfortunately, not on all calls, anyway seems pretty solid. Even if Jolla suggests to flash A11 it’s seems ok with A13 too.
And most important, it fixes the green tint of screen
Regarding how you flashed stock A13, you’ve used EMMA right? But I assume it’s ok too using Xperifirm to donwload the really latest stock version and then use Newflasher to directly flash it to Xperia… what do you think?

Yes.

I have no idea. I’ve never used them so I can’t tell…

Can we hazard a guess at what binary blobs(?) are involved with fixing the banding and try them on our Android 11 bases?

1 Like

Maybe someone from Jolla could shed some light on this? And the same for the echo issue, which seems to be completely gone with Android 13.

3 Likes

I actually had the echo bug on Sony’s latest A13 too! But just with one caller…
Doing some tests currently

Did U managed to get the mobile data working?

Mobile data does work without any problems in SFOS flashed on top on Android 13. It only doesn’t seem to work with Android 13 AOSP binaries (but I haven’t had time to test it any further, so maybe it’s caused by something else), but as those Android 13 binaries are not known to provide any benefits over the Jolla-recommended Android 11 binaries (which work perfectly fine over Android 13) then just go ahead and use the Android 13 OS + Android 11 AOSP binaries combination which has been working for me flawlessly for two weeks or so.

2 Likes

The biggest improvement to have Sailfish flashed over Android 13 base is for sure the screen.
Just put you 10 III to minimum brightness and you’ll see the green horrid screen ahahhaa
That happens on both Sony vanilla android 11 and of course on Jolla’s sailfish because it uses some android stuff to display stuff.
But I guess you can also flash Android 12 to fix that issue.
@wetab73 what you would suggest between A12 and A13? Jolla seems to say that A12 is okay too. Funny that they still suggest A11 as optimal base… with that green tint? :o

I’ve never used SFOS on top of Android 12, so I can’t say anything. For me flashing SFOS over Android 13 fixed not only the display banding/tint problem but also the echo issue, so I have no reasons to bother trying Android 12…

forgive me if I am asking a silly question, but i always understood that the issue of the system OS (11/12/13) centred around compatibility of the install routine.

and that any functionality SFOS receives from android was from the downloaded AOSP version of android that is co-installed on the device alongside SFOS itself. i.e. the process of flashing the device.

so why [should] the pre-flash system OS (13 in your case), have any effect on the presentation/effectiveness of android sourced functionality in a live SFOS flashed device? i.e. mic echo and screen banding.

2 Likes

Clearly, SFOS not only utilizes drivers / firmware from AOSP binaries but also from the underlying Android OS.

Android (e.g. when flashed via Emma) creates an AWFUL LOT of partitions, of which SFOS then replaces / reflashes only a few, whereas the whole rest remains intact, including things like baseband, dsp firmware, Bluetooth, etc.

Also, I’ve seen several times on this forum how Jolla people were saying that drivers from the underlying Android are still used by SFOS, see e.g. this post by @flypig, where when asked whether SFOS is using the installed android or completely replacing it he replies that “there are elements of Android (drivers) that are still used by Sailfish OS”.

Anyway, it is very easy to verify it yourself. While using in both cases the exact same AOSP binaries, first flash SFOS over Android 11 and note how display functionality is flawed with awful tint and banding, plus the echo issue is also there. Then flash SFOS on top of Android 13 and see how those issues are simply gone. As in both cases you’re using the same AOSP binaries and the only thing that changes is the underlying Android version, it is the best proof that it is drivers from the underlying Android what affects that specific functionality in SFOS.

3 Likes

Anyway, it is very easy to verify it yourself. While using in both cases the exact same AOSP binaries, first flash SFOS over Android 11 and note how display functionality is flawed with awful tint and banding, plus the echo issue is also there.

Like we discussed in maybe this or another thread… I flashed my X10III with A11 AOSP in Dec '23, and I don’t have echo, nor weird tinting. It was on stock A11, on the shelf for 18 months. I didn’t upgrade Android before flashing.

I’ve been wondering about tinting though… Do I maybe somehow miss it? Not sure what it’s supposed to look like, but my screen behaves perfectly normal all around AFAICS. Brightness slider is near the bottom end always here.

2 Likes