Android Mobile Data Connectivity Broken

REPRODUCIBILITY: 100% (always)
OSVERSION: 4.5.0.18
HARDWARE: Sony Xperia 10 III - xqbt52 - xqbt52 - 1.0.1.18 - aarch64
UI LANGUAGE: English (UK) (user: en_GB, os: en_GB.utf8)
REGRESSION: yes (since: 4.4.0.72 - aarch64)

DESCRIPTION:

In prevoius 4.4 and earlier releases internet connectivity on a mobile data connection for Android apps worked intermittently and often failed when moving from WIFI to mobile. Android apps simply reported ‘No internet’ or similar. From release 4.5.0.16 mobile data connectivity for Android apps, specifically on Xperia 10 III and XA2 seems completely broken. Testing with Aurora store, Whatsapp, Facebook, MS Outlook, Messenger, Slack & Telegram gives connectivity errors in every case. Restarting the network stack from settings/utilities, or android support, or rebooting the phone does not correct the problem. Sailfish apps are unaffected by this problem and can access the internet using mobile data at all times.

PRECONDITIONS:

Need Sailfish X with Android support

STEPS TO REPRODUCE:

  1. Stay in range of WIFI, use Android app requiring internet; works fine
    2.Move out of range of WIFI, so that mobile data connection in use; no internet connection possible for tested Android apps
  2. Move back into range of WIFI; internet connection for Android apps restored

EXPECTED RESULTS:

Android apps should be able to connect to the internet using a mobile data connection.

ACTUAL RESULTS:

No internet connection for Android apps using mobile data at all - completely broken.

MODIFICATIONS:

  • Patchmanager: no
  • OpenRepos: yes
  • Chum: yes
  • Other: none specified

ADDITIONAL INFORMATION:

Tested on Xperia 10 III newly flashed with 4.4.0.72 and then upgraded to 4.5.0.16 and then to 4.5.0.18.

Also tested on XA2 upgraded through all the 4.X releases incrementally to 4.5.0.16

It is understood that Jolla made some changes as a result of:

But, certainly in my case abd for some others, this seems to have made the situation worse than it previously was.
Device Owner User: defaultuser
Home Encryption: enabled


the initial version of this bug report was created using Bugger 0.9.9+git2
3 Likes

I see the same issue on my X10 III. I’m curious, did you installed Sailfish OS from an Android 12 basis?

No, it was a ‘by the Jolla book’ fresh install on an Android 11 base :

OK, so after a week of mucking around trying to fix things and multiple attempts I finally got a telnet connection into my Xperia 10 III and was able to reset the phone back to factory settings. I then re-flashed the latest 4.4 release from the Jolla website, logged into my Jolla account and did the official OTA update to 4.5 using the GUI.

So, a good clean 4.4 installation from fresh based on the recommended Android 11.4.19.v9a lena binaries with no apps other than the stock Jolla apps, no patches, no openrepos or chum, etc, and then upgraded to 4.5 via the official Jolla OTA update.

Compared to my XA2 update (above) its a bit of a disaster …

  • Android apps almost always have no connectivity on mobile data - so little change from 4.4

  • Office 365 email accounts, whilst not reporting the old ‘Account Signed Out’ error, consistently fail after a reboot or just a period of time, reporting ‘Connection Error’ - the only way to recover the situation being to delete the accounts and set them up again from scratch. So again no real improvement from 4.4. This has happened three times in the last week as the phone has switched from mobile data to wireless or vice-versa.

  • Bluetooth to car or speaker or … anything no longer works. Although bluetooth seems to be active no pairing or connection seems possible, whereas it was in 4.4

  • Videos no longer play in the web browser most of the time (e.g. BBC News), or if they do there is no sound

The XA2 has the Office365 issue, the android connectivity issue and the video playback issue, but not the bluetooth issue

So, bearing in mind that 4.5, for me, seems to introduce more problems than it fixes, maybe I should go back to 4.4 …?

The inability to play videos in tbe browser has now been fixed by 4.5.0.18, but the other problems, especially the mobile data issue with Android apps, remain unfixed and are being experienced by others. This is very frustrating as 4.5 was supposed to make things better :disappointed:

I got a similar issue and I couldn’t connect to the Internet, neither on the Android side nor on the Sailfish side. However, if I was connected to WiFi it worked.

It got fixed once I disabled and enabled again mobile data.

Nothing I’ve tried so far fixes the problem for Android apps - toggling mobile data, toggling flight mode, restarting network using settings/utilities, warm reboot, cold reboot, or just shouting at the phone in a loud voice. However, mobile data generally works fine for all Sailfish apps - though switching from WIFI to mobile data does break Exchange/Office 365 accounts permanently.

This is really getting so annoying, Android apps are useless for me right now, can’t get connection whatever i do. So frustrating!

Haveyou checked the Network settings in Android? To open the settings run

‘apkd-launcher com.android.settings/com.android.settings.Settings’

in Terminal, install the Android settings patch from Patchmanager or look for an APK which is a shortcut to the Android Settings Application.

I reported something similar yesterday, just FYI. Also network issues since 4.5, but not so severe.

Have you already tried with 4.5.0.19? If you still experience this bug with 4.5.0.19, would you be willing to provide logs?

No internet connection on Android apps when using cellular data seems to be a duplicate of this one, but on 4.5.0.19, so it seems that this is still a valid bug → added to internal tracker.

Now, it would help a lot of someone who is experiencing this could gather some logs. I would assume ofono logs (Collect oFono Logs | Sailfish OS Documentation) would be most helpful, as those should give us some hints about what’s happening on the network.

3 Likes

So, this is my experience with the issue.

I’m on a Xperia 10 III, in Italy, with Iliad as provider. I had never had any big issues related to mobile data, until recently. I roamed abroad, I used wifi networks in many different places, and never experienced any issue …fortunately. The only bug I faced was while in the USA, where I got an extra Ultramobile card that somehow did not get along well with my Iliad card, which could only work alone.

Now I cannot get Android apps to go online through Mobile data at all: only via wifi. I tried pretty much “everything” without the situation changing: I turned the phone off and on, I started only data service, I restarted ofono service, I erased its data and restarted it again, I reverted to Android (and used it to call, text, and browse), I reinstalled SFOS, and the issue is still here. BUT, the thing I remember doing before all this, I changed my SIM card: I had a normal one until recently, then I got an esim!

I know that Iliad is quite particular (data service is working fine right now, even without any input after another new reinstall: my APN is still called internet as by default, and SFOS browser works fine), but I allow myself to think this issue is somehow more related to SIM cards rather than providers, because 1) the issue was not there before the card change, and 2) other users seem to have experienced similar troubles.

I am attaching here the logs* I got through Ofono Logger. I tried to connect via Firefox to either fast.com (or example.com), first while connected with wifi, then again after turning wifi off, only with mobile data. I hope they help somehow.

*Yes, I will obviously provide the key “to whom it may concern”, if case may be.

Oh, BTW, if I decide to select the mobile network manually, I can only connect to Iliad 50, but not Iliad 88 which shows up white (not greyed out), but replies with “denied”.

3 Likes

[SOLVED, for me…]

@247 @Valorsoguerriero97 @jameson (Ciao a tutti!) and @Rikudou_Sennin (sorry for bothering you, but yes, it seems the esim card has something to do with it…):

I can now confirm that in my case the issue was related to the SIM card. I bought a normal replacement from Iliad, and now I browse with Firefox while on 4G, with wifi off, with wifi on and connected, and with wifi on but no known wifi network available (i.e. pretty much any occurrence I could think about and test).
I will keep the esim.me SIM card for travel purposes, but I understand that it is a no-no for me at home, at the moment.

A few last details:

  • as usual per Iliad, I did not need to set up anything (APN still “default”);
  • when I do NOT “select a network automatically” I only see Iliad 50 now (compared to before, when I could see both Iliad 50 and Iliad 88 in white, and TIM 01, Vodafone …, etc. greyed out).

Best to everybody!

Definitely wasn’t my case, my other SIM card (not an esim.me one) had the same trouble as well. But glad you got it working!

1 Like