Android problems after Update to 4.5

I have found another (maybe related) coincidence: the three apps that still have online connectivity (WA, Insta, Briar) are all located inside /home/nemo/android-storage/Android/media ( and no other apps). Before the update, they had their respective folders in /home/nemo/android-storage. So here’s the new question: how is the android-storage/Android/media folder treated differently from the android-storage mother folder? And if it is the (still dirty) workaround: how do I get the other apps that really need internet connectivity into the Android/media folder?

I cannot confirm this distinction.
In my case, all Android apps are in home/defaultuser/android_storage/Android/data
(none still in /nemo btw)
Most have no connection to the internet, but some (like Signal or Tor) do.

1 Like

Hm, another escalation - originally, Instagram worked although other apps already lost connection. Today Instagram wasn’t able to load pictures and videos, but displayed texts correctly. After experimetally clearing Instagram’s cache and app data, I am not even able to log in because of lack of internet. It looks like Instagram literally had some sort of tunnel which collapsed when I erased stored data :confused:

For me, with Fennec the fix was to go to about:config and disable IPv6 from the DNS. (Search for dns and it pops right up.) Thabks for pushing me to that direction!

Now, how to make Deezer work like that…

Hm, yes, that makes sense! The first AP I used had IPv6, but the second one did not. So probably the ipv6 stack is broken and nobody even noticed until now…

Yeah. Telia/Finland doesn’t support IPv6 at all over SIM card, so no wonder I can’t get anything work here…

So… if IPv6 is the culprit, is there a way to disable IPv6 system-wide (or rather AppSupport-wide)?

This is above my pay grade, unfortunately, so I would be thankful for any hint.

Certainly, but it seems that just disabling ipv6 doesn’t actually solve the problem for some reason. I tried changing the ipv6 preferences in /etc/gai.conf, in sysctl (even making it persistent by making a new file in /etc/sysctl.d), even manually flushing the ipv6 address with ip -6 addr flush wlan0, and yet the apps (including the Sailfish settings app) still can’t connect to the internet. This is very odd.


Same problem with connecting every android app here, too. I’ve got XA2 with I’m ordinary user, I’ve installed some patches from repos, nothing special …

So, any new info or maybe a solution on this issue? Just went from XA2 to 10 iii and I have the same problem in both. No android apps connectivity. It’s annoying as hell.

No general solution to this problem seems available, or at least evident on this forum. I have it on on a newly flashed Xperia 10 III (flashed to and then OTA GUI upgrade to 4.5) and an XA2, which had been upgraded through every release from 3.4 days. I’ve reported the problem in a bug report

but this hasn’t had much response.

There appears to be an outstanding problem with Android app mobile connectivity which has been around a long time now for, in my opinion, so serious an issue.

So, the state as-is looks like this:

The only Android app that kept its connection to the internet is Whatsapp, just because I didn’t clear out its cache and application data. Instagram worked until I decided to try and flush its app memory. Also, while WA still works, it has lost its connection to (so now it is unable to fetch Gifs - I don’t need it, but maybe it helps to pinpoint the culprit). Gifs received via WA messaging can be opened and sent, so it is not a data type problem but a connection-to-the-web one.

No store (Aptoide, FDroid, Aurora) works, Android App Support setting puts the “no internet” tag on every WLAN I connect to, and mobile data connection also doesn’t work (for the Android side, all native Sailfish apps are working flawlessly).

So far I tried: restarting App support, restart network (both SFOS and App support independantly), uninstalling and reinstalling Android Compatibility layer, restarting the phone multiple times, reinstalling single apps. The APN is set as it is on the SFOS layer, and tinkering with it didn’t improve anything. Also, having Tor active or not doesn’t change a thing (it only seems to affect SF browser anyways).

So far, my guesses are either some kind of pass-through issue through the Android compatibility layer (like some kind of closed ports or tunnels), changed connection/handling routes either on the connman or Droid side, or else (I mod humans, not technical devices).

I’d like the Android side to regain network access again (the printer app only needed a local WLAN connection without internet access, which isn’t possible atm, so it has nothing to do with the internet itself), that’s all.

Are there any logs I could collect and post here to help solve the problem? Unfortunately, NielDK’s compiled Wireshark application doesn’t install anymore, so I cannot rely on this like in my Jolla Phone days :confused:


Add-On: is there some kind of Sailjail/Sandbox setting for the Android App Support/Compatibility layer?

It looks like DNS issue. Have you got dnsmasq installed (e.g. from Waydroid)?
AAS from version 4.5 requires a working DNS proxy at localhost.
Fix your configuration or install DNS alternative

1 Like

Thanks for your suggestion - where do I “fix my configuration”, or do you mean the few things I can do in the settings gui? I just don’t know which configuration file handles network i/o.

Add-On: after installing DNS alternative, only Android Whatsapp and everything that uses the torified SF Browser (running through 9050) has access to the internet, nothing else (including every native store app, every native forum, etc). Which holes should I punch open, and where?

Alright, SOLVED from my side -

the problem really was dnsmasq (first from birdzhang which worked flawlessly but stopped functioning briefly when 4.5.015 came, worked again miraculously two weeks later, just to completely break down with After installing kan’s DNS alternative package, even more connections were blocked out, so I uninstalled everything related (dnsmasq, blocklist etc), and it suddenly worked (after restarting ofc.). Now I can set up a clean DNSMasq/DNS alt-pack in peace, knowing where the culprit was.

Thanks for your hint, kan ^^

Should you use 32bit phone you have to use a dnsmasq from
The one from CHUM repository doesn’t work in 32bit SailfishOS.

thank you, removing dnsmasq fixed the problem completely on my Xperia 10 Plus - Dual Sim