No internet connection on Android apps when using cellular data

HARDWARE: Sony Xperia 10 III


No cellular data on Android apps


Xperia 10 III with Sailfish X installed


  1. Disable Wi-Fi connection
  2. Turn on Cellular data
  3. The android app states that there’s no internet connection, native Sailfish OS apps (including the browser) are working flawlessly with cellular data


Android apps should work with WiFi and cellular data.


No internet connection on Android apps at all when using cellular data. So it’s not possible to use e.g. Telegram when moving out of range on a Wi-Fi network.




Newly flashed with latest


Thanks for the report. This seems quite similar as this:

Just turn on mobile data a few seconds before switching off WiFi.

Tried that already. Cellular data is always activated on my devices.

Flashed the device back to Android now as it is unusable outside my home because of that. Hopefully I will get a refund as this issue seems to be present since more than a year and I don’t expect that there will be a quick fix. I paid for Android support but it’s really unusable with that issue. The main purpose of a mobile phone is to take it outside your home and use it with cellular data.

1 Like

A lot of 10 IIIs work flawlessly with mobile data.
Is it maybe an issue with your provider?

Never had a problem with my provider. Neither with Android nor with iOS. It must be a Sailfish X issue.

With Android flashed back on the Xperia 10 III everything works perfectly.

1 Like

I am actually writing this on my 10 III,, Vodafone, Germany with Fennec using mobile data.

This must be another SF issue.

o2 Germany here. Never had problems with them.

As i don’t get any answer from the Jolla Helpdesk regarding my refund request i decided to give Sailfish X one more chance and reflashed the phone one more time. But still no change. Even the preinstalled Aptoide and F-Droid stores can’t establish an internet connection when using mobile data. Only native Sailfish apps work with it.

If i don’t get any answer from Jolla Helpdesk i will try to open a PayPal case to get my money back. Sorry guys, but 49.90 EUR for a broken Android support is wasted money for me.

1 Like

Xperia 10ii. O2 Germany. Mobile data is often brocken when switching back from wifi to cellular. The mobile network option in android settings is greyed out in that case. It may sometimes (but not always) come back when restarting alien dalvik. My workaround is to just don’t use wifi (if it’s not absolutely necessary due to low mobile coverage).

No chance on the III even when not connecting to a Wi-Fi network. In the Android settings menu the mobile data option is greyed out for me too.

And anyways, not using WiFi but only mobile data is not acceptable for me, as I don’t have a mobile contract with unlimited data.

As this issue seems to be present since at least multiple months i can’t understand why Jolla doesn’t write it on the shops page that there maybe issues with mobile data in Android apps with certain providers. If I knew that before, I hadn’t purchased Sailfish X at this time.

Did you try to restart the android app after changing from WIFI to mobile data? or restart Android support after changing from WIFI to mobile data?

Yes I tried everything, but no success.

Reboot does the trick. I always reboot my phone after switching of wifi.

1 Like

I’m sorry, with Android and iOS this step is not necessary :smiley:

I will not do any further experiments. Either Jolla provides a date until when this issue is expected to be fixed or refunds me my money.

1 Like

I would be millionaire if I could get refund from every androidOS bug

1 Like

It seems that you are not using your smartphone outside your home… otherwise you would not make such comment. And it’s not a „small bug“, it’s an elementary failure!

I would return any other software too if elementary features are not working as promised. And mobile data on a MOBILE(!) phone is elementary.

The 49.90 EUR are not for the Sailfish OS itself but mainly for the Android support. And exactly this is not working as intended. If I only want to use the Sailfish apps I can opt for the Sailfish Free edition.


So, if it is not your phone and it is not O2 Germany…
What or who could it be?

A bug in Sailfish OS as it’s working perfectly with this SIM card on stock Android.


My request for refund was denied though the product is not as described and EU law obligates them to provide a 14 days return period.

Also they expelled that there’s no estimation date until when this issue is due to be fixed. As there is no change since multiple months to up to a year, I don’t expect that there will be any fix.

I never seen a company which is such user unfriendly as Jolla and won’t recommend them to my friends. They are providing a broken product for a lot of money.

As for my next steps, I will try to get my money back through a PayPal case and maybe take legal actions against Jolla.

1 Like