Xperia 10 II + SFOS

Did you already unlock it? In that case you need to lock it before the updates become available.

Ah okay! So I need to lock it, update it, and then unlock it again?

Yes. See here for how:

Thank you for the help! Might do so once Exchange support is available, in order to flash SFOS again

Can someone already write a little conclusion on how they find the Xperia 10 II with SFOS?

1 Like

I’ve decided to split off the discussion about bugs and other problems with Sailfish on the Xperia 10 II to a new thread:


Here goes my end of the week experience summarized. Mostly it works. Phone calls, text messages and email all go through. Setting up workplace email, which was semi-automatic in Android, was still impossible. To be fair it fails everywhere else but Gmail, so it is more of an organizational problem. The harbour store seemed quite empty, installing Storeman from was easy though. Took me a while to realize that only the newest applications are for aarch64 and can not be installed. Installed a black & white ambiance to safe battery on OLED. Also BatteryBuddy to keep it from charging over 70%, mine has newer gone below 40%.

The browser engine is still too old for most modern websites but for many things that I do it is passable. Most streaming services will fail, but our national broadcasters services work. Maybe it is a good while to reconsider those subscription services. The speakers sound different and not in good way, but I can live with that. 21:9 aspect ratio isn’t as widely used as it is on Android but who cares. Display burn in is something that I wonder about, like running DisplayTime program nightly would be cool, but likely a bad idea.

Nothing I’ve encountered seems to be a problem specific to this model. What works:

  • Everything except
  • NFC is something that I did not get to pass on the Android side hardware testing and have not tried it here either, Matkakortti is not aarch64 yet. Payments wouldn’t work anyway.

Having this time without online service providers apps has me pondering that is running Android something that I want to add to this? It be quite happy with just flatpak support. But I’m likely going to get a license anyway and if it is not my cup of tea give it forward. Well if it’ll get GCam working then its a must have.


Community member @leszek has uploaded a video with tests of the device’s main camera under Sailfish OS:


All 4 cameras seem to work ok under SFOS.
But I had to install piggz-o-vision and set the camera ID in /usr/share/harbour-advanced-camera/qml/pages/CameraUI.qml = 1

(for bottom camera)




Nice! Beeing unfamiliar with this app: is it a permanent configuration, or do you have to adjust the config whenever you want to use a different camera?

1 Like

Well, I’ve hard coded that for me because editing program code while walking is hard :grinning:

I may build something more flexible (like a dropdown) later.


I ended up replacing: =
=== "primary" ? "secondary" : "primary"

if (parseInt( + 1 == = "0";
else = parseInt( + 1;


This cycles through all available cameras when the “switch camera” button is pressed.
(back camera needs a restart of the app for some reason)

Maybe not very convenient but good enough for me.


With WiFi enabled, the battery seems to go down rather quickly (similar to the Jolla Tablet, which, with WiFi enabled, also has a tendency to drain its battery in a single day). With WiFi disabled and minimal usage, my battery dropped 6% over the course of 12 hours.


I do not remember the Jolla tablet battery to go down that quick.

And I would say it is not the device itself but maybe something in the lastest (4.1.0) release?


Weirdly my battery life has been quite satisfactory. Days go by and there’s still charge. Now admittedly it’s not in very active use right now but WiFi is on and mobile Internet. Just automatic email sync is off.


Cant talk about the 10ii but -in general- what is an absolute pig when it comes to depleting the battery is the browser.

If you don’t browse the internet the battery is fine.


Curiosity got me and I checked out if this code would also cycle through the 2 “selfie” cams on the XA2 Ultra . . . No, it does not. In fact it only cycles thru the main camera and nothing else. :frowning: My QML skills are still very poor, so I haven’t tried anything else.

I’m eager to get SFOS on the 10 II, and maybe see if I can get it to simultaneously (or nearly simultaneously) take 3 images with the 3 main sensors. I don’t know what good it would do, but something suggests that I should try.


On SFOS 4.1 ?
Does the screen go blank when you try to switch cameras or does nothing happen at all?

4.0 I haven’t upgrade to 4.1 yet on the XA2.

On clicking the camera change button, the image goes black then returns to the main camera (without a second click).