Xperia 10 II bugs

This is just meant as a very general thread for reporting problems you encounter with (the first release of) Sailfish on the Xperia 10 II, to find out if others have also encountered those problems and to figure out what’s causing them or how to reproduce them, in order to submit useful bug reports. Some of these may not necessarily be unique to the Xperia 10 II. For general discussion of Sailfish on the Xperia 10 II, see this thread.

I’ll start off with a couple of problems I’ve come across so far:

  • The OOM killer seems to have gone haywire today and started killing pretty much everything, despite the device possessing more than enough RAM to run all of my (mostly lightweight) applications.

  • Perhaps related to the above, a little later, I was unable to unlock the device with any fingerprint, it appeared as though the fingerprint reader was unresponsive. Going into Settings -> Device Lock, all of my fingerprints had disappeared. I selected ‘Add Fingerprint’, but got an error about there not being enough memory to save the fingerprint. Then, the old fingerprints reappeared and the fingerprint reader was responsive again.

7 Likes

I pass on my impression:

  • battery is not so good for me, last night I lose 20% (WIFI, phone on, no data connection)
    -System seems sluggish
    -Some apps cannot be installed

I reflashed the phone today, the battery is still bad, the Android battery is very good

These are my first impressions

I have a problem charging the phone.
Just one out of three different wall plugs (did not use the sony wallplug, but different one’s that always worked with all my devices) is actually charging the X 10ii.
Esp. a quick charge wall plug I often use (in the past e.g. for Xperia X, Xperia 10+) did work with Xperia 10 ii before flashing SFOS, but now, just the tone after plugging in is to be heard and … nothing happens.
So the tone indicating plugging in is no guarrantee for successful charging…one have to observe the battery pecentage to make sure it’s actually charging!
That’s a No Go…really

update
As usual in those cases it seems to be the cable is the phones enemy … or vice versa.
Some USB-C cabels simply don’t work as they should (and actually do with other phones).

next update
Even quality highspeed USB-c cables don’t help.
Only the crappiest old cables I could find do charge the phone.

My take so far for X10 II:

  • No major bugs specific to the device. There are the usual SFOS ones, but the device version is quite fine. Battery drain is good and in par with what I got in Android (albeit I don’t use 4G data, only WIFI, but I have 2 4G sims in it).
  • The device shape is great too (a bit tall to my taste). It has the same width as the Xperia X, and the iPhone S2 2020. So great to hold in hand, but like 1cm taller than both devices.
  • Everything seems to work fine. Latest SFOS EA fixes many bugs I used to see (in calendar, general usability, etc.). I’ll be using the phone when final version released as my work phone, and hopefully in a few weeks/months if all is fine, I’ll put my personal sim in it!

Now, I haven’t used it extensively. I had a few phone calls on it, and no issues at all in losing audio/microphone in calls as the bugs in XA2. So that’s great, hopefully the bug won’t appear randomly, but so far it’s working fine.

4 Likes

I have seen and solved a similar issue in the past:

Might want to check your calendar databases, maybe it’s the same thing.

I don’t use automatic backups, I don’t have any online calendar accounts and my calendar database only contains a fairly small amount of events, so unfortunately I don’t think our problems have/had the same cause. I experienced the OOM issue again, and this time I believe it’s caused by a bug in the Camera application, where sometimes if you snap a picture and immediately go to view it and try to zoom in, the application freezes and causes the OOM to kick in.

Yesterday I lost around 20-25% battery overnight.
Before that, I was losing 4% overnight.
Weird :thinking:
I’ll see if that’s just one night. Maybe an edge case of some background service or maybe a bug.

Turning the screen off often appears to be delayed by a second. This makes it possible to accidentally execute an unwanted action. The problem seems to be the same whether you lock from the top menu or by pressing the power button. I’m not sure what the underlying factor could be, since it’s happened both when I had many applications open and without any applications open.

In my case the registered fingerprint was lost and I had to re-register one today. Since I have been doing several re-starts SIM swaps and also the phone died from battery at one point I can’t pinpoint at which point this happened and what caused the issue. I will be keeping an eye on it now in case it happens again.

Last night it was fine, also around 4% battery drain.

Maybe Battery Buddy @direc85, as I’ve installed it the night before, test it, then delete it. Maybe some process or service kept running and consuming the battery.
Reinstalled it yesterday (and disabled every option in it), and battery drain went back to normal. So that might be it (or just a coincidence).

On Xperia10II running 4.1.0.24 after re-booting Mobile Network greyed out, have to change to 2G and signal comes back and then can alter to 3G as in marginal rural area poor 4G coverage.
Has anyone noticed after Signature spoofing now get icons such as FakeStore from microG showing?

For some reason I don’t get notification sound when receiving Telegram (Android) messages even though there’s the same notification bar appearing as Whatsapp for instance, and works with Whatsapp. Anyone else experiencing this or similar?

Backup from my Xperia XA2, didnt went smoothly. It faild at notes and so every backup after note failed. Had to remove all my notes make a new backup and then it was a sucess. It did also mess upp gallery app. New pictures taken with phone never came visible in gallery. Reebot fixed that. Nextcloud that was visible in gallery is still missing

Solved at [3.4.0 onwards?] Restore backup fails when restoring notes (here: from Xperia X to Xperia 10 II )

1 Like

Anyone have an issue with photos from Android apps (open camera, signal), not showing up in SFOS gallery ?

I installed Simple Gallery Pro from F-Droid, and I can see all my photos and videos (from Android apps and SFOS).

I checked the tracker, and it does list DCIM and Pictures in Android folder, did a reset too, but still only SFOS photos appear in the default gallery.

2 Likes

Xperia 10 II doesn’t find my wifi on channel 13. (xa2 finds it)

I changed to a wifi on a lower channel. Sailfish apps connect via wifi, but android apps can’t connect anywhere. Mobile data works with android apps, but wifi doesn’t.

Edit: Same situation as PeperJohnny said, restarting android fixes the wifi problem for a while. The problem seems to occur quite often.

I had luck with restarting the android layer every time it won’t work over wifi.

Yes my photos from Advanced Camera don’t seem to show up in Gallery. (Xperia 10ii running 4.1.0.24).

1 Like

Other than the fingerprint reader, I’ve been having a fair amount of trouble with the android notifications.

  • Ever since I changed the notification sound of one of the android apps none of them have notification sounds. Vibration works. (uninstalling the app, resetting doesn’t change anything)
  • I’m not sure if they ever did, but the notification icons for android apps don’t show up on the lock screen either.

+1 for @orangecat issue, I haven’t even realized it yet, but indeed android photos don’t show up in the gallery.

1 Like