VoLTE provider support

Thank you, my Sony Xperia 10 II is not “denied” network in the US anymore, with T-Mobile service. I am assuming the phone and OS are utilizing VoLTE.

It took me a multiple tries to get the ‘flashing’ “4G Calling (beta)” option [within Settings > “Cellular network” page] to be solid, and “Registered” as shown below the option wordings.

First, I did re-image Sony Xperia 10 II, and the T-Mobile SIM card didn’t register with the 4G Calling (beta) option, which I assume this option translates ‘turn on’ VoLTE perhaps,?

Second, I did replace the SIM card with another T-Mobile SIM that is already activated, and not have been used yet, and with a different number; that did help to get “4G Calling (beta)” [is that VoLTE option?] with solid and not flashing light, and phone (modem?) “Registered” to be displayed.

I suspect that the first SIM card got 'blacklisted by T-Mobile; and I say this, because the phone did place and receive phone calls and MMS messages for an hour or so, without enabling or working on anything to enable VoLTE within Saifish OS, and then all went down, with message “denied” under Select Network Automatically option under “Cellular network” page.

However, for the good of me, I am not able to get this menu on the SailFish OS; where is it at, and how to get there?

A side note, on SSH to complete the task.

I did follow the steps to create folders and so forth within Sony Xperia 10 II, via SSH with USB IP address, as the instructions in a post on this forum was greatly helpful.

SSH How-to: type CLI terminal commands into your phone from your Linux computer

However, as I was able to SSH from another PC into the Xperia 10 II SailFish OS, I didn’t know how to sudo, or be root user on the phone. It happened to be to issue this command to come from ‘defaultuser’ to ‘root’:

$ devel-su

And thus when prompted to enter root account password, enter the already set password at “Developer tools” for “Remote connection”.

And then followed your wonderful instructions, and rebooted; changed the MMS input (not sure if before or after reboot); and all is well; the phone works!

Thank you


The screen you aren’t finding isn’t part of Sailfish. It’s an application “NetMon VoLTE Checker”. It can be installed using Storeman.


I’m having issues with mobile data and VoLTE on a Free Mobile (a French carrier) Sim card.

Basically, on Android mobile data is working great (no VoLTE because phone not supported by carrier).
However, on SFOS, mobile data is not working at all (whether VoLTE is activated or not).

Phone calls, SMS and even MMS works, so I’m wondering if it’s related to VoLTE?

Can anyone with the same carrier please confirm if they have a similar issue?

I have no problem with mobile data on the Xperia 10 ii on the Free network in France.

1 Like

OK, got everything working fine until this afternoon and suddenly network status on T-Mobile US has changed to “denied”! So not back to square one, but to square less than zero, since before I had VOLTE voice working at least I wasn’t denied. Not sure what I’m gonna do now.

Ed. It looks like it’s maybe back again, and then disappears. Signal strength is ok, and I’m in the same place. Please don’t mess with my head, T-Mo.

Ed x2. Well, now it’s Network status is now going from “Searching” to “Denied” every time I start up the phone with the T-Mobile SIM. Not good. Anybody got a suggestion?

Thanks. I’ll try to get my hand on a different carrier Sim and see if that’s related to the 10 III, volte, my line, or bad flashing.

I’ve seen this happen before. It’s not related to the configuration and T-Mobile USA isn’t denying 10 II or 10 IIIs by whitelist. The first thing I would try is changing the SIM out for a newly issued one. Basically, ask them for a replacement SIM and they’ll send one. It’s also important to register the new SIM using the target 10 II. Don’t set it up in another phone then move it over. That process works reliably on the ATT networks, but not the T-Mobile ones- it’ll be hit and miss. There’s some difference in how they track ICCID and IMEI relationships.

1 Like

Ooops. I just did get a new SIM at a T-Mobile storefront. Tried it in the 10 II in the store with no luck and went home to sulk. Never got past Searching/Denied even after rebooting a bunch of times in the store and at home.

Then I put the SIM in the pinephone and it started getting service within a minute. Good news, got a working SIM. Bad news, in the wrong phone now.

(Dumb story: the biggest nearby T-Mo store with phone repair is closed for remodeling. I get to the door, and there’s a QR code to scan for other locations. That’s nice if your phone’s broken. . . . :roll_eyes: )

(post moved to the correct thread: VoLTE on the Xperia 10 II - filling in the gaps - #55 by jenix)

I have tested Volte in xperia 10 II with two providers. Based on the information I gathered from Play customer service, they do not support 10 II and 10 III (which was already reported in the table). Polkomtel however, needed some manual work with creating modem.conf, but after that works flawlessly.

Country: PL
Provider: Polkomtel
Device model: 10 II
Registered: ✓
Voice in: ✓
Voice out: ✓
SMS in: ✓
SMS out: ✓

Country: PL
Provider: Play
Device model: 10 II
Registered: ✕
Voice in: ✕
Voice out: ✕
SMS in: ✕
SMS out: ✕

Swapped the Sim with another Sim to test. On Android free is working and the other one (sosh) working on Sailfish.
Got the free mobile Sim back to Sailfish and it’s working fine now. Weird but 4G is good now.
Though VoLTE not working (didn’t work on Android Xperia 10 III either but Sim volte worked on other supported Android phones by Free).

I did activate/test a new T-Mobile (US) SIM card into Sony Xperia II, SIM card did work as 4G (VoLTE); and then transferred t to Sony Xperia III, and SIM card still connecting to 4G.

However, the 1st SIM card failed on Xperia II; and did replace the SIM card at T-Mobil Store (3rd card); and that failed too, with “denied” message under ‘Cellular network’ page at SailfishOS.

Any suggestions to overcome this VoLTE issue with Sony Xperia II and US T-Mobile?


1 Like

@X0X0 That’s very odd. It does sound like that IMEI is on a list /w T-Mobile. Can you run an IMEI check to make sure it’s not flagged as stolen, lost, salvaged or something? I can’t think of much else to try besides grabbing a US Mobile SIM and trying that T-Mobile MVNO. I largely expect the same problem though if the IMEI is on any of the “naughty” lists. Also, just to confirm, you’re using T-Mobile prepaid and a prepaid SIM, correct? Post paid accounts and SIMs won’t work. I don’t know why, but it’s purely account controls and nothing technical.

@robthebold Hum. X0X0 found something similar. That’s very odd, I have now three people with 10 II on T-Mobile prepaid and four on US Mobile. One question I might ask is if you’re using T-Mobile prepaid or a postpaid account. This will absolutely make a difference. If you’re using T-Mobile prepaid (and a prepaid SIM) then purely out of curiosity, can you request a free SIM kit from US Mobile (use checkout code FREESIM)? I’m curious if you can activate a basic account (like $12 I think) and get that to work. If it registers to US Mobile successfully then there might be something else to address with T-Mobile. If it’s denied on US Mobile also then it’s on a “naughty” list.

It’s T-Mobile Bring-your-own-device prepaid plan with a prepaid SIM.

Wikipedia says that US Mobile uses T-Mobile and Verizon – do you know which you’re getting when you sign up?

So I finally got Sailfish OS flashed on my Xperia 10 iii and, aside from MMS, everything else seems to be working great, including VoLTE.

I went into my MMS settings and set everything to, but still no dice.

I’m on T-Mobile US, specifically using their T-Mobile Connect $15/mo plan. Thoughts @hackman238 ?


For me on Xperia 10 III (62.0.A.3.109) it can’t even register.
Without config changes or even with: VoLTE on the Xperia 10 II - filling in the gaps - #57 by JacekJagosz
Registered: ✕ - fixed that with help from archon: VoLTE on the Xperia 10 II - filling in the gaps - #58 by archon
Country: PL
Provider: Polkomtel
Device model: 10 III
Registered: ✓
Voice in: ✓
Voice out: ✓
SMS in: ✓
SMS out: ✓
**** Requires modem.conf mapping. (only on X10II?)
And also requires sending an SMS to activate VoLTE service, as archon said.

Tried a few more times, to no avail. It looks that it is really impossible to have VoLTE activated on Tandem (twin SIM) offer in T-Mobile Poland. All customer support people say that it can’t be done, attempts to activate it via SMS or via their online portal result in various errors (e.g. “Not an USIM card” while it is an USIM card, or “Temporary error, try again later”).

Well… having those twin “Tandem” SIM cards is so convenient and useful that I will have to give up on VoLTE for now, i.e. for as long as voice calls can still work without it. But I still can’t comprehend how can they simultaneously offer two services incompatible with each other.

So for me:

Country: PL
Provider: T-Mobile Poland - Tandem (twin) SIM cards
Device model: 10 III
Registered: ✕ (because they refuse to activate the service at their end. The only solution is to switch to a normal, single SIM card and only then have the service activated).

  • Country: DE
  • Provider: 1und1
  • Device Model: 10 II
  • Date tested: 2022-07-30
  • Registered: ✓
  • Voice In: ✓
  • Voice Out: ✓
  • SMS in: ✓
  • SMS out: ✓
1 Like

If VoLTE can’t register (the switch keeps blinking forever, also the terminal-command shows not registered), this means that my provider (Country AT, provider HoT) probably doesn’t have VoLTE enabled, right? Should I add this to the Wiki then with everything marked as not working? Because it’s probably not really an issue from Sailfish