[Release notes] Suomenlinna 4.3.0

I will, once I figured out what I understood wrong. Most specifically, I’m still confused by the “dependency pairs”, and the “mutually exclusive dependencies”. I think it would help to have some real examples (without the and placeholders) worked out that clarify your terminology.

Thank you, very nice of you :innocent:

That’s good to know, but I would’ve liked that you had found something :sweat_smile:

Ultimately, I really wonder why it would have worked it the first place. Zypper doesn’t seem able to cope with this: it wants to use the highest version of a package no matter what, it seems. To me, that would mean this property trickles down onto PackageKit and onto Storeman. So unless Storeman has some additional logic in place, it shouldn’t have been possible in the first place.

Ok. I will keep on publishing the packages like I do now, and put a note on the OpenRepos page with some zypper instructions. When Chum comes out with a GUI, and when Jolla decides to fix their cargo build, I will also move to Chum with Whisperfish. Separate repositories for every SailfishOS version is the better approach anyway, given that all normal Linux distro’s have that approach.

EDIT: would it maybe work (from within Storeman) if I made a second “application”?


But you did it the way I meant it and it is supposed to be.

Yes, they all use libzypp, which uses libsolv as its dependency resolver.
But it was working fine for a year (and not only for crypto-sdcard, also for Storeman), hence I assume some update of libzypp / libsolv broke it.
Edit: Looking at the dates, that cannot be the case: I detected the change in behaviour mid 2021 on a device still being on SFOS 3.2.1 (from December 2019; the libzypp RPM was updated from v17.3.1 to v17.9.0 in SFOS 3.2.0 in November 2019), so that does not tell any conclusive story.

Still the RPMs created this way will only install on the intended OS releases, but that has to be performed manually for older OS releases.

And it IMO it is supposed to work this way, but obviously needs a proper bug report at https://github.com/openSUSE/libsolv/issues
I think the observations we made here and at Storeman issue #108 are sufficient for this.

I eventually experience the same as Samule: on a Xperia x f5122, all went apparently well, in spite of showing many system packages as being in the way if the upgrade but now, few seconds after each boot, it reboots on and on. There is not enough delay to analyse.
Unfortunately, that is the 2nd upgrade with a problem: 4.2 forced me to reinstall from ground up. Let’s hope I will avoid that.
Has anyone a clue how to stop that boot loop else than reinstalling fresh?

Me too, Xperia X. Ran ‘jolla-camera’ in terminal and got

[D] unknown:0 - Using Wayland-EGL
jolla-camera: /usr/share/droidmedia/hybris.c:53: __resolve_sym: Väite ”ptr != NULL” ei pidä paikkaansa.
Aborted (core dumped)

Claims that ptr != NULL is not true.


And a nice workaround

Maybe some insights, @Jolla?

1 Like

Thanks for flagging these posts here @peterleinchen. There’s a relevant comment from @abranson in the thread you reference on this. It would be good to please refer to his comment before jumping straight in and trying the workaround. It’ll help us diagnose the problem and may also prevent further issues down the line.


The SIM Application Toolkit icons appear to be broken in the UI after the update. Logs show QML errors.

I was able to run a SIM application manually from the command line:

dbus-send --dest=org.sailfish.simkit --type=method_call / org.sailfish.simkit.show

There is also another method signature which takes a list of strings, presumably the application name(s).

Reference: D-Bus APIs - SailfishOS Documentation

I just updated
When I try to enable the internet I see “Connecting” then “Limited connectivity” then back to connecting!
My phone didn’t do this prior to the update, anyone else seen this?

With this new version, I have the following regression:
When starting the camera from the lock screen (while the phone is locked, i.e. you’re asked the pin to get out of the lock screen), and you record a video, the screen will turn off and the app will stop the recording after a bit more than 30 seconds. (I have to touch the screen to prevent this.)
Anyone else have this issue?
I have a Sony Xperia XA2.


Yes, confirmed.
And created a bug report

1 Like

Try version 3.11 or 4.16. Works for me but there is a slight audio delay with the sound.

On related news, HBO Max doesn’t work either. It starts playing the video, but there’s no sound and the screen is black. Subtitles and controls show up tho :grin:

Xperia 10 Single SIM

Yesterday, my system crashed so I had to reflash the phone.
With the new flashed phone (not updated from previous version) I saw some interesting things I want to report here.

First a positive thing (the only one): It’s now possible to switch off the phone. (before, it did always reboot immediately so that it was not possible to switch off the phone)
edit: this was only one or two times!

Very strange is the SD-Card access: In the / (root) directory is a symlink to /storage/self/primary . Clicking this symlink reports “unknown, link target not found”.
A directory /storage does not exist.
In /mnt is also a symlink to /storage/self/primary , also does not work.
The directory /media , previously used for the SD-Card, is empty.
The “real” and working path to the SD-Card is /run/media/defaultuser/0123-4567 .

SD Card data is found by Gallery app and Camera app. Other apps, I don’t know at this time. But SD card is not accessible via Dateiverwaltung in a normal way without searching deep in the file system and checking things a user would normally not expect.

Opening PDFs with File Browser sometimes possible, sometimes not. Going to the PDF and tapping on it leads to a page with the file properties and a thumbnail icon that shows the PDF correctly. Tapping the icon leads to error message “Page could not be loaded”. Tapping on the white dot in the upper right corner of screen does the same. Pull down memu + open leads to Internet browser tries to open the PDF. Browser reports then “file not found”.

This is - edit: unusable for me (edit end), so I will flash SFOS 4.2 again because I want also use the phone and not only make experiments with it.

1 Like

XA2 Plus Dual SIm
/media/sdcard is symlink to /run/media/defaultuser (no other file in /media)
/sdcard is symlink to /storage/self/primary which doesn’t exist
/mnt/sdcard is symlink to /storage/self/primary which doesn’t exist

1 Like

Good luck with that approach (says the guy still on 3.2.1 :frowning: )
And be cautious with such words like ‘absolutely’… :wink:


Thank you for your confirmation and the workaround

Out of curiosity I now reflashed one of my Sailfish phones (Xperia 10 / Dual SIM) with SFOS again and was more careful. Now it works much better and I want to report what I have done.

  1. Flash phone without inserted SIM and memory card.
  2. First boot without inserted SIM and memory card.
  3. Go to language setting, first app choose, download and intro. (with WLAN connection)
  4. Then I opened every single app one after the other and gave every app the required rights.
  5. Switch off (as good as possible)
  6. insert SIM and memory card in the right moment. (critical because phone still can not turned off - but immediately reboots)
  7. Phone reboots
  8. Installed additional apps & storeman.

Now working fine:
Torch, reading PDFs via file browser, playing MP3 audio (Unplayer) and MP4 video (LLs vPlayer).
For the SD card access I made a symlink to /run/media/defaultuser manually and it works. So this is also OK.

It seems there are some differences between an updated system since 3.3 and a fresh flashed system…

edit: At this moment, after everything is ready installed, it is now possible to switch off the phone without immediately reboot. :heart_eyes:

edit: …only on battery. Connecting the charger causes power on of the phone.

Take a look at the P.S. here to understand why these SD-card symlinks are fine and correct: They are only relevant (and point to something extant), when looking at them from inside AlienDalvik.

1 Like

As a novice jolla-user.
How do I remove ‘git-minimal’ and ‘gittin’ ? Removing means uninstall, right ? Terminal ?

Will be fixed on OS release 4.4.0.

You can safely ignore the warning on gittin and git-minimal. Simply, go ahead and install Those two packages get removed automatically. In other words, the warning is unnecessary.