[4.3.0.12] Jolla camera (also torch) does not start at all - as well as videos do not play

To be honest:
I was really thinking of trying out 4.3.0 on my daily driver and risk the update limbo (or even have problems like this).

BUT this one is another proof for me to stay on 3.2.1 then if it is not solved in the public release (which I do not expect to happen :frowning: ).
And being for 3-6 months without a cam is not what I expect from an OS that should simplify and enrich my life.

1 Like

Don’t mean to be mean, I appreciate all the hard work that’s been going into the OS, but I also have to be honest, and a bit off topic. The quality of the produced images on my XA2 isn’t of the highest order. I can’t really compare it to what Android did (I bought the phone just to install Sailfish OS, which I immediately did, didn’t even bother with Android), so, can’t quite rule out that the quality is simply down to (poor?) hardware (that I highly doubt, being Sony sensor and optics, but it is possible).

1 Like

I can’t confirm the issue on my end (Sony XA2, full license), I just updated from 4.2 to 4.3 and the camera app is still running fine, and so does the flashlight. Could this maybe be affected by differences in the vendor image/firmware version? V17 being the latest for the XA2, I’m still on the older v16, however.

1 Like

I have the same problem I stop working after upgrading to 4.3, I have Xa2 plus H4493, Android camera if it works

I’m on firmware version v17, nevertheless, I don’t have any problems with camera app / flashlight after the upgrade (XA2 paid, no EA but regular upgrade from 4.2. to 4.3).

1 Like

Problem is with missing adaptation-common repo.
Here’s the fix, root privs required:
devel-su
ssu ar adaptation-common https://releases.jolla.com/releases/4.3.0.12/jolla-hw/adaptation-common/armv7hl/
ssu ur
zypper ref
zypper dup

Update:
You may need to run first, if getting error messages on ssu ar:
rm -f /var/cache/ssu/features.ini
ssu ur

Update 2:
If you don’t have zypper installed (root privs required):
pkcon install zypper

6 Likes

I have the same problem. Upgraded from factory reset to 4.3 today on an XA2.
When attempting the solution above I get a “bash: zypper: not found”

pkcon install zypper
Should help.

1 Like

The solution didn’t work me, though. The camera still isn’t loading.

I cannot confirm this bug. Both, the XA2 and the Xperia 10 ii with 4.3.0.12 are flawless - cameras work as they should

Thank you deusexbeer. The described procedure brought back the camera on my XA2 (single sim) and it also solved the problem with playback of videos located in the gallery which caused the gallery app to crash. :slightly_smiling_face:
But it is really important to type the repository path correctly. It is easily possible to check if the adaptation-common repository is active and working with the command zypper pa adaptation-common (after doing the ’ zypper ref ’ command). This should then print out a list of the packages in this repository.

1 Like

Thank you very much deusexbeer, I work after several attempts

Same here with XA2.
Updated right now - no sailfish camera, no flashlight…

sadly @deusexbeer solution with adaptation-common and zypper steps did not help me

For the XA2 (dual SIM model, should not matter?) the repository added standard on my daily driver SFOS 3.2.1 device is:

ssu ar adaptation1 https://store-repository.jolla.com/releases/4.3.0.12/jolla-hw/adaptation-qualcomm-sony-nile-dhd/armv7hl/

Mind the ‘-dhd’ !
But when trying to add this repo it gets automagically “censored” to

Enabled repositories (user):
- adaptation1             ... https://store-repository.jolla.com/releases/4.3.0.12/jolla-hw/adaptation-qualcomm-sony-nile/armv7hl/


After adding above mentioned repo adaptation-common, thanks to @deusexbeer
devel-su; ssu ar adaptation-common https://releases.jolla.com/releases/4.3.0.12/jolla-hw/adaptation-common/armv7hl/; ssu ur
and using @olf 's sfos-upgrade there were 13 new pacages downloaded and

Install (13 packages)

  • audiosystem-passthrough;1.1.2-1.2.1.jolla;armv7hl;adaptation-common
  • bluebinder;1.0.12-1.2.1.jolla;armv7hl;adaptation-common
  • geoclue-provider-hybris-binder;0.2.32-1.3.1.jolla;armv7hl;adaptation-common
  • gmp-droid;0.4-1.2.1.jolla;armv7hl;adaptation-common
  • gstreamer1.0-droid;0.20210820.0-1.2.1.jolla;armv7hl;adaptation-common
  • libgbinder-radio;1.4.1-1.2.1.jolla;armv7hl;adaptation-common
  • libgbinder;1.1.10-1.2.1.jolla;armv7hl;adaptation-common
  • libgrilio-binder;1.2.5-1.3.1.jolla;armv7hl;adaptation-common
  • libncicore;1.1.18-1.2.1.jolla;armv7hl;adaptation-common
  • libnciplugin;1.1.1-1.3.1.jolla;armv7hl;adaptation-common
  • nfcd-binder-plugin;1.1.8-1.2.1.jolla;armv7hl;adaptation-common
  • ofono-ril-binder-plugin;1.2.5-1.3.1.jolla;armv7hl;adaptation-common
  • qtscenegraph-adaptation;0.7.6-1.2.1.jolla;armv7hl;adaptation-common

Afterwards camera and flashlight and video works…

2 Likes

you mean adaptation-common, right? @Starghost did that typo as well before. keep an eye!

@peterleinchen what do you mean with:

Same to me. After update from factory reset to 4.3 on my xperia xa2 no native cam, but Android “Open Camera” is working fine.
Very annoying.

Oh dear (to myself).
Yes, of course. Please see my code lines :wink:

olf’s sfos-upgrade

1 Like

thx, heard of it. never used. you mean installing and running through that process on already installed 4.3 can maybe fix the problems?

I don’t know whether or not this is related, but I did another factory reset. This is my second time of going from complete reset to 4.3 without any third party installations. And like the first time I get a strange notification when downloading v 4.3:
“Remove the following packages before update:
git-minimal
gittin
ofono-alien-binder-plugin”
I’ve not installed anything myself, so I assume that these are jolla-packages. I’ve no idea what these packages are or if it’s safe to simply uninstall them using the terminal. Seems strange that I would have to jump through these hoops to install an update, and if the packages are official sailfish packages why the installer simply doesn’t handle it. Could this be the cause of my issues with the camera? On previous installs I just ignored this warning, as I couldn’t see how there could possibly be an issue as I’m coming from a clean factory reset.