[Release notes] Suomenlinna 4.3.0

Added under “Known issues - generic”


Not sure if it was posted before, but it looks like gittin and git-minimal seem to be Sailfish packages who were removed in 3.2.1, hence it really should be fine to remove them :slight_smile:

1 Like

Then it makes really sense to throw a -confusion issuing- warning on installation of 4.3.0 where there have been at least 4 (stop) releases in between!??


Funny thing is that I found these packages still present on my phone, which seems to contradict the statement given in the 3.2.1 CHANGELOG.


If you have updated from 3.2.0 all the way to 4.3.0, then the packages were installed at first. They remained in your device all the way until 4.3.0, which (I’m guessing here) remove a package they need, and hence they are marked for removal during update. All going to plan!

If you had flashed, say, 4.0 which didn’t include them: no such packages, no such issues.

Now, removing a package or two during Linux distro update every now and then (Manjaro user here) is normal - even more so on upgrading to a newer distro release (Ubuntu user here, too) - but the way Sailfish displays it to you is a bit ominous. Usually it shouldn’t happen, but they are Sailfish-provided packages, which make this even more rare. With Openrepos, everything is possible, and hence the ominous message may actually reflect a system-breaking change. The good and the bad of having an opened Linux base aystem, I guess…


The warning is justified as two packages that are not listed in the repositories were detected.

Another thing is that Sailfish does not clean up itself effectively. It should have removed those packages after they had been removed from the repositories. However, during this update, they are automatically removed (removing manually is ok, too).


Yes, that may be true technically.
(and it is as @direc85 said: I checked dependencies of gittin → git-minimal on 3.2.1 and it requires openssl-libs-1.0, which was removed on 4.3.0)

Nevertheless this statemenet stays!


Using the %dist macro in the Release tag for rpm.spec files might solve some confusion. For example, current packages would have an 1.sfos4.3 Release tag, while these packages would have an 1.sfos3.2 Release tag. The updater could filter those packages out and not show old 1.sfosx.x packages and delete those silently.

Store packages could be built with 1.harbour4.3, while openrepos could have a 1.repos4.3 suffix. This would make it easier to do maintenance on older packages (deleting) or inform people that certain packages seem to go unmaintained.

I am slightly surprised this isn’t part of rpmbuild in SFOS, but I assume nobody saw the merits in this rpm versioning.

Edit: should I make some sort of proposal for this, like in a new topic, or in the meeting?


AFAIR, Jolla’s SSU does not support repository pinning (i.e., %dist tags) and repository priorities (all are at 99).
It was invented by Nokia in the early 2000s and was state of the art back then.

1 Like

new in 4.3, MMS messages that fail to download stay in “Waiting” forever when retrying.
if you cancel the waiting, and then hit retry, it stays in waiting forever.
this is reproducible 100% of the time.

note that MMS works fine for me, as long as i have the correct network settings the FIRST time i send/receive the message. (which i rarely do, since i have to disable wifi to send/receive MMS)


@teleshoes, please create a proper bug report (at Bug Reports - Sailfish OS Forum) by filling out the form there and reusing (copy&paste) your bug description from here (which is fine, IMHO), or Jolla will likely not denote this in their internal bug tracker.


Since the update:

  1. When hitting the paper clip in an Android app, it takes 7 seconds until images/videos are shown for selection.
  2. Screen regularly hangs while typing. I can keep typing multiple words on the frozen screen and my input will be processed many seconds later.
  3. Noticeable general delay when navigating SF-native apps/sections (eg Settings).
  4. AdvancedCam not working

This is Xperia X with
(Didn’t read this entire thread - too long)

1 Like

@hhead, please create three different, proper bug reports (at Bug Reports - Sailfish OS Forum) by filling out the form there and reusing (copy&paste) your bug descriptions 1, 2 and 3 from here (you might extend them a bit), or Jolla will likely not denote this in their internal bug tracker.

  1. AdvancedCam not working

Please read its description and use a current version of Advanced Camera from SailfishOS:Chum.

This thread has 113 posts!! Is there a simpler howto for using sailfish:chum ?

1 Like

I also did ignore the warning to remove the ofono-alien-binder-plugin package. And the upgrade did work without any errors, warnings.

Is there something that might make the browser not prompt for passwords storage in a website?

Ie on my banking site i enter the passwords but i don’t get the option to store them.

On an XA2 dual SIM:

I got asked to remove git-minimal and gittin, but no other packages.

Logged in over USB as developer, checked the presence of the apps

[nemo@Sailfish ~]$ pkcon search git-minimal
Searching by details                                                            
Installed   	git-minimal-2.20.1+git2-1.2.11.jolla.armv7hl (installed)    	Core git tools, cut-down version
[nemo@Sailfish ~]$ pkcon search gittin
Searching by details                                                            
Installed   	gittin-0.1.3-1.3.1.jolla.armv7hl (installed)                	A library to hangle Git repositories

and removed with

[nemo@Sailfish ~]$ devel-su pkcon remove git-minimal

supplying the developer password when prompted. This also removed gittin automatically.

Upgrade went without further problems.


glad it worked for you.

i just ignored the errors and upgraded regardless - figured it wasn’t my job to interpret developer gobbledygook…

After reading your comment I was somewhat worried, but then I decided to simply ignore those conflict warnings and continue the update:
The first time it failed, but the phone booted just like normal into 4.2.
Tried a second time: The updater showed an even longer list of conflicts, but worked flawless and updated the phone to 4.3.0. Haven’t tested in depth, but so far everything seems to be just fine.