[release notes] Pallas-Yllästunturi 3.4.0

But now, the 100th reply?

@Objectifnul @jovirkku but what could it mean instead. For me it means “Alien Dalvik 8.1 added support for f5121”. If it doesn’t mean this, i don’t know what it should mean or what it should tell the people!? Another mystery then :wink:

1 Like

You are saying that

Sailfish can connect Bluetooth Low Energy devices now. However, Android apps cannot use peripheral devices via Bluetooth - other than for playback of the sound. Therefore smartwatches, for instance, cannot be controlled from Android apps

Is this something that is planned to be solved in the future or does this mean that using peripheral bluetooth devices with Android apps will remain (forever) impossible because of technical limitations?


1 Like

Its an old log. Like I stated in the changelog thread they splitted the packages and that pulled in a lot of old changes to ad to the changelog.


The log has been fixed now. There is also the reasoning why the old items appeared in the 1st version of the log.
See: [changelog] Pallas-Yllästunturi 3.4.0

1 Like

Not sure about that. Vertical gestures feel more consistent (since, you know, my phone is usually in portrait mode).
And come on, please do introduce option to disable the top menu when an app is open, so that the whole top screen margin can be used to close running app (just like it was in MeeGo and earlier Sailfish releases)


@jovirkku This issue was also fixed in this update:


1 Like

I find the new incoming call experience confusing. It feels much more natural and consistent with the OS overall user experience to answer a call with a swipe down gesture.

The browser works much better now! As I said previously, the browser video playback issue was fixed. In addition, an issue I found with Google search where the user was not able to select suggestions was also fixed and a website I frequently visit now works. For this reason this has been one of the most relevant Sailfish OS releases for me.

And weather app looks much nicer now!

3 Likes (RC9) rolled out today for Early Access subscribers. Please read the release notes.


Just re. swipe action, I personally get confused which actions are up and which are down, so up/side=better for me.
With. a. mixed. reception. and this thread now running at 111112 entries, a ‘poll’ thread on contentious changes might be an option - just an idea (for anyone).

1 Like

Media DB doesn’t work after new update. Resetting via sailfish utilities didn’t solve that, same goes for manually deleting the library files in nemo/.cache/tracker.
So gallery and Media Player are emtpy, no sources…

Updated from 3.3 to on my XA2 and everything went fine. Android works, Media DB works (but never had problems with that). Wifi points are all there. Thank you :slight_smile:

1 Like

Solved - just took hours to index 1000 Files.

I’m having issues after updating. It looks as if zlib was upgraded from 1.2.9 to 1.2.11 and libpng remains at 1.6.34 and is still trying to load symbols for zlib 1.2.9 (which are no longer there). This breaks applications trying to use libpng, such as OpenStreetMap.

Just got to say - these release notes are so much better than on askbot. The side-by-side history display of the OP is not perfect, but tells me what’s changed.


Finally I’ve updated my Jolla 1 from to in one shoot. Update done with version --dup after I tried via UI without success.
But that was maybe due to a error in one repro, which I had to delete upfront the upgrade process. Don’t know why this repro was suddenly broken, it worked for months before.

Neither zlib nor libpng have been upgraded from 3.3.0 to 3.4.0. They have kept their versions 1.2.11 and 1.6.34, respectively.

I have certainly not tried all apps relying on Open Street Maps but at least OsmAnd works fine on XA2/
Which app is broken and how?

@jovirkku, could “Screenshot functionality is broken” be added to the known issues for the Jolla Tablet?

@nthn: Done. Too bad that it is broken.


I have the same thing with the alarm. One vertical swipe is snoozing, the other vertical swipe is disabling the alarm. When I’m still asleep I really do not know what I’m doing and I’ve disabled the alarm too often when I should have snoozed it.

A vertical and horizontal swipe for this might help me here.