[release notes] Koli 4.0.1

Why is this issue no longer listed under known issues for XA2? (it was previously tracked and incorrectly states as fixed in a TJC release notes):

3 Likes

Title of a page now seems forced white when an attachedPage exists?

I’m afraid the fix didn’t make it in in time for this release, but should be there for the next.

3 Likes

Hello,
I need help. Update went smoothly. But after update I am not able to open the core apps any more (Browser, Galery, Phone, Contacts, Mail). At first startup, they asked for permission. I accepted - the app closed. Now non of the apps does open. However, I tried to open the browser by terminal and it works immediately.

What I already tried: Reboot, Open Accounts, and start sync., Reboot

Edit: Opening Contacts app by terminal does not show any contacts

I have a dual sim XA2. On 3.4, the mobile icons (1 and 2) on top right of the home screen had different colors, and the mobile internet connection icon had the same color as the default sim for internet. So by looking at the icon color you knew if SIM1 or SIM2 was active for mobile internet.
Now on 4.0.1, all these icons are white, so you can’t decide by the icon color which sim is used for mobile internet.
Is there any setting to bring back the old behavior?

“Waiting for connection…” The first trials didn’t work, now update process waits for a connection…I am looking forward to all the new features! :wink:

My experience so far:

Is Patchmanager broken? I can’t apply any patches nor can I access the Web catalog. Is this a permissions thing?

I also found that my SDCard is no longer auto-mounting (having previously followed the guide on TJC). I haven’t got the time to see if I can redo the procedure to see if it’ll work today, but if anyone else does, can they report back if it works or not. So if you have a long password, I’d suggest you temporarily copy it to notes or in a file NOT on you sdcard to facilitate easier unlocking eg. after an emergency reboot.

SailfishConnect, which needs to be uninstalled before an update, has a missing dependency - libcontextkit-statefs-qt5.so

5 Likes

The problem with not showing contacts, happens to me too. A strang thing was, that the history was also empty.
But after a reboot the contacts and history is back.

Cannot seem to connect with my XMPP account anymore. Telepathy Gabble/Wocky tries to use TLSv1 (and enforce that now it seems) which fails with most modern servers that require TLSv1.2+.

See also: Missing support for TLS1.3

2 Likes

and “Archive” option instead of “Delete” in the email client would also be wonderful!

2 Likes

Since failed update, the update hangs with “waiting for connection” in the settings page. Is the server overloaded, or is it a problem of the failed update?

1 Like

A reboot didn’t help in my case. All Core apps have now permissions to use other apps/data - but still, the apps won’t open and if opened via terminal, the have not data (e.g. contacts). Using my backup data didn’t help. Also deleting/reactivating the google account didn’t help. This sucks.

Tapping on adress in contact details, ther is no option to “show on map”.
Only the statusbar shows “this action is currently unavailable”.
Is there a way to send the adress to a map-app?

Enable Do Not Disturb mode to turn off notification sounds and vibrator feedback

:heart::heart_eyes::+1:

Address books support developed for contacts

Yess! :muscle:

2 Likes
  • Keyboard colours now follow the application theming (apps can override the ambience style)

Do we have control over this ? I really like the unified look given by ambiences.

I also have hard time dealing with some colors and the way ambiences works now have greatly improved my life by allowing me to remove them from the main interface.

2 Likes

Overall very positive upgrade experience (XA2 Dual Sim).

The update went through flawlessly. Had a few hiccups with contacts that were not showing up and calendar events. Easily resolved by making sure that I give permissions to the Contacts app and also go to all the Accounts and do a re-sync to bring all the calendar events and cloud contacts. Rebooted a couple of times in between and contacts appear normally. Also the call log got populated with the names instead of just showing numbers once the contacts loaded and I rebooted. Very happy, seems like a solid release and much better experience compared to the 3.4 update.

Another nice touch was the warning to uninstall some apps from OpenRepos (Contrac and System Monitor in my case) before starting the update - it’s good to see Jolla listening to the community requests :slight_smile:

Interesting UI changes, not sure if I like all of them but I am happy to see changes/experimenting/evolution.

Keep up the great work! Looking forward to new hardware support :wink:

PS: Seems that the battery life returned back to the previous levels, I am at 49% after 24hrs since last charge with the same use pattern as with 3.x versions. 3.4 introduced some horrible battery drain which I never tracked down, resulting in the phone barely lasting for a day with a full charge…

2 Likes

Issue with my XA2, single sim. After this screen:

After reboot I am stuck either on the Sony screen, or passing it, but then it stays black. Backlight turns on when pressing power, but that’s all. No SSH access.

Update failed on XA2. (Alien dalvik removed / storeman removed / all patches disabled)
Stuck while checking the device lock code.
Where and when to except v4 image to flash please ? :slight_smile:
EDIT: never used Defender app

About the warning note regarding to Defender:

Are there plans to bring back bash at some point? Busybox’s ash is an inadequate replacement for bash in my opinion, as simple things like shopt are not present, nor arrays. I’m sure there’s a ton more, but those are the first two issues I ran into when running a bash script on Koli.

Thank you.

9 Likes