[release notes] Koli 4.0.1

OK, thanks… both of you.

I downgraded to libcontentaction-qt5-0.3.16-1.2.12.jolla.armv7hl and nemo-qml-plugin-contentaction-0.3.16-1.2.12.jolla.armv7hl. For obexd-contentfilter-off-1.1.7-stable.noarch I don’t see any alternative package. So cannot downgrade that. Also I get the warning that it would break my system to remove obexd-contentfilter-off.

Still I get the warning I should remove these three packages.

OS upgrade went fine after downgrade those packages. Thanks again!

Not sure man :confused: i don’t use official ports

could you give me a hint, which command do the trick?
with Pkcon or zypper?

See an example for another package here: How to reinstall "original" package version?


Can’t update from to since although suggesting initially that the update is just 30Mb I’m now told that the download (downloaded) needs 500Mb but has only 349Mb currently available!
Not only this but having “successfully” installed I’m being told that I need to uninstall pages of items before I update!!! Surely the change of such a minor version can’t affect so many entries!!!

How do I delete the downloaded update please and can Jolla issue an update that actually works for XA2 users please.


@ninepine: I had a similar issue initially with my XA2 when trying to update to

The memory is apparently needed for the installation - not for the download of the update. In my case, it turned out that i messed up with zypper download and downloaded some rpms in the system memory without deletuing the rpms later (thus having too little memory space).

Once I resoved that issue, the warning and hinting to removing 100+ packages disappeared. Further, I learned that in the present case I could ignore the warning.

Thanks but this is a very minor upgrade from. 0.1.45 to 0.1.48 so cannot possibly require 500mb. Maybe somebody from Jolla /Sailfish can fix this error please?

Making sure that the erroneous error messages are also removed please would also help. At the moment it seems that needs some serious work.

1 Like

I believe Sailfish updates the packages piecemeal rather than a la carte. If it’s suggesting a 500MB download, it’s downloading updates to all individual packages. Someone else can correct me on that.

1 Like

An OS update is executed using the software code (and the other setup) already in the device. The new update cannot help the installation of itself! The code of the new update will be in effect only after the device restart which is done in the end of the installation.

So, if a phone has in it then the update to is done by running the instructions contained in the code of Hence, if there is a problem in installing, that problem is most probably caused by something in the phone now - the changes in do not affect at that point yet.

The download size from to is around 30 MB. Only the modified code packages are replaced.


I’m encountering the same issue on my Jolla Tablet, it isn’t saying it needs to download 500MB, it’s saying the device needs 500MB free space after the 30MB update is downloaded, and prevents the user from installing it.

I even enlarged the root partition on my tablet with several GBs a couple of years ago specifically because the “not enough space on root partition” problem kept showing up with every new release.

Edit: ah, wait a minute, perhaps the enlarged root partition got undone after performing a factory reset.

Edit 2: it did indeed get undone after a factory reset. Here’s a great guide to enlarging the root partition. @ninepine, if you follow this guide, you’ll be able to fix the problem.

Edit 3: well, apparently, by following the guide, my device lock code got changed, and now I can’t do anything with my tablet anymore. Great.

1 Like

Someone else have problems with dynamic orientation in the last update?

I also have problems with dynamic orientation not working in android apps in
It worked correctly in on my XA2 plus.

I ignored the warnings and installed the update without any further issues.

1 Like

Wait, this is absolutely ridiculous. I have 10 attempts at unlocking the device. I tried three times in the UI, and two times in recovery mode, so how can my device possibly be locked already?

1 Like

Do the dynamic orientation and fullscreen video play work in android apps, e.g. chrome etc. after updating to

Hm, I planned to do this tonight as well, did you use the route with or without device encryption? (I wouldn’t see where the lock code enters without encryption, but I want to be sure)

Some time ago I had a similar problem and was forced to delete the update files to reset the update function to offer the update again.
Possibly this helps:https://together.jolla.com/question/210487/forced-downgrading-after-deactivation-of-the-early-access/

Does anybody else have following issue?:
When choosing an entry from the call-history here comes the dialogue to choose the SIM-card but it immidately disappered, so calling from the call-history is impossible for me.
Sony XA2 Dual Sim (Europe) (was the same in
greetings from a formerly tjc-user