[release notes] Koli 4.0.1

I also have bluetooth problems with 4.0.1 (on Xperia X F5121).

When entering in the terminal:
[nemo@Sailfish ~]$ ssu lr
[W] unknown:0 - QConnmanEngine: Unable to translate the bearer type of the unknown connection type: “bluetooth”
[W] unknown:0 - QConnmanEngine: Unable to translate the bearer type of the unknown connection type: “bluetooth”

I could update one Jolla C and XperiaX without any problem (both with increased root size if this matters).
The positive thing is, my Jolla Account did survive this update, in the past i everytime had to put in the password again.
On the other hand i must say, more buttons for omp, no apps from omp.
The messages cover has still the unsightly and not adjustable white lines and the background of the webview in the mail-app ist still white and seems to be also not changeable :-(.
The mail-app says no accounts, when it for instance startet with “Apps after boot”.
The new notifications should be adjustable in their vertical position on the screen because they are often hide and disturb other items and actions.
Last but not least, the update leaved our beloved patchmanager unfunctional ;-).

The file is owned by group privileged. No idea whether it is important to preserve that.

Jolla Phone is not supported any more. OS release 3.4.0 was the last one for this device launched 7 years ago.

@jovirkku and team: Congratulations for keeping the device up-to-date for so long, and showing iOS and Android how it should be done.
I really appreciate the work you do, and am grateful that you do it.


Xperia X installation went flawlessly and everything works apart from a regression in the browser. My Salesforce internal website loads but does not render anymore which is a big problem for me at the moment and makes me consider installing Android support to install Firefox.
Xperia 10 installation also went flawlessly and the website opens so it’s only on the Xperia X (main device).
The browser tries to do something as it’s task is taking 80% of the processor as seen in lighthouse (top).
I tried leaving the device doing it’s work but even after 2 minutes nothing appears.
It does work in the private browsing though! Does the browser have a cache that could be deleted, might help.

It has something to do with my HOST file. I download it from https://winhelp2002.mvps.org/ to keep the web mostly AD free. I will restore the original HOST file and see if that helps. Clearing the cache did not help though.

Re Clock - if still not working have you tried the solution in Sailfish Core Apps do not work after Update to Sailfish (sandboxing problem?)

devel-su pkcon install --allow-reinstall jolla-clock

1 Like

The “computer” side of things seems to be working fine on my XperiaX 5122.

However, there is NO ANDROID whatsoever. Everything just crashes at startup. This is disappointing as there are a couple of apps that are supported on 4.x and which I still use :frowning:

And with the Jolla C Phone?
How long will this device be supported?

I’d think SFOS 4.* will be the last one. They should drop all those handicapped oldies.

Hello @ninepine,
thank you very much for this hint.
It is a little bit strange: This solution works (the clock-app starts after reinstalling) - but after a phone-restart the issue appears again.

For me, the circumstance is not too tragic, since I planned to reinstall the system anyway.
If I could have solved the problem, I would have postponed the reinstallation to a later time.
Now I wait until the official version is available and then do a “Sailfish restart”!
(There are some other little problems that I hope to solve this way).

Thanks for the feedback.

Edit: Now I have it! After I read the original post then but correctly. First “pkcon remove harbour-dynclock”, then again “devel-su pkcon install --allow-reinstall jolla-clock”! Now it works even after a reboot.

Thanks again!

1 Like

I do the same, except that I had replaced /etc/hosts with a symbolic link to the modified file. That had pretty fatal consequences in

@remote My Jolla C works fine. In what way handicapped?


Upgrading from to -> Problem with store, could not determine size of the update.

Maybe there’s a rush on the server, I will try again later.


same issue here - will try again later

Sorry and thanks for reporting. There was a reason other than rush. Fixed now. Please try again.


Upgrade from to a few minutes ago without any problems (Xperia Xa2 / single).
Everything seems to be working fine!
Thank you very much for all the fantastic work!

1 Like

Upgrading from to My X says to uninstall libcontentaction-qt5 and nemo-qml-plugin-contentaction.
Doesn’t look right to me??

@eson You may have had mister magisters repository enabled and updated to his version… he has removed the rpms today.

1 Like

you are right, there was an notification within storeman to update this packages.
Question is now, how to remove the packages without breaking the system to start the update to
Or is it safe to ignore the message from the updater “Uninstall the follwing before proceeding with the sailfish OS update”

Upgrading from to seems to have worked quite well.