[] Extremely strange lock code bug on Jolla Tablet, please read the whole thread

After following section 3.3.2a of this guide to enlarging the root partition in order to be able to install the latest Sailfish update ( ->, my Jolla Tablet booted up fine, and I was able to install the software update. When the tablet rebooted after updating, I entered my lock code, but it claimed the code was incorrect. I entered the code two more times to make sure I hadn’t made any typos, but it kept saying the code was incorrect. I presume something must have happened to the file containing the code whilst resizing the partitions.
I then rebooted to recovery mode and tried to access the shell, which also asked for my lock code, and also said the code I entered was incorrect twice in a row.
I then rebooted back to the UI, which told me the device is now permanently locked - even though I had only used up 5 out of the 10 attempts I set as the limit.
Strangely, rebooting back into recovery mode always seems to give me five attempts to unlock, even though the UI says I have no attempts left.

Apparently, performing a factory reset is also locked behind the device lock code, which still isn’t working, so now I wonder: how can I get this device to work again?

1 Like

Okay, I really don’t understand what’s going on anymore. After several reboots into recovery mode, suddenly the lock code (in recovery mode) works. I won’t risk going back into the UI and having it blocked again, so I’m quickly going to factory reset the device, change up the partitions, update to the latest Sailfish version and then set the lock code. The Jolla Tablet truly has the most esoteric bugs out of all electronics I’ve ever seen…

1 Like

I have exactly the same problem.

I’ve updated my original post a little bit because it wasn’t completely accurate. Do you also experience the problem right after having updated from to

After I suddenly gained access again, I actually managed to just remove the unlocking attempts limit by following this post:

So, in case you also somehow manage to get into recovery mode again (I really don’t know what I did other than reboot into UI and recovery several times), the value you have to modify is ‘maximum_attempts’, just change it from 10 (or however many attempts you had configured) to -1, save and exit. Note that this probably doesn’t solve the underlying problem, but because it’s so weird and seemingly random, and the Jolla Tablet isn’t exactly Jolla’s main focus, I don’t think the problem itself will ever be fixed.

Yes, it was right after updating .45 to .48. I have also always 5 tries in recovery mode, but have to wait 24 hours. And: Recovery mode says “WARNING: Locking directory /run/cryptsetup is missing!”. Sounds like that’s somehow connected to the problem.

1 Like

Okay, this is crazy: When I rebooted after using all my tries in recovery mode, my lock code worked again.

1 Like

Glad to hear it’s suddenly working again for you too. Sounds like we both found an incredibly weird bug in, then. I’ll edit the thread accordingly.