Xperia 10 III Mobile data stops working

REPRODUCIBILITY: 100% (always)
OSVERSION: 4.4.0.68
HARDWARE: Sony Xperia 10 III - xqbt52 - xqbt52 - 1.0.0.142 - aarch64
UI LANGUAGE: English (UK) (user: en_GB, os: en_GB.utf8)
REGRESSION: no

DESCRIPTION:

Mobile data ceases to work after a while, with no apparent reason.

PRECONDITIONS:

EXPECTED RESULTS:

Mobile data keeos working

ACTUAL RESULTS:

MODIFICATIONS:

this only reflects the current status - the problem occurred as well with none of the below installed

  • Patchmanager: no
  • OpenRepos: yes
  • Chum: yes
  • Android support: yes
  • Other:

ADDITIONAL INFORMATION:

All of the following attempts failed to restore the mobile data:

  • Changing the SIM slot
  • enabling/disabling slots
  • Changing IP mode (dual/v4/v6)
  • removing var/lib/ofono/* ( and mistakenly var/lib/ofono)
  • reflash SFOS
  • reflash Android 11 ( tried with 62.0.A.3.17 and 62.0.A.3.109) then SFOS.
  • downgrade AOSP binaries to v8a

What worked (to some extent):

  1. flashing Android12 ( 62.1.A.0.617 ) with newflasher (on linux) then SFOS: this brought the mobile data back, but only for a while ( then stopped )
  2. without reflashing of any kind , mobile data worked abroad (roaming). I have not paid attention to the operator
    2.1. at some point it failed (on Orange RO) where it remained blocked 3G and no data.
    2.2. forcing on Vodafone RO brought back 4G and mobile data wile abroad
  3. once back in home network ( Free Mobile/FR ) mobile data went back to the same failures

Common things while not working

  • settings Mobile Data displays “enabled”.
  • the status bar does not display the data activity
  • journalctl -u ofono display every now and then Unexpected data call status 4100. Less often there’s also status 27.
    Here’s a longer extract:
Aug 17 10:32:25 Xperia10III ofonod[3362]: SMS History Probe for modem: 0x37b38f20
Aug 17 10:32:25 Xperia10III ofonod[3362]: Registered interface org.ofono.NetworkTime, path /ril_0
Aug 17 10:32:25 Xperia10III ofonod[3362]: nw selection is already auto
Aug 17 10:32:25 Xperia10III ofonod[3362]: smsc query error INVALID_MODEM_STATE
Aug 17 10:32:25 Xperia10III ofonod[3362]: Provisioning for MCC 208, MNC 15, SPN 'Free'
Aug 17 10:32:25 Xperia10III ofonod[3362]: Name: 'Free'
Aug 17 10:32:25 Xperia10III ofonod[3362]:   APN: 'free'
Aug 17 10:32:25 Xperia10III ofonod[3362]:   Type: OFONO_GPRS_CONTEXT_TYPE_INTERNET
Aug 17 10:32:25 Xperia10III ofonod[3362]:   Username: '(null)'
Aug 17 10:32:25 Xperia10III ofonod[3362]:   Password: '(null)'
Aug 17 10:32:25 Xperia10III ofonod[3362]: Name: 'Free MMS'
Aug 17 10:32:25 Xperia10III ofonod[3362]:   APN: 'mmsfree'
Aug 17 10:32:25 Xperia10III ofonod[3362]:   Type: OFONO_GPRS_CONTEXT_TYPE_MMS
Aug 17 10:32:25 Xperia10III ofonod[3362]:   Username: '(null)'
Aug 17 10:32:25 Xperia10III ofonod[3362]:   Password: '(null)'
Aug 17 10:32:25 Xperia10III ofonod[3362]: Name: 'IMS'
Aug 17 10:32:25 Xperia10III ofonod[3362]:   APN: 'ims'
Aug 17 10:32:25 Xperia10III ofonod[3362]:   Type: OFONO_GPRS_CONTEXT_TYPE_IMS
Aug 17 10:32:25 Xperia10III ofonod[3362]:   Username: '(null)'
Aug 17 10:32:25 Xperia10III ofonod[3362]:   Password: '(null)'
Aug 17 10:32:25 Xperia10III ofonod[3362]: Requested file structure differs from SIM: 6fb7
Aug 17 10:32:26 Xperia10III ofonod[3362]: Unable to read mailbox dialling numbers from SIM
Aug 17 10:32:27 Xperia10III ofonod[3362]: imsradio0 > 27 vopsChanged
Aug 17 10:32:27 Xperia10III ofonod[3362]:   0000: 76 65 6e 64 6f 72 2e 71  74 69 2e 68 61 72 64 77    vendor.q ti.hardw
Aug 17 10:32:27 Xperia10III ofonod[3362]:   0010: 61 72 65 2e 72 61 64 69  6f 2e 69 6d 73 40 31 2e    are.radi o.ims@1.
Aug 17 10:32:27 Xperia10III ofonod[3362]:   0020: 32 3a 3a 49 49 6d 73 52  61 64 69 6f 49 6e 64 69    2::IImsR adioIndi
Aug 17 10:32:27 Xperia10III ofonod[3362]:   0030: 63 61 74 69 6f 6e 00 00  01 00 00 00                cation.. ....
Aug 17 10:32:27 Xperia10III ofonod[3362]: imsradio0 > 27 vopsChanged
Aug 17 10:32:27 Xperia10III ofonod[3362]:   0000: 76 65 6e 64 6f 72 2e 71  74 69 2e 68 61 72 64 77    vendor.q ti.hardw
Aug 17 10:32:27 Xperia10III ofonod[3362]:   0010: 61 72 65 2e 72 61 64 69  6f 2e 69 6d 73 40 31 2e    are.radi o.ims@1.
Aug 17 10:32:27 Xperia10III ofonod[3362]:   0020: 32 3a 3a 49 49 6d 73 52  61 64 69 6f 49 6e 64 69    2::IImsR adioIndi
Aug 17 10:32:27 Xperia10III ofonod[3362]:   0030: 63 61 74 69 6f 6e 00 00  01 00 00 00                cation.. ....
Aug 17 10:32:28 Xperia10III ofonod[3362]: export_entries_one_storage_cb with ME failed
Aug 17 10:32:39 Xperia10III ofonod[3362]: data reg changed 0 -> 1 (registered), attached 0
Aug 17 10:32:39 Xperia10III ofonod[3362]: Activating context: 1
Aug 17 10:32:40 Xperia10III ofonod[3362]: Unexpected data call status 27
Aug 17 10:32:45 Xperia10III ofonod[3362]: Activating context: 1
Aug 17 10:32:46 Xperia10III ofonod[3362]: Unexpected data call status 4100
Aug 17 10:32:55 Xperia10III ofonod[3362]: data reg changed 1 -> 2 (searching), attached 0
Aug 17 10:33:00 Xperia10III ofonod[3362]: imsradio1 > 7 radioStateChanged
Aug 17 10:33:00 Xperia10III ofonod[3362]:   0000: 76 65 6e 64 6f 72 2e 71  74 69 2e 68 61 72 64 77    vendor.q ti.hardw
Aug 17 10:33:00 Xperia10III ofonod[3362]:   0010: 61 72 65 2e 72 61 64 69  6f 2e 69 6d 73 40 31 2e    are.radi o.ims@1.
Aug 17 10:33:00 Xperia10III ofonod[3362]:   0020: 30 3a 3a 49 49 6d 73 52  61 64 69 6f 49 6e 64 69    0::IImsR adioIndi
Aug 17 10:33:00 Xperia10III ofonod[3362]:   0030: 63 61 74 69 6f 6e 00 00  00 00 00 00                cation.. ....
Aug 17 10:33:39 Xperia10III ofonod[3362]: imsradio0 > 7 radioStateChanged
Aug 17 10:33:39 Xperia10III ofonod[3362]:   0000: 76 65 6e 64 6f 72 2e 71  74 69 2e 68 61 72 64 77    vendor.q ti.hardw
Aug 17 10:33:39 Xperia10III ofonod[3362]:   0010: 61 72 65 2e 72 61 64 69  6f 2e 69 6d 73 40 31 2e    are.radi o.ims@1.
Aug 17 10:33:39 Xperia10III ofonod[3362]:   0020: 30 3a 3a 49 49 6d 73 52  61 64 69 6f 49 6e 64 69    0::IImsR adioIndi
Aug 17 10:33:39 Xperia10III ofonod[3362]:   0030: 63 61 74 69 6f 6e 00 00  00 00 00 00                cation.. ....
Aug 17 10:33:40 Xperia10III ofonod[3362]: imsradio0 > 27 vopsChanged
Aug 17 10:33:40 Xperia10III ofonod[3362]:   0000: 76 65 6e 64 6f 72 2e 71  74 69 2e 68 61 72 64 77    vendor.q ti.hardw
Aug 17 10:33:40 Xperia10III ofonod[3362]:   0010: 61 72 65 2e 72 61 64 69  6f 2e 69 6d 73 40 31 2e    are.radi o.ims@1.
Aug 17 10:33:40 Xperia10III ofonod[3362]:   0020: 32 3a 3a 49 49 6d 73 52  61 64 69 6f 49 6e 64 69    2::IImsR adioIndi
Aug 17 10:33:40 Xperia10III ofonod[3362]:   0030: 63 61 74 69 6f 6e 00 00  01 00 00 00                cation.. ....
Aug 17 10:33:40 Xperia10III ofonod[3362]: imsradio0 > 27 vopsChanged
Aug 17 10:33:40 Xperia10III ofonod[3362]:   0000: 76 65 6e 64 6f 72 2e 71  74 69 2e 68 61 72 64 77    vendor.q ti.hardw
Aug 17 10:33:40 Xperia10III ofonod[3362]:   0010: 61 72 65 2e 72 61 64 69  6f 2e 69 6d 73 40 31 2e    are.radi o.ims@1.
Aug 17 10:33:40 Xperia10III ofonod[3362]:   0020: 32 3a 3a 49 49 6d 73 52  61 64 69 6f 49 6e 64 69    2::IImsR adioIndi
Aug 17 10:33:40 Xperia10III ofonod[3362]:   0030: 63 61 74 69 6f 6e 00 00  01 00 00 00                cation.. ....
Aug 17 10:33:44 Xperia10III ofonod[3362]: imsradio0 > 7 radioStateChanged
Aug 17 10:33:44 Xperia10III ofonod[3362]:   0000: 76 65 6e 64 6f 72 2e 71  74 69 2e 68 61 72 64 77    vendor.q ti.hardw
Aug 17 10:33:44 Xperia10III ofonod[3362]:   0010: 61 72 65 2e 72 61 64 69  6f 2e 69 6d 73 40 31 2e    are.radi o.ims@1.
Aug 17 10:33:44 Xperia10III ofonod[3362]:   0020: 30 3a 3a 49 49 6d 73 52  61 64 69 6f 49 6e 64 69    0::IImsR adioIndi
Aug 17 10:33:44 Xperia10III ofonod[3362]:   0030: 63 61 74 69 6f 6e 00 00  02 00 00 00                cation.. ....
Aug 17 10:33:44 Xperia10III ofonod[3362]: nw selection is already auto
Aug 17 10:33:44 Xperia10III ofonod[3362]: data reg changed 2 -> 1 (registered), attached 1
Aug 17 10:33:44 Xperia10III ofonod[3362]: Activating context: 1
Aug 17 10:33:45 Xperia10III ofonod[3362]: Unexpected data call status 27
Aug 17 10:34:00 Xperia10III ofonod[3362]: Activating context: 1
Aug 17 10:34:00 Xperia10III ofonod[3362]: Unexpected data call status 4100
Aug 17 10:34:20 Xperia10III ofonod[3362]: Activating context: 1
Aug 17 10:34:21 Xperia10III ofonod[3362]: Unexpected data call status 4100
Aug 17 10:34:46 Xperia10III ofonod[3362]: Activating context: 1
Aug 17 10:34:47 Xperia10III ofonod[3362]: Unexpected data call status 4100
Aug 17 10:35:20 Xperia10III ofonod[3362]: imsradio0 > 7 radioStateChanged
Aug 17 10:35:20 Xperia10III ofonod[3362]:   0000: 76 65 6e 64 6f 72 2e 71  74 69 2e 68 61 72 64 77    vendor.q ti.hardw
Aug 17 10:35:20 Xperia10III ofonod[3362]:   0010: 61 72 65 2e 72 61 64 69  6f 2e 69 6d 73 40 31 2e    are.radi o.ims@1.
Aug 17 10:35:20 Xperia10III ofonod[3362]:   0020: 30 3a 3a 49 49 6d 73 52  61 64 69 6f 49 6e 64 69    0::IImsR adioIndi
Aug 17 10:35:20 Xperia10III ofonod[3362]:   0030: 63 61 74 69 6f 6e 00 00  00 00 00 00                cation.. ....
Aug 17 10:35:20 Xperia10III ofonod[3362]: data reg changed 1 -> 0 (unregistered), attached 1
  • ofonologger
15:38:24.215 Unexpected data call status 4100
15:38:24.215 src/gprs.c: pri_activate_callback() Activating context failed with error: Unknown error
15:38:24.215 src/binder_data.c: binder_data_call_new_1_0() [status=4100,retry=-1,cid=0,active=0,type=,ifname=,mtu=0,address=,dns=,gateways=,pcscf=]

I can extract more logs if I’m told what are the “interesting” parts.

Other remarks:

  • After each Android flashing cycle, data worked fine in Android, regardless the version
    ** 5G worked ok
    ** 4G or 3G worked ok as well when restricted in settings
  • SFOS VoLTE is not and was not enabled
  • Voice keeps working fine (dropping to 3G)
  • When not in call it expectedly displays 4G
  • Quite often I receive several times the same SMS
  • While it worked, Mobile data config remained on Dual (default)
  • WLAN status and usage doesn’t matter ( it failed with no WIFI configured at all as well as with WIFI registered)
  • failure occured irrespective of Android support, CHUM or OpenRepos

Other details are available in the Unable to use mobile data on Sony Xperia 10 III 4.4.0.64 thread.


the initial version of this bug report was created using Bugger v0.9.6

2 Likes

We have a couple of other tracked bugs which could be similar to this one. It would be helpful if you could also take a look at these to check whether this may be a duplicate, or whether there are any commonalities between what you’re experiencing and what’s described in these.

3 Likes

It happened a few times on my 10 III / 4.4.0.68, too. The record so far has been 3 same SMS within a few seconds.

1 Like

Hello @flypig , thanks for looking into this bug.

I had misread it, thinking it relates to Dual/IPv6/IP setup. If my description helps in some way, I can paste it in a comment of the tracked one.

Concerning your second suggestion: I have not enabled VoLTE under SFOS (it doesn’t work under Android and looks it never will due to some feud brewing between the operator (Free Mobile) and Sony ). I tend to rule out this second report:

2 Likes

'lo!
Got a 10 III me too.
I recovered today a working 4G data conection after two plain weeks without.
To be precise the data conection has been ok during aboit two months, then erratically, websites, streaming … Everything related to network failed, just a bit. Desactivate/reactivate data, retstart ofono, restart phone, sony reset, change data settings (apn, dual stack …), change sim slot … things worked, not worked, no rules seemed to be deduced. And, lately, two weeks ago, no data at all, logs listing dbus and ofono errors (4100 …).
Today, scrutinizing the forum, I read somebody speaking about disabling the pin code of the sim card (thanks to this person). Done it, reboot, and “voila”. I’ve not yet done a second reboot to confirm the functionality, but reactivate the pin code does not seems to bring back this mess (not for today, at least).
For the information to be complete : I use the Free telecom network (France).

1 Like

what does it look like in SFOS when you have a locked pin code for the sim?
If I am in Settings>System>Sim cards, and I can’t see anything on screen saying i have locked sim(s) does that mean it is unlocked?
And that this is not the cause of my mobile data problem

In Settings>System>Pin code you got a checkbutton “ask for pin code” and a button to modify this pin code. So I just unchecked, validated entering the pin code, reboot, not entered my pin code and got my data connection back, which I use for this answer.

1 Like

So in both my XA2 Plus on 4.4.0.64 and my 10 iii on 4.4.0.68 , this section reads as follows:

"PIN Code"
"SIM1 | Talkmobile"
[greyed-out/deselected] "Require PIN code"

This seems different to what you describe.
So that would seem to indicate that my Sim doesn’t have a pin code?

Either way, same on both phones but mobile data works on the ZA2 but not the 10iii.

Thanks to @savaju I got it working!
steps:

  1. toggle OFF System Settings/Security/Require PIN Code for your SIM card
    RequirePIN
  2. shut down the phone
  3. with the phone turned OFF, long press volume up + power keys; phone vibrates once; keep buttons pressed until three short vibrations. without this step, the procedure didn’t work for me
  4. turn on the phone.
    In my case, 4G data came back to life.

Additional remarks:

  • Toggling “Require PIN code” ON with mobile data in status OK will break it upon reboot
  • Toggling “Require PIN code” to OFF with mobile data in status BROKEN will make it work after reboot. So far that worked without the reset procedure described at step 3 above.
  • the procedure “fixed” as well the connectivity on another SIM (Auchan Telecom) which previously remained stuck in 3G. Now it goes 4G with mobile data.

Awkward.

2 Likes

Since the above ‘fix’, the phone hit several times the condition described above (no data, unexpected status code 4100).
The condition goes away only after rebooting (flight mode toggle, SFOS utilities/ network or Ofono restarts are not effective ).
No need to do the reset step though, reboot is enough.

So far that correlates with moving (car, train), bad signal condition (tunnels, metro ). With my FreeMobile SIM, bad 4G signal may trigger national roaming (fallback on Orange FR 3G network).

1 Like

Tried this one, never worked for me (Vodafone IT).

1 Like