Xperia 10 II - Unable to log in to Dropbox

Hi,

I have upgraded my Xperia X to an Xperia 10 II.

I backed up my Xperia X to Dropbox.

Now I am unable to login to Dropbox on My Xperia 10 II.

Does anybody know a workaround for this?

Thanks

3 Likes

From the release notes:
Signing into Dropbox works via Google only. So, after triggering the sign-in at “Settings > Accounts > Dropbox” and the browser page dropbox.com appears, tap “Sign in with Google” (if you have a Google account).

1 Like

Since avoiding google services is one of the reasons for using SFOS this aspect is a bit … strange. Let’s hope for the next update

2 Likes

I use Sailfish to avoid Google thanks.

1 Like

A very hackish workaround is mounting the Dropbox as External Storage in a nextcloud/owncloud instance, and then access the files through that.

Actually, logging in with Google does not work either.

The Sailfish browser crashes after logging in to Google before connecting the Dropbox account in Sailfish account settings.

Do you still have the Xperia X with the data you need? And an SD card? Maybe forget dropbox altogether for now and go the solid state route?

1 Like

I logged in to dropbox, with copy paste of the url from the browser and sending it to my desktop, after that, doing the inverse with the redirect to my phone.

And wala! it’s logged-in, the problem is there I don’t have any app that connects to dropbox.

2 Likes

Yes, I have tried that. The Xperia 10 II does not recognise the backups from the Xperia X.

I also managed to log in to Dropbox with the Android app and download a backup from there - which the Xperia 10 II doesn’t recognise either.

1 Like

did you try to copy paste the link of the login to you laptop, and later come back to your mobile with the redirect link?

It worked for me.

Try copy paste the login link to firefox for android.
Worked for me.

1 Like

I copied and pasted into Opera and it worked as well, although I also can’t restore my backup from my XA2 Plus because it doesn’t see it.

Can’t even try copy-pasteing the link to another browser: adding Dropbox account only takes the browser to dropbox.com/developers which doesn’t get you anywhere (adding the account to the phone).

3 Likes

Since upgrading to the latest Early Access (4.2.0.21) today: signing in with the built-in Browser still does not work, but copying the URL into Firefox (Android) I was able to complete the login and the account was added into settings. And I can share files and do backups into it!

3 Likes

I encountered this issue too. In my case it arose when I restored a backup (from memory card in this instance), and in doing so restored a Dropbox account in settings.
It can be overcome by deleting the Dropbox account and re-adding it.
The Firefox thing works.

Sorry this is a bit late. I’m not sure if this will work for you, but I found that SF wasn’t recognizing a X 10 Plus backup from Dropbox, but managed to get it going by doing the following:

  1. Create a new backup on Dropbox. This creates an Xperia 10 II folder there.
  2. Log in to Dropbox from a browser, and delete the newly created backup and copy the one you want to restore into the Xperia 10 II folder.
  3. Go to Settings>Backup, and you should be able to restore it