Impossible to login to Dropbox or OneDrive

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): YES


It is no longer possible to login to an existing Dropbox or OneDrive account.


Existing Dropbox and/or OneDrive account


  1. Go to Settings/Accounts
  2. Add either a Dropbox or OneDrive account
  3. The browser is then opened to take you to the sign-in web page
  4. Enter the correct account credentials on the sign-in page
  5. You are told the sign-in has been successful and that you can close the browser page
  6. Close the browser page and you are taken back to the settings/accounts/ Dropbox or Onedrive account screen
  7. The screen has a rotating circle with the message ‘Updating Account’
  8. You are then taken to the accounts page
  9. Immediately you get a notification ‘Account needs to be updated’
  10. Click on the notification - you are taken to Settings/Accounts
  11. Under the relevant account it says, in red, ‘Not signed in’
  12. Open the account and you get ‘Sign in via Browser app’
  13. Repeat (3) to (11) above - same result every time


You are signed in to your existing Dropbox or OneDrive account


You cannot sign in to your existing Dropbox or OneDrive account


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

  1. All other accounts - email, Jolla, caldav, where no browser based sign in page is required - all work fine
  2. Speculation - there is a bug in the new web browser engine such that the sign-in token is not being passed back from the browser correctly or at all (Sailjail?)
  3. This worked fine on 4.3
1 Like

Are you using ‘sign in through google’? The non-google login was broken from around 4.1, this one works (but have to remove/readd it after loading a backup) or was working in 4.3

Nope, For the OneDrive account you are taken to the standard Microsoft sign-in web page; for the Dropbox account you are taken to the Dropbox standard sign-in page.

There was one thing (step) I forgot to mention, in that with the Dropbox sign-in the browser also displays a ‘Do you want to authorise Sailfish to access your Dropbox account?’, to which you reply ‘Allow’.

This same process worked fine on 4.3.

Are you sure you logged in google-less in 4.3 and not earlier? It got broken around 4.1, I had an account setup from like 2.0 and it was working alright all up to 4.3, when reflashed for the first time finally and learned it got broken in the meantime, since 4.1 only ‘sign with google’ is working, so it seems it’s the same in 4.4

‘Google-less’ - nice phrase :laughing:

I don’t have an active google account so I know I can’t have logged in the-opposite-of-Google-less!

But can I be sure I logged in ‘google-less’ using 4.3? … not 100%

My Dropbox account is very old, so its quite possible I logged in to that prior to 4.1 and its stayed logged in ever since, but the OneDrive account is quite new so I am reasonably sure I have logged into that for the first time on SFOS in the last year or so - so maybe not 4.3, but possibly 4.2 or 4.1.

The XA2 I’m using at the moment is a freshly flashed, so again its possible I am seeing a ‘delayed bug’ in this respect. If so, then this presumably means I can’t use any of my cloud accounts on SFOS without setting up a Google account first - the irony being that I am using Sailfish to get away from Google :disappointed:

1 Like

Yeah, so most likely dropbox login was pre 4.1 so bit of an old issue sadly (Xperia 10 II - Unable to log in to Dropbox - #2 by vige) loss of OneDrive might be new

I’ve tried logging in to DropBox with the latest Sailfish OS 4.4.0 and didn’t experience any issues. This was either using the browser to log in, or via the Settings app (in the latter case I was able to upload an image using sharing).

So it would be good to explore this further as it should now be fixed.

@Steve_Everett, would you be willing to collect some logs? If so I can post instructions.

1 Like

Oh wow thanks, works for me, definitely was not working in 4.3

1 Like

I can add some more info here…

So, after many, many attempts I finally managed to login successfully to dropbox - which was good because that’s the cloud service settings/backup uses in automatic mode and I hadn’t been able to do a cloud backup since upgrading to 4.4 (why can’t automatic backup be configured to save to an SD card? Manual backup can, so this seems illogical).

But then, the next day ‘Could not Upload Backup’ was displayed as a notification. Why? Because I was not signed in to Dropbox. So at some point between successfully signing in to Dropbox and one successful backup being uploaded, I got signed out again.

Then we were back into the ‘circle of futile login attempts’ as described in my bug before being successful again, but this time only for a few minutes before being logged out. During those few minutes though I could indeed upload stuff to Dropbox.

So it seems that, with the patience of a saint and a great deal of repetitive perseverance, you can actually login to dropbox but it doesn’t last. There is a variable time ranging from seconds to hours before you are kicked out again.

So the bug may be slightly different to my original report.

Note that I still cannot login to Onedrive at all though.

Yes I can, though it won’t be immediate because I am away for a few days now.

Thanks, this is useful feedback. We may be able to find out more by testing this further, since previously I didn’t run the account for any length of time. If the Dropbox credentials are being forgotten, or blocked, then this should show up if we test it over a longer period.

That’s probably easier than collecting logs for the time being.

I’ve had the same issue that @Steve_Everett just reported about getting logged out from Dropbox.

Device/OS release: Xperia 10II/4.4.0

I signed in on the 6th April performed a Manual backup, and left it as my preferred Automatic Backup option (daily, 2AM, WLAN)

No backups have been made since (in fact the automatic backup hasn’t worked for me for years now that I think about it), and when I just checked it said I was logged out of Dropbox.

I’ve just signed in again and made another backup manually and will check back soon to confirm if it’s works tonight (and have changed the connection option to both WLAN/Mobile connection)

I do not know how sfos handles cloud storage and accounts. is a nice cli tool that can handle lots of cloud storage providers including onedrive and dropbox

1 Like

Arghhh … Just got logged out of dropbox yet again and auto backup failed :disappointed:

I thought Dropbox removed Linux support years ago? Is it supported again?

Not sure why you’d think that, there has always been a Linux desktop client.

They dropped support for non-ext4 filesystems a while ago and I think there’s only x86 versions of the client but otherwise it’s been fine.

Doesn’t work for me. The “Accounts” inside the “Settings” app re-directs to the browser to login. The browser tries to connect to and apparently fails over to some other dropbox page.

Hasn’t worked at all on 4.4 an I don’t think it did on the last version of 4.3 either

Hm, old news perhaps? I thought they discontinued desktop client support in 2018. My Linux machines and my SFOS phones stopped connecting to DB around then and I stopped using the client too. Here’s some articles about it from the time:

I am happy to stand corrected if support has been reinstated, though. :smiley:

All I can say is that this exists, is regularly updated, and works:

curl -O “
curl -O “

And the support page does list (some) Linuxes:

1 Like

I had a problem activating my dropbox account with 10iii. My db registration is old and does not use a google account.

The way i managed to setup the account is this:

  • delete old db account from settings
  • open browser and login to your db account, let browser store your db credentials
  • check your email account, db will ask for a login confirmation, acknowledge that
  • go to settings and add a dropbox account, the account will be created, a bowser window will open asking to allow permissions, accept that and signing in will complete successfully
  • Check your email again if db has asked for another confirmation

Test the account, eg sharing an image from gallery, it should work.

1 Like