[Release notes] Verla 4.2.0

The reason I asked about the release of 4.3 is this problem is acknowledged in the release notes at the top of this thread along with a statement it will be fixed in 4.3.

I don’t know what happened with the latest version of 4.2 but I had no problem with WLAN access on Android apps before this latest version.

right, didn’t see that - seems we’ll have to wait a bit then :slight_smile:

@babo you have to remember that this is EA release. You have to expect some issues.
If you want stable system stop using EA releases.


Technically, it only mentions that the lack of connectivity right after installing the Android support will be fixed in 4.3, not necessarily the lack of connectivity after switching between networks.

1 Like

On the OS update screen for version I get a message to remove the package “feature-xt9” because it could make problems with the update. I don’t have openrepos or anything related installed. What should I do?
Update: I just went ahead and it worked.

Upgraded to I got that same message about the “feature-xt9” package (also got the LONG list in the previous upgrade).

Out of interest I tested and noticed that while the Dropbox-signin still doesn’t work in the built-in Browser, I was able to complete it in Firefox.

Also I noticed that while adding an Exchange account still does not ask for the MFA, the account is added without errors. The built-in email app claims that it was able to sync Ok, and even shows my email folders, however the folders are all empty.

Are these purely coincidental, or have these issues been worked on?

Update to .21 went smoothly on X10II (Dual SIM). The AutoComplete typing lag seems to have been gone, also Android apps work ok when connected to WiFi. What’s left is to check battery life and also if switching from WiFi to cellular data is successful - with .19 I had to manually turn off WiFi.

Update went fine on XA2 (40mb)

no new issues found yet

You’re absolutely right. I’m at fault here. For some reason, I truly and honestly completely forgot that it was an EA release. I’ve been an early access subscriber since so long that I forgot about it (worth noting that I never had any trouble upgrading since J1)

But then again…

Introducing a bug and willingly passing it over to the official release promising a fix in an upcoming update, isn’t a thing Jolla regularly does? Shall we dig and search?

And… I believe I have posted having in mind the update rolled out today(13/09), which its announcement didn’t state any fix for any of the issues I mentioned/commented on.

Don’t get me wrong… Im happy and satisfied with SailfishOS, but Come On!!

  • Android apps losing connection?
    Doesn’t it feel like Jolla1 all over again? A book could be written on this subject/issue searching just TJC (and as an end user/customer I dont really care about the differences, challenges and specifics of the different implementations and android versions, etc… that we are all aware of).

  • Loss of telephone audio? No audio during phone calls? A few very quick finds:


However! It’s still an EA release. So I’ll gladly wait.
If Jolla actually fixes those 2 issues and they are included in the official release, I will then confess my ignorance publicly on here and I’ll gladly purchase 5 sailfishX licences just to support Jolla.


I just completed the second update

After downloading I was asked to deinstall the following packages before I continue installing:

… and more:

Since I didn’t install theses packages on my own, I decided to ignore this.

The new update works so far…

Sony XA2

Upgrading from to on my 10 II took ~890 MB and I’ve observed the same warning “remove the following packages because they may cause problems during the upgrade: $list_of_many_system_packages>”.

Other observations regarding the update process:

  • Very low screen brightness after reboot (when entering cryptsetup PIN and while displaying progress of the upgrade)
  • GUI upgrade seemed to hang at 0% after the reboot. Finally, I did a manual upgrade (ssu re, version --dup, reboot) because the progress bar was barely visible anyway (see above)

and some first notes regarding the update itself:

  • Sticky mode of app grid only works on the first page - the behaviour for the second page of app icons is still paging-only (just like in the previous version)
  • Predictive text input only works after installing from harbour and rebooting again

Same here …

Thank you Jolla for the Update!
Installed it right now and updated from to .
Download size was 40 MB.
Have to report that after the complete download, update and restart, I came to enter the encryption code, then it tried to boot, but doesn’t work but rebooted after a short time.

But after the second reboot, it runs fine, without visible problems. Storeman asked again for access to something, but only one time.
Phone seems ot work fine, including browser, LLs player, AllRadio, File manager, Books, Quanto Fa, Wunderfitz, Unplayer, Camera, Pure Maps. (tested)

Phone works fine!

edit: saw right now that browser is on (felt) double or triple speed! Thanks again Jolla!

Seems to be the solution. Could not reproduce crash yet since deactivating all alarms (and activating again afterwards). Thanks a lot!

today I successfully logged into the wifi of Deutsche Bahn ICE. I missed to hit the notification, so I opened the browser and entered http://neverssl.com as the url, which was redirected to the landing page. I could tick the required box and press the accept button, which wasn’t the case in previous versions.

Actually I’m on


yes, captive portals are working now in my case (hlb - ger, clicked notification, button worked now)

I still need to restart android several times a day because its permanently loosing connection with weak wifi or cellular. However, the browser was affected in the previous EA as well and is not anymore with .21

Edit: it just happened again. browser could not connect. switching into and from flightmode fixes it

1 Like

I think the phone remembers the brightness setting from last session. Maybe this value was set to the lowest in the update process.

Did you check the brightness setting in the upper menu? Is it set to lowest? If you set it brighter, does low brightness persist at next unlock or reboot of device? Or does the device now remember the last brightness setting?

I always set the brightness to the lowest value - but the screen is was much brighter when I startet the update. Therefore I do not believe that the phone remembered the brightness level.

1 Like

After yesterday’s update to, I experienced loss of telephone audio at least twice during the call. Audio did not get restored in next call fired immediately after previous call (call again). It restored after 1/2 hour without restart.

I too experienced low brightness when entering decrypting password and on upgrade progress screen, almost as dark as no background light (I was in a lit environment, so I couldn’t verify). I don’t think it’s related to, as I saw it when I upgrade to that version as well.