XA2 Ultra high battery drainage

on my XA2 Ultra
usual battery drainage used to be around 25% over 24 hours
i make a very moderate use of this phone
on the same usage with drainage got up to around 50% over 24 hours
with many “Battery discharging rate” peaks of 15% for several minutes which hardly look related to any special usage

is this a “feature” of this new
or is my phone dying?

may i expect a Jolla team expert answer on the subject?


I never managed to get anywhere close to only 25% discharge a day on my XA2+. Actually my battery hardly lasts for a full day. The level drops around 10-15% over night, with AlienDalvik stopped, and mobile data set to 2G only.
Recently I got my battery replaced but battery lifetime didn’t increase significantly, so I assume it’s the SW.

I get the feeling that sfos 3 was faster and more efficient

i would understand better your answer if a knew what means SW

i have 3.3 on a Fairphone 2 it is night and day compared to 4.5 on the XA2
Gps works, compass works, Browser works much faster + many other
in fact everything is better except some cosmetic

If I knew, it may be operating system, any service running in the background, or other apps. I just wanted to make clear, that I don’t think recent high battery drainage is caused by hardware.

Might be the same problems as others and I have with XA2:

1 Like

There are some ways to debug what is causing high battery drain. One is to check what is causing wakeups from “/sys/kernel/debug/wakeup_sources” and another is checking output of “journalctl -b --no-pager” for messages related to suspend, especially if something is mentioned preventing suspend. Also is AppSupport running?


thanks for your answer
could you be a bit more explicit about “/sys/kernel/debug/wakeup_sources” and “journalctl -b --no-pager”
i am a layman and do not understand what you mean
and AppSupport is not running if this means Android AppSupport
in the time battery drainage returned to the usual less than 10% over the last 12 hours night without changing anything in the setup

Open a terminal and enter:

cat /sys/kernel/debug/wakeup_sources
devel-su journalctl -b --no-pager

The password needed for devel-su can be set by enabling developer mode in Settings.

PS: It’s much nicer to work in the terminal from the comfort of your computer.
Also, log viewer apps exist.

Since the battery drain is so high, recently, every evening, before going to bed, I stop AlienDalvik and activate flight mode.
Most of the nights charge level drops by about 3% until the next morning. I think this is acceptable.

Serveral times a week it happens, however, that charge level drops by 30-50%. I have no clue, so far, what causes this huge difference. Maybe I should also try to terminate all apps before I leave the phone for the night.

It would be a good idea to identify the process which causes the drain overnight. Just use the top command in terminal or install Lighthouse from chum or openrepos and sort the processes by cpu usage. Such a high battery drain is often a sign for a crashed/hanging process.

Systemdatascope can also help as it provides very precise graphs about battery usage as well as cpu and so on.
Depending on how you close you zoom into the graph, you can also see the average consumption for a given period of time.
Excellent app IMO.

thanks for the answers

Android Support is always disabled on my device

it is difficult to know what is the involved process as it does not last that long and SysMon does not seem to provide any recording of what happened

regarding SystemDataScope
i downloaded and installed version 0.5.0-1.11.1 and i cannot go past the settings which do not get saved
so it does not work
Chum refuses to update it
by the way ChumGui is really an horrible thing on my devices it seems to never work as it should

Maybe this could help:

Especially the command

‘while true; do (echo “%CPU %MEM ARGS $(date)” && ps -e -o pcpu,pmem,args --sort=pcpu | cut -d" " -f1-5 | tail) >> ps.log; sleep 5; done’

Did you follow the instructions in the first page?
It’s a bit tricky on the first use. One has to launch it, initialize, wait, and launch again.

i finally downloaded version 0.5.2 from Chum and got it working (not that difficult)
i can see peaks of drainage at some times, very short ones, this is no different from what i could see from SysMon
i can record the graphs but that does not tell me what is the application or process that is producing these peaks

Yes, correct. But you can see if the sleep consumption is correct (average on XA2 is around 15mAh). Also, it gives some information on the triggering frequency of the processes. This is maybe an useful hint to help determining what is going on.

I also happen to have battery drain issues on XA2 and I started investigating.

I was able to test old versions of SailfishOS (oldest I tried was and still had the issue, so it is likely not caused by an update.

The only thing I know has changed is my SIM card: I switched from a SIM card without VoLTE support to a SIM card with VoLTE support (same operator). Since disabling 4G helps with the issue, perhaps this is linked.

I started my investigation by looking at the logs of ofono with 4G enabled and with 2G. There are much more logs with 4G.
The logs with 4G contains a lot of these:

Can't parse modem-handled proactive command

I tried with the most recent ofono from upstream and it cannot parse the input either, so I’m assuming the data is just plain wrong.

Does any of you have this error in their ofono logs?
Could you please tell me how frequent you see lines added to the ofono logs while the phone is not in use with 4G enabled (and tell me if you have the battery drain issue or not)?
(With 4G enabled, I have a few dozens lines every minute, while with 2G, it I can see 10-20 minutes between 2 log lines.)

I’m not sure yet where the input comes from and if we have control over it, but I’ll continue my investigation.