Upgrade to 4.6.0.13: Cannot unlock phone and other weirdness

REPRODUCIBILITY: every boot after upgrade
OS VERSION: 4.6.0.13
HARDWARE: Xperia XA2 Ultra single SIM
UI LANGUAGE: English
REGRESSION: n/a

DESCRIPTION:

When I boot into the upgraded OS:

  • I can enter my passphrase normally the first time (white on black)
  • it boots to the lipstick UI, however my ambience has been replaced by the default blue lighthouse
  • I cannot swipe left or right or otherwise unlock the phone. The dialog simply does not show up
  • everything that does not require to unlock the phone appears to work normally
  • I can switch to the Guest account (which I set up some time ago iirc) and use it
  • I can shut the phone down normally
  • I have not tested calls or messages, but email appears to be working normally

PRECONDITIONS:

Upgrading from 4.5.0.25 => 4.6.0.13 through the UI.

Before upgrade I got a “Please remove or revert the following packages” message. Since there is strong opinion on this forum that this message basically means “If you continue, these packages will be removed” I continued with the upgrade, of course only after taking a good look at the list: angelfish, optional KDE/Qt packages, some more Openrepos/Chum packages. And aliendalvik. OK, I thought, that shouldn’t break the system.

STEPS TO REPRODUCE:

  1. upgrade as described above
  2. reboot

EXPECTED RESULT:

I can continue using the phone as before the upgrade, with all my user customisation/data intact

ACTUAL RESULT:

I cannot unlock the phone and it seems that some settings (ambience) have reverted while others (Email, top menu customisation) work just like I configured them.
I can shut the phone down normally.

MODIFICATIONS:

Chum & Openrepos are installed, as well as some packages from there. I tend to sometimes edit system files, most notably some additional configuration to /etc/ssh/sshd_config*. I manually created desktop launchers in ~/.local/share/applications and edited some under /usr/share/applications. User scripts in ~/.local/bin. Probably more.

ADDITIONAL INFORMATION:

  1. Booted into recovery & telneted into the system.
  2. Unlocked & mounted /home
  3. Chrooted into /rootfs.
  4. Enabled persistent storage in /etc/systemd/journald.conf, undid steps 3-1 and then repeated them.

In the chrooted system I gathered some information.

I can look at last boot’s journal entries. Looking at errors only I notice this:

XA2 fpslave[2359]: fpsettings_scan_directory: /usr/lib/sailfish-fpd: can't open directory: No such file or directory

There are 3 fpd/fingerprint packages installed: sailfish-fpd sailfish-fpd-slave-binder sailfish-devicelock-fpd and none of them list this path (see zypper listing).

Beyond that I’m honestly stumped as to what might be happening.

Here is all the output I gathered:

journalctl, errors only
journalctl, grepped for fingerprint
full journalctl output for the last boot (journalctl -b -1)
zypper listing all installed packages

Hardware and OS version:

bash-5.0# cat /etc/*release*
# This file is copied as hw-release (analogous to os-release)
NAME="Sony Xperia XA2 Ultra"
ID=h3213
MER_HA_DEVICE=h3213
MER_HA_VENDOR=qualcomm
VERSION="1.0.0.8"
VERSION_ID=1.0.0.8
PRETTY_NAME="Xperia XA2 Ultra 1.0.0.8"
SAILFISH_BUILD=8
SAILFISH_FLAVOUR=release
HOME_URL="https://sailfishos.org/"
NAME="Sailfish OS"
ID=sailfishos
VERSION="4.6.0.13 (Sauna)"
VERSION_ID=4.6.0.13
PRETTY_NAME="Sailfish OS 4.6.0.13 (Sauna)"
SAILFISH_BUILD=13
SAILFISH_FLAVOUR=release
HOME_URL="https://sailfishos.org/"
NAME="Sailfish OS"
ID=sailfishos
VERSION="4.6.0.13 (Sauna)"
VERSION_ID=4.6.0.13
PRETTY_NAME="Sailfish OS 4.6.0.13 (Sauna)"
SAILFISH_BUILD=13
SAILFISH_FLAVOUR=release
HOME_URL="https://sailfishos.org/"

PS: I have seen this but it does not seem to help/apply here.

1 Like

Small addition: I performed the filesystem check offered by the recovery script. Apparently all is good, no errors reported.

Still investigating. I have trouble parsing all that journal output.

Found this in the full output:

systemd[1]: Stopping Dispatch Password Requests to Console...
sailfish-fpd[2356]: *** SLAVE TERMINATE
sailfish-fpd[2356]: sighnd_handle_signal: Got signal [15] Terminated
systemd[1]: Stopped target Remote Encrypted Volumes.
fpslave[2359]: fpcontrol_master_rd_cb: master hangup

And a little later:

audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=sailfish-devicelock-encsfa-fpd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

I have no idea if it’s normal to start/stop the fingerprint service(s).

I can’t look at systemctl status output in the chroot, and I can’t ssh into the phone when it’s booted into the UI.

I just realized looking for fingerprint problems only is a logical error - I should be looking for device lock problems.

I have the same problem, when i do the upgrade, i can not get past the unlock screen and get the blue lighthouse ambience. I also noticed that on bootup the time the spinning circle is shown is very long. Ido not use device encryption.

1 Like

Oh that’s interesting.

So you do get an unlock screen? Is it for the SIM PIN or the OS (mine is for the OS; afaiu a passphrase or PIN is mandatory even without encryption)?
And whatever you enter, you’re stuck there?

Are you still hoping to find a solution?

I do; SIM card currently resides in a different phone.

I tested the update to 4.6 about 5 times, i was always greeted with the blue ambience. I thought it was patchmanager related, so i uninstalled all patches, checked if the fpd packages were updated, reinstalled lipstick packages, since i could access the phone via ssh. Tried sfis-upgrade, nothing helped. On one installation attempt it worked, but the system wasn’t properly updated, half of the new packages were missing. I just restored my old rootfs and home backup and gave up.

Lucky you, I don’t have the option to redo the upgrade.

Currently reading [Release notes] Sauna 4.6.0.11 - #124 by mjtorn and onwards (@nthn - @mjtorn dialog)

I managed to get in via ssh.

I mean while the full OS is running, not in recovery. By some fluke I was able to connect to wifi without any unlocking.

Now things look much better.

I seem to remember olf had a nice command line upgrade tool somewhere.


edit:

Nope, that didn’t work either. Not the upgrade, not a downgrade to 4.5.0.25.
I had to reflash in the end. Read on…

1 Like

So. Let’s recap. After the initial problem as described I had to do a full re-flash of the OS.

  • I had a very specific issue: not being able to unlock the phone and no custom ambience.
    No messages or hints in the logs either, after apparently succesfully upgrading from 4.5.0.25 to 4.6.0.13 through the UI.
  • I reflashed the phone completely, and after a reboot it works normally, as expected
  • I had a full backup of the complete /home folder and moved defaultuser into place while in recovery. After a reboot, I have the exact same problems again!
  • So I moved the original /home/defaultuser back, and voilá, it works again like a freshly-installed SFOS.
  • I tried moving parts of the folders under the backup /home/defaultuser into place on the new /home/defaultuser, one subfolder at a time, rebooted, and it always worked again (except for the ambience), all the way until I replaced all folders with their backed-up versions. In other words, I now have /home/defaultuser completely restored from backup. The only thing I changed was to copy the two empty files jolla-startupwizard-* from the new ~/.config to the restored.
  • Then I also replaced the folders /home/.system and /home/.android and /home/appsupport-root. I’m honestly no sure about /home/aquota.user anymore. I did NOT replace the zypp cache directories.
    Everything still works after a reboot.
  • Then, just for shits and giggles, I moved /home/defaultuser as it was created during the flashing/first boot back in place. After a reboot, still works. Then I moved the originally backed-up /home/defaultuser in place again, and voilá, same problems again.

Now I moved my strangely “recreated” /home/defaultuser back again and it works and looks just like before the upgrade (well, after re-installing all the software), accounts, calendars, top menu customisations, everything except for the custom ambience.

Each of these changes was performed in recovery, followed by a reboot into the UI.

My buest guess: while the upgrade itself went OK, something inside /home/defaultuser broke it.

I thought I could trace it back by gradually replacing all subfolders, but could not because it fixed itself during the process.

In case somebody has an idea what to look for, I still have the pre-upgrade backup and a backup of the newly created /home/defaultuser.

1 Like

If people could just disclose that they broke their home folders so the rest of us could ignore those “bugs”, that would be great.

I explained it well enough, your summary is disingenious at best.

If you don’t want to read it, don’t comment on it.

You’re getting increasingly toxic, attah.

2 Likes

Or wait… the initial problem was not related to such a restore? In that case; sorry!
I read your last post as recap of full process, not recap of troubleshooting.

1 Like

The exact same problem (device boots to interactive lockscreen, but there is no unlock option) happened on our device. Creating a new home directory and copying over all files also fixed it. I tried running diffoscope between the old and new directory trees, but I couldn’t find any meaningful differences (there were some minor permission changes, but recreating the old permissions made no difference), seems quite cursed :person_shrugging:

1 Like

I seem to have a similar problem.
Just updated a xperia 10ii - at the end it said: Update didnt work and restarted.

But now everytime i restart it only shows
a) the message that the bootloader is unlocked (same as before when it worked)
b) the option to enter the password for the first time (same as before)
c) the screen blinkin white for 2 times shortly sayin the words “no apps started”

After that nothin else can be done with the phone keys (only hard restart).
No error messages appeared before the update.

Any idea what i could do?
Its quite late already - so i have to try to get it working tomorrow.
Maybe someone has a tip - as i never had a problem during the update and it is my daily driver.

A friend of mine had the same problem today. He also did not have a working backup.

What we did in short:

rebooted phone from hybris recovery image.
(we needed an older one than 4.6. Only 4.3 was available but that worked just fine.)

Start phone to recocery mode
Connect USB
Choose Option 3: Terminal/Shell
telnet from computer to phone
mount crypted device to chroot
sftp all relevant data from /home/defaultuser to computer
reflashed device
sftp data via shell back to /home/defaultuser

@nephros pointed to the relevant documentation and suggested also a solution via SD card.
The sftp thing was easier for us and we didn’t succeed in mounting a SD card.

well - then i have a big problem.
I always had the bug that i can not turn my phone off - it instantly reboots.
So i tried some time now with the instructions for xperia 10ii - but i fail at the first step already: turning the phone off.

What i was able to do was get an (sadly about a year old - but better then nothing) backup tar file from the sd card. But thats all

update - somehow i managed to get the led blue - which i did by trying out the instructions i found on the “how to install sailfish x” page - which mainly was:

Switch off your phone and wait until the LED is off .
3.2 While the phone is off, hold down the Volume Up button and connect your phone to your computer via USB cable.

so basically i rebooted and then connected to the cable + pressed volume up (not up+down as written on the recovery page).

So far so good.

Currently downloading the latest sailfish image as told in the instructions.

I keep you updated.

edit. sadly i get an error message and it immediatly jumps out of the recovery mode:

The comand:
sudo fastboot boot hybris-recovery.img

results in:
Sending ‘boot.img’ (24068 KB) FAILED (Write to device failed (Cannot send after transport endpoint shutdown))
fastboot: error: Command failed

After that the phone reboots. This error comes every time i try.
With
fastboot devices

CQ3001JEYX fastboot

is shown - so connection seems to be there.

If it keeps rebooting I have no idea. I am sorry.

You should be able to force the phone to power off by pressing both Power and VolUp buttons down at the same time and holding them down until the phone vibrates three times.

I already tried that trick before - doesnt work since i have this phone - just reboots.
Still - poweroff is my smallest concern.
I ordered a Xperia 10iii now - since the battery of my old one was quite down already.

If theres some way to get the broken phone to work again.
So far i couldnt figure out how to solve the error i get when i try : sudo fastboot boot hybris-recovery.img