The Volla 22 (Gigaset GS5) Thread

It’s no problem. One should use encyption :slight_smile: I will use it.
The problem with sim cards exists (vers I have two cards (o2 DE and Play PL). The first card starts when the second are deactivated. After reboot you could activate the second card. It’s a workaround but one could unterstand it. I hope it will be solved in the future

Ah, I understand. That’s a different SIM card issue :slight_smile: But probably related.

1 Like

Just a heads up. Found a new Rephone (6GB ram, otherwise GS5) for 169 euro. Flashed vollaos, which did not come up (?) and continued with the sfos flash, all’s well. So far: usb file transfers, photos, videos, wlan all work fine :wink:

1 Like

Have you changed the script…Rephone not k69v1_64

Nope. product: k69v1_64 installed fine.why do you ask?

Has anyone every compared the performance of SFOS installed on a sd card vs installed directly on the phone?

I am not really sure if I should install it directly to overcome some glitches, like sometimes problems with the music and pictures database and so on.

1 Like

I’m thinking the same thing. I have Sailfish installed on the SD- card and at least using Waydroid slows down the phone and eg. gestures are sometimes sticky.

This is a reply to The Volla X23 (GX4) Thread - #6 by ric9k

@ric9k: I don’t use any Android apps so I don’t need/use waydroid. But waydroid should work: The Volla 22 (Gigaset GS5) Thread - #202 by Seven.of.nine

Oh, yes, ok, thanks.
Sorry, realizing I was a bit too concise.
I just thought you meant there was no way to use Android apps (but you meant there was no Android App support).
Hence Waydroid is possible and I read here that it was working well, as well as the camera, gps and the rest, globally.
So, as soon as my XA2 dies or gets adopted by a friend, I’d enjoy trying one of these Gigaset!

I’ve cracked. I found a GS5 new (they say, screen sticker seems in place from origin…) for 150€ which is the best I’ve seen around here since month.
So well… I’ll follow the links and guides found in the first post as soon as I receive it!

1 Like

So, I re-read this thread, I think I found how to flash the GS5 (not lite) when it’ll arrive.

  1. Download the last testing from here:
    which direct link is this, at present moment.

  2. Unzip (Android SDK must be installed).

  3. Press Vol UP and plug the phone, check if the blue led lights (I suppose)

  4. cd to the unzippzd dir and run as root.

  5. Into the phone, with devel-su, Update with

ssu re #(at the moment, but to be adapted from here)
ssu ur
zypper ref
zypper dup

Am I correct?
(I’m afaid to brick my GS5-not-lite as I flashed some N900 and XA2 only but never a ported one)


Have a look here … Index of /obs/nemo:/testing:/hw:/volla:/halium-mimameid: … Download, extract, cd there and run the ~ no warranty but should be better. Enjoy.

1 Like

This is not necessary/possible on the GS5/Volla 22.

I have to admit, out of an excess of caution (since flashing the wrong phone once) I’ve first:

  1. Made sure in the stock android that USB debugging and OSM flashing are on (using fastboot flashing unlook)
  2. Double checked that fastboot works and that flashing is permitted
  3. Installed the volla base using ubports (since it’s in that context that @piggz has been doing the ports)
  4. Then flashing and updating as you describe from 4 on.

The last install I did was a rephone. In that case, I was curious to see if android comes up and it DID NOT boot android. So, I just flashed SFOS anyway and it just worked. The GS5s I’ve flashed VollaOs also always worked.

1 Like

This is more a note to self, but I believe that Gigaset, Volla and Rephone all use the same base images from lineage. I dimly remember while doing too many things in parallel, flashing a GS5 (my first one which runs fine) that I just unlocked the stock Android and flashed. But I would not do that again.

@piggz, I’m assuming you always have a volla android flashed first?

1 Like

I do …however, because the V22 build flashes the entier super partition, it wipes both system and vendor, so, I include a vendor partition in the sailfish build. So, it shouldnt really matter what the base image is.


Thank you @piggz and @poetaster for your answers.
I am delighted!
Beautiful to see SFOS on an affordable and promising device like the GS5.
Beautiful to be able to try other devices than supported ones.
Beautiful to be free from, mainly, you know who and you know who :–)

Out of curiosity, I wanted to see this UbPorts-installer and VollaOS.
So I began with them, even if not mandatory.
Then I flashed SFOS as described above.

First sight: Perfectly booted, phone works, SIM is seen after some reboots.

But there is only 45MB of free system storage.
I didn’t find how to free some more storage.
Are there some files to delete?

1 Like

Boot in recovery…factory reset and wipe format data

Thanks. I tried but then, the decrypt password (first one) was not working anymore.

Yes, if you delete the user data (which you have to to free up the space), you have to flash again. But the user data will be gone and on flashing you should have about 5.x GB of space on the root partition.

EDIT, I forgot that the last time I did a flash after doing a volla install (Rephone). So I had to flash again after wipe/format. I haven’t tried it yet, but @piggz suggests you could just flash a GS5 directly, without the volla os install, but you’d still have to wipe the user data as @teracube says one was of the other.

1 Like

Cool, great.

Done. Working great, including SIM card after some reboots.
Strange, vibration (enabled in settings feedback) was working but not any more.
Vibrator works in CSD tool though.
I’ll try to flash once again.

1 Like