The Volla 22 (Gigaset GS5) Thread

Indeed. I always turn that off and hadn’t noticed that the option is actually on! Hmmm.

Maybe @piggz , you would have an idea on how to fix vibration feedback? (vibrator works in CSD tests but not with keyboards or menus)

Saying once again but it’s really nice to have SFOS on a phone with a good camera and GPS, fast processor…
I could easily upgrade to with the zypper commands found above.

I have some other questions. Perhaps one of you folks know the answers:

I do backup the entire system on my XA2 by booting in recovery console and issue a:

dd if=/dev/mmcblk0p76 of=/some_file_on_microsd bs=16M
So I have both / and /home saved at once in a file, with all settings, apps and so on.

On the GS5, is there a way to
-have a recovery console? (i.e. what image to flash with fastboot?)
-discover where the partition hosting / and /home are?

Is there a way to use the wide angle rear camera?

Construction material
Did you also notice how crazy the GS5 is slippery?
It’s even self moving very slowly but certainly, on almost flat surfaces, especially paper.
E.g. try to dispose it on a toilet paper roll (no joke, sorry, it’s the very best example). Observe it for a while!
Or some folded paper sheets. The folding is a bit higher. The phone will surreptitiously move. Once, it fell while I was looking somewhere else.

1 Like

The bind-interfaces can create others problems to others network stuff especially when interfaces come up and down in combination with evolute network services like dnsmasq and the DNS Alternative which contains dnsmsaq plus others service to proxies the queries. I suggest to try bind-dynamic instead.

1 Like

I just noticed that, unlike on the xperia III , you only see camera 0 in advanced camera. So, @piggz?

As far as dd is concerned, also one for @piggz

The rephone is less slippery :wink: I bought caseroxx bumpers for both. The GS5 bumper is perfect. Fitting the same one on the rephone is less ideal, but still works.

It is a shame that it has not being equiped with OLED / AMOLED display

IPS Display mit einer Auflösung von 2340 x 1080 Pixel

It would save some energy from battery with pure-dark theme (and it is nicer).

The rephone has 6GB of RAM instead the GS5 like the Volla 22 has 4GB, only.

I dont find the Caseroxx cases/bumpers.
Would you have a link or a hint?
Thanks /itm/195738043517?var=495598182641

Edit, also on Amazon search for caseroxx gigaset gs5

Oops, I only searched from the phone with duckduckgo :face_with_open_eyes_and_hand_over_mouth:

I encountered the SIM problems after a reboot. Didn’t came back even after several reboots.
Close to your procedure, this was also working.
In short, principle seems to be: enable the SIM when the phone is fully booted.

In details, what worked for me was:

  • disable SIM slot 1 + Enable SIM slot 2
  • Power OFF
  • Insert SIM in Slot 1
  • Boot
  • Enable SIM slot 1. It will ask for the pin code.
    So it seems that SIM is not recognised while booting but can be, after.

PIN Settings page does not allow to disable both SIM.
But if we could disable both, there would perhaps be a way to have 2 SIM working. :thinking:

Is there a way, by command line, to bypass the Settings restriction and disable both SIMs?

Interesting. Just happened to me for the first time in months.

  1. Sim settings unchanged from 1 on 2 off.
  2. I went to the PIN settings. Tried to set pin. faills.
  3. Shut phone down. Turn it on.
  4. If you are greeted by a login immediately, you’ll get a PIN request too.

I haven’t tried moving sims around. I’ll try with turn on 2. Turn off 1, etc. next time.

1 Like

It’ll work now; there wont be a next time. :innocent:

I’m sure @nephros knows how to turn both SIM slots off through command line.

1 Like

Heh, I’m sure he does :wink: since 4.5, although other things suck, the sim/pin thing seemed ‘settled’. guess not. interesting debugging coming for sure. :slight_smile:

I’m drying.
Searched for “You must have at least one SIM slot enabled” (pops up when one tries to disable both SIM slots). But as error messages, they are stored elsewhere than in the searched files.

Maybe something interesting here?:


Unfortunately I don’t.

I’m guessing such things are managed through some Android daemon/utility, qcrild or so?

radio     3767  3133  0 Jul02 ?        00:01:30 /odm/bin/hw/qcrild
radio     3770  3133  0 Jul02 ?        00:06:03 /odm/bin/hw/qcrild -c 2

I’d try killing that second one on a hunch, but it probably will restart through doid-hal-init.
(and these are from a Sony, not Volla)

Maybe that’s a question for the porters IRC or XDA?

1 Like

Well you can probably hack the first one to disable all the checks.

I wonder why switching both sims off is guarded against though…

1 Like

There is also the ofono-tests package which has all kinds of tools, including a ‘disable-modem’ one…


Ah, thanks for the tip. Might help us gather some info for @piggz

Vibration solved: It was set too short. Discussion and details here.
…hmmm… Setting the vibrator to vibrate longer makes a real difference. It just works. But after a while, it stops working at all and doesn’t even respond in CSD tool anymore. Hardware problem. the trick was necessary for my GS5 and works.

Really cool to have ths port!
By the way @piggz, I know you mentioned Paypl and IBAN but from Switzerland, both charge fees to money transfer. Is there another way, a free one tha I could use to buy you some beers and coffees?

heh, not sure, what else is there? any suggestions ? :slight_smile: