Sony Xperia 10 III experiences?

Hi All,

I’m new here to the forums and have been a long time SailfishOS user. My first SailfishOS phone was Jolla’s first phone, and since 2018 I have been using a Fairphone 2 with SailfishOS (which is a community port).

Since my FP2 is starting to show it’s age i’m looking for a new phone and i found the Sony Experia 10 III to be relatively cheap, available and officially supported. For SailfishOS I don’t need the Android and exchange support so i guess i can go with the free edition.
My requirements for a phone are: Dual sim and removable storage. Since the Sony has enough internal storage for my needs just a USB stick for an occasional backup would be more than enough.
The apps i use are very modest: Calls and SMS messages, the media player, and osm scout for offline maps and navigation.

Is anyone able to share some experiences with the Sony Experia 10 III? I’m especially interested in battery life (my FP2 just makes it 24 hours when 100% idle) and i’d hope for at least 3-4 days with minimal use.


The battery is capable to work 3 days and with little use longer. I had no prblems with installing Sealfish and everything works fine.

I’m in a similar situation: the SIM slots in my Xperia X stopped working, and I’m considering my next move (while I am getting by with an old LineageOS release on an ancient Wileyfox Swift: I am finding this quite hard work :sweat_smile:). TheXperia 10 III does seem like a nice device.

I am worried by the many reports of problems with SFOS 4.5. If anyone can clarify whether a newly-flashed Xperia 10 III is a good daily driver (as opposed to one that has been updated from 4.4) it would be useful.

I would also be interested in hearing about how well Android support works on this device. (@pa4wdh I hope that this doesn’t look like I am trying to hijack your thread, but it seems best to keep requests for comments in a single thread :wink:)

Of course you will only hear the complaints. And it seems the complainers only ever get louder and louder - without any correlation to what’s actually going on.

I don’t know where you get the impression that this would make any difference.

Perhaps barring the extra ipv6 woes on some networks, the III is just as good as a daily driver as anything else.

It’s Xperia!

It’s called Sailfish!


Thanks for your replies.

So far it seems to be worth a try to buy the Xperia 10 III.

@attah Thanks for correcting me on the phone’s name. Xperia gives quite some more search results than experia :slight_smile: .

@pakman It’s alright :slight_smile: . I couldn’t care less for android support, but that doesn’t mean others have to do the same.

1 Like

I’m using it for a couple of weeks, and I love it.
It has a couple of issues (I can’t use my micro sd card because sim slot 1 is not reliable as a data connection for me, echo during calls (lowering the volume seems to help), camera is a bit crippled because camera2 API is not supported on 10 III), but I am very pleased with it overall.


Bizarrely, this week. The battery ran down and I recharged it. I restarted it and moved on.

Later, someone emailed me complaining that my phone was off (which it often is (flight mode) anyway). However in this case neither SIM had activated, despite the phone being on.

A reboot solved the issue and it appears fine now

1 Like

Well, I have been using Sailfish since the first release for the Xperia X came out, and I have been following the Sailfish story since the IGG tablet campaign. I don’t recall as many complaints about issues with earlier releases of SFOS as with 4.5. To be fair, there have been some reports of successful upgrades, so it isn’t all complaints.

From the fact that in the past, the suggested fix for some problems has been a reflash (in some cases, reflashing back to Android, and then flashing Sailfish once more).

I think that it would be helpful if you could clarify whether or not this is a conclusion that you draw from your own personal experience with the Xperia 10 III, and if so whether you have upgraded to 4.5 yet.

To me, if you buy the 10 III you’ll have a pleasent experience. Just for performance, even my 10 first model, on SFOS, it runs very quickly. On stock SONY Android 10 it’s like chooopyness and slagginesh overload!

1 Like

I’ve been here since “The First One”.

Me neither; or maybe some earlier 4.x was about the same.
But i take that as more new and inexperienced users, and perhaps ever increasing standards SFOS is held against.
I.e. both these observations can be true - and i think they are.

This is true; but that has generally been when the user has broken their device.
The number of “oh, i had a patch active”, having installed something invasive, doing manual backups and not mentioning it etc etc is quite astonishing.

If it ain’t broken; don’t fix it.
There is no generic breakage from updating vs reflashing, and i don’t think there has been since the user name switch. Assuming there is some unspecified one is not productive to put it nicely.

No this is clearly visible on the forum.
I am however always on the latest phone and version - and that has been just fine historically. Not perfect, but just fine.

1 Like

I concur with others: i’m super pleased with my 10iii, Android supports work well (with my 10ii i had to restart it every few days otherwise it was stuck), and it’s a lot smoother than my 10ii.

No OoM killer issues either.

Tethering now works on SIM1 with the latest CLAT implementation - even though i have to restart conman from time to time - but i can deal with it.

VoLTE also works well.

Only issue is the lack of support of 3 cameras - i liked the wide angle on my 10ii!

1 Like

Oops typo, sorry Jolla Sailfish it is. :wink:

If you don’t intend on buying a license I’ve been testing the gigaset GS5, which has a replaceable battery with and it’s good. It’s a bit cheaper (about 230-270 depending on if it’s full or lite).

EDIT: I was really disappointed in the 10ii, which I only acquired as a test box (which it remains) so that I have a reference to what ‘official’ sailfish users experience. But if you’ve been using an FP2 (which I also had) you’d been happy with a GS5. For the savings, you can buy a spare battery :wink:

I’m literally BEGGING Jolla to urgently do something with two things that badly affect my blood pressure:

  • lack of any tone when calling someone via VoLTE whose phone is also on 4G. Nothing at all, pure silence until either someone answers the call or the connection times out. If the called number is busy then all you get is disconnection after a few seconds and you don’t even know the reason because you don’t hear the busy tone or any message. If someone just doesn’t pick up (i.e. when you’d normally hear the “free” waiting tone), you can’t even know if the connection was established at all as all you “hear” is silence and you just wait and wait hearing nothing. It is a SFOS problem, because my SIM card put into my wife’s iPhone does normally get the usual tones on VoLTE connections, and my wife’s SIM card inserted into my 10 III with SFOS starts getting silence. And this is a VoLTE-only problem (and only if both sides are on 4G), because if either party is on 2G (or 3G) it doesn’t happen at all.

  • the fingerprint sensor. The way this thing works on the 10 III on SFOS is a mental harassment. How can it work 100/100 on the XA2 Ultra while on the 10 III it locks and becomes unresponsive literally every few touches? I have never seen such a fingerprint sensor behavior even of lowest-end Android phones of manufacturers whose names I can’t even spell.

I’d happily trade it for VoWiFi support, which is also badly missing, and with quite shitty 4G signal level where I live my wife’s iPhone really benefits from it.

If by “work” one means not doing anything, then yes. But if by “work” one means any active form of use, then I’d say it’s up to some 1.5 days. Which is OK, but twice worse than with Sony’s genuine Android onboard.

The update caused no significant issues for me - there are always problems - that’s what this forum is for, but aside from the issues below, I consider it perfectly usable. My perception is that SFOS is steadily improving which each release. Android support works well for what I have tried, and I notice no penalty in speed or power drain. Bluetooth connects to a couple of different cars OK.

I have both Android and SFOS X10iii so I can compare directly.

The X10iii has no 4G VoLTE support in my country on any of the 3 carriers. You can’t make the Android one work, nor the Sailfish one, so this is not a SF issue. This is probably Sony’s doing. This is not an issue if it works in your country, but if it doesn’t 4G voice may never work.

GPS is slow and poor if you are not outside under clear sky. This seems to be an inherent problem with the Sony AOSP. The XA2 had it worse, but I suspect all the Sony’s AOSP suffer from the same underlying issue. This may not matter to you. I need to use GPS in the forest, and it doesn’t work.

Standby power drain is worse than under Android, but the phone is probably good for 2-3 days.

battery seems to be lasting 2 full days.
nice and responsive.
gps signal lock still seems pretty poor, though it does now work (unlike my xa2 plus).

i think it’s a question of grip - how you hold the phone. it needs a very specific angle with my thumb, but it works 100% of the time.

of course i first need to press the button to wake up the screen, release the button, and then press it a bit less to have fingerprint recognised

The non-perfect grip explains some of the failed readings, but not all. I can’t tell how often it happens (maybe once or twice a week for me?), but I have to restart the fingerprint sensor daemon every now and then to be able to unlock the 10 III without typing. The last time I did it was last night and the restart fixed the issue immediately.

Apparently it happens quite often, since there was a suggestion regarding Google assistant button and the fingerprint sensor daemon.

No, it is not a question of grip or angle, because it is not the sensor not recognizing the fingerprint but not working at all (being temporarily kind of blocked or sleeping and not reacting at all). I place my finger on the sensor, it does nothing, I keep the finger on it without slightest movement, and it suddenly wakes up after 5 or 10 seconds and recognizes the fingerprint.

I have a LED notification enabled in mce ( mcetool --enable-led-pattern=PatternFingerprintAcquired ) to indicate when the sensor is active, so I always know if it is a problem of fingerprint not being recognized (in such case the LED blinks but the screen doesn’t unlock) or the sensor not being active at all (no LED). And it’s almost exclusively the latter. Moreover, I can sometimes see that the LED lights up even when there is no finger on the sensor (e.g. when I place the phone close to some object) which then kind of blocks it for some time, like 10-20 seconds. So it looks that sometimes the sensor gets triggered by other objects than finger, which kind of temporarily disables it.

I have an identical (at least when it comes to size and location) sensor in Android phones (e.g. my mother’s Motorola G52) and they work for me in 100% of cases. My 10 III is the ONLY device that permanently gives me problems in this regard.

Lastly, I also identified the fingerprint daemon to be sometimes causing power consumption issues due to high CPU usage. This can be seen e.g. in Crest application - sometimes the /vendor/bin/hw/ process starts utilizing a lot of CPU time - and this is most probably when it gets locked and doesn’t react to touches.

That sounds interesting too.
Do you have some info on it’s battery life with SailfishOS and where i can find the port for the GS5?