[Solved] VPN ipv6 leaks with ivpn - 10III

Hi there,

I’am having a hard time configuring vpn while blocking non-vpn connections on my Xperia 10 III.

I configured the vpn follwing the official documentation and the interface shows a connected status but when I check my IP, the v4 is the expected vpn IP but not the ipv6.

  • I read this similar issue which concludes 4.5 should have solved the issue but not in my case it seems.
  • I read several other posts which made me update from to for CLAT support ; it didn’t help.
  • I also read a post about disabling ipv6 with sysctl, it didn’t do the trick neither.

Here is the config :

dev tun
proto udp
remote xxx.xxx.xxx.xxx 2049
resolv-retry infinite
cipher AES-256-CBC
dhcp-option DNS xxx.xxx.xxx.xxx
remote-cert-tls server
verify-x509-name fr name-prefix
key-direction 1
comp-lzo no
verb 3
;ca ca.crt

What did I do wrong here ? How can I fix this and get a full vpn coverage ?


Please read the CLAT debugging thread from here onwards - CLAT in is not yet addressing the VPN. You can contribute, by sending log files to the PR author, also here for tcpdump. If you have a public VPN provider which supports IPv6 (?), that would be a plus.

1 Like

Thank you @canne for pointing this feed, this answer from @Fubo solved the issue by disallowing ipv6 connection through mobile network : switching from dual to IP.

I would love to contribute to SFOS but I have very little time now. Will try to patch CLAT and submit the logs during the week-end.