SFOS fails to send MMS (picture share)


I’m using Xperia X Compact flashed with official Sailfish X release for Xperia X patched with g7 tool.
After update I cannot share pictures via MMS. MMS settings are correct (nju mobile).
It fails With message “Proble with sending this message” and no message body/attachement shown.
Snippet from system log here:

Can anyone with Xperia X/X Compact updated to SFOS 4.3 can check if sharing pictures via MMS works under

1 Like

Hi, on xa2 plus and 4.3, it’s the same

I can confirm it on my XA2

Same on my Xperia 10 II dual SIM. Nothing (except initial stuff) shown in MMS Logger.

I’ve filled bug report here:

guys feel free to add some comments there.

Hi guys,
which cellular operator are you using?
Were you able to send MMS with on the same device with the same SIM?
Does SMS work ok?

It seems that it does not depend on the operator. The failure happens before the transmission of the message.

1 Like

Nothing has changed in my case. Worked before, stopped after upgrade.
I have 1 sim, polish Orange provider.

Quite interesting. I have Polish Orange and I can send MMS from my Jolla C.

Sorry ,now I can received MMS, but I had to change my param. My old param didn’t work in 4.3

but I can’t save picture to gallery nor send MMS (but it’s an other problem)

If old parameters are wrong and you don’t want to have problem again (for example after flashing) you can make PR to this https://github.com/sailfishos/mobile-broadband-provider-info/blob/master/mobile-broadband-provider-info/serviceproviders.xml


operator: NJU Mobile (polish orange subbrand)
MMSes were working fine up to 4.2 (last send 16.10.2021), same device/sim
Same MMS settings on JP1, where I can send MMSes just fine.
There’s no problem with sending SMSes on both devices…

Problem is with contact book interaction I suppose. Just sent MMS entering a number directly. Tried both with an without country prefix - both has been sent.
Selecting address book entry makes send failing.

1 Like

Cool info, but didn’t work for me :frowning: Even with recipient as number it fails

Didn’t work for me

Internal bug filed. We need to investigate why sending the MMS fails in some cases.
Thanks for reporting.

See also: Sharing image via MMS fails after update


[7405]: [C] unknown:0 - Cannot copy message part file “/tmp/sailfish-share_A8tK3n/20211112_183111_1.jpg” to “/home/defaultuser/.local/share/commhistory/data/8041/20211112_183111_1.jpg”

I have the same problem on both Xperia X (newly flashed with SFOS and Jolla C (updated from SFOS 4.2), can’t send MMS.
Provider tre.se.

Can confirm this bug. Swedish operator Tele2 but I also dont think that matters as it fail before even trying to send. Nothing in log when using mms log.

Sending worked fine before update. Receiving mms still work. Both sending and receiving sms also work. Its just sending mms that is borked.

No changes besides updating to 4.3. Same device, same SIM, same settings.

Hm… RN states it is fixed. I still have problem sending/sharing pictures with MMS.

Anyone else still with the issue?

1 Like