[Release notes] Verla 4.2.0

Hi. In changelog is written that problem with MCE not providing memory level should be fixed. See original report: [][Xperia 10 II] Unknown memory level reported by MCE

Today I update my Xperia 10 II and I don’t see /dev/memnotify device on my phone. Was it upgraded properly? Do I have proper kernel build?

[root@Xperia ~]# uname -a 
Linux Xperia 4.14.239 #1 SMP PREEMPT Fri Aug 6 06:27:00 UTC 2021 aarch64 GNU/Linux

I started mce with --verbose flag (edit systemd unit file) and it logs to journal:

modules/memnotify.c: g_module_check_init(): memnotify not available

edit: I got reply in original thread. TLDR: Further tuning of memory limits may be needed…

Storeman does not work anymore, even after removing the app and installing Storeman installer.
I am grateful for every update but the most important features are still not functioning or missing:
making video calls with e.g. Telegram,
a properly working GPS
sharing facilities

Close button removed from the browser toolbar

That’s my go-to button to close tabs, and I’m not sure I agree with this change :smiley:
I guess I have to change my ways now.

For a real “yay!” - mpris by default! Yay! :slight_smile:

That’s for developers updates (as the name states :slight_smile: ) and something quite different from the Early Access that we’re talking about here. I assume it’s for Jolla developers whilst they’re testing/implementing updates, and as such us end users aren’t supposed to enable it.


The update to went flawlessly on my end :slight_smile: Thank you very much to the whole Jolla team for all your hard work, really appreciated.

Cheers, Samuel

My XperiaX update stopped when the progress bar was at 100%. I waited a while and forced a boot knowing that at the end I can have a bricked phone. Though the phone booted normally. One good notice is that now I can see what I write on this forum. Thx


The same here on XA2… Waited for an hour and made hard reboot. Device rebooted twice. After that tried to update via ssu, downloaded some files and finished. Seems ok now.

Link to Browser not working, e.g. if you click on a link in a mail northing happens.

For me sometimes when unlocking, the screen, just slowly wakes up, and stay quite dark in the beginning. Never had that before…

Like 50-60% of edge swipes are failing now, especially while the App Grid is opened. Am I the only one experiencing this?


unfortunately sound on my xperia 10 ii is still not working (see No sound - No microphone). Is there any chance to get this fixed somehow?

There no word about problems with scrolling the text prediction list, but it seems to be fixed. At least in my Xperia X and 10. :smiley:

Just updated my Xperia 10 II from 4.1 with no issue in the update process. No major issue so far.
Update 2021-09-02:

  • problem: Contacts in People no longer show pictures. The only way to add picture is to take a photo…
  • problem: Ordinary timer alarm did not play, but pops-up every minute or so (restarting phone solved the problem temporarily
  • problem: after 15 h uptime, phone blocks from time-to time (GUI freeze)
  • some application appear unstable: Fernschriber, Pure maps)

Wifi on all Android apps not working with flight mode on - wifi on. XA2.

No fix yet - the text prediction bar can get stuck. In such a case, try dragging the whole keyboard sideways, even as far as to another keyboard (another language). This should release the prediction bar.


This should work, no known problem with it. Just tried with XA2 and 10II - “SVT Play” (Swedish TV) and the speed test “FAST” worked ok in the flight mode via WiFi.

The browser seems go load faster…any reason for that?

Kind of sad that we didn’t get a browser engine update. I can’t login to my banking web interface with the current one.


Yep. While many many good things in Verla for X10 II, still being stuck on ESR60 for probably next release cycle months is a big disappointment.

If browser updates could be released on its own schedule, would be a huge win. Since it’s such a central-to-everyday component.

1 Like

It is a big task. Work in progress.