[Release notes] Struven ketju

Storeman allows to backup and restore a list of packages which are currently installed by it.
Another reason to regularly backup everything one can think of, but not to include Storeman in a …

rant about backup functionality>



Hi @cvwild & @tmindrup
I got the same problem with the android apps - nothing is showing up… I tried to reboot couple of times and tried to stop and restart aliendalvik over the terminal, but it didn’t help… do you maybe have an idea what I could try other than reinstalling the whole os?
btw. I am german too :slight_smile:
Thank you

Is there documentation for ExecDbus somewhere? I can’t seem to find it.

There is! Well, at least there is something, well hidden in Harbour FAQ.

1 Like

See SFOS 4.5 feedback thread - #193 by jovirkku

Hi, I started to download several times in the last 30 minutes. I can see no progress, even in the online-monitoring. I assume, too many people are trying this at the moment.

Did 4.5 leave Early Release? There seem to be more problems tan usual.

Yes. See at the first post of this subject.

It does not look very wise to me releasing an update that reportedly breaks Bluetooth.

1 Like

What does the following involve?

Audio functions of Android apps improved (application-specific audio streams, audio volume is consistent across reboots, etc)

I was hoping that would fix this issue I was having that would stop the media player when a sound plays in an Android app (the media player doesn’t start back after the sound is done playing).

Is this related in any way to the improvement of audio functions of Android apps?
Or could I fix this issue with “application-specific audio streams”?

Update got stuck on download. Restarted. Download started again listing tons of packages that I should remove before update… never heared of them… I don’t use openrepos. Update install started. Update got stuck on sailfish logo with bar reaching the S letter of the „OS“ at the end. Stil there after 15 min. What to do?

Xperia 10 II updating on batterylife…

After 30 min no changes. Plugged in charger.

Force turn off… system damaged. Does not start further than security code. Reflashing… :-(((( damn!

Xperia 10 II update = went smooth as silk

1 Like

Applies to my 10 iii too

During download, I saw the message:
the listed packages may cause problems
DeadBeef Silica
Chum GUI
2 packs related to DeadBeef packs

removed packages from Storeman

As I said during the download, I removed the mentioned packages that were mentioned that can do problems.

Xperia 10 III update = went smooth as silk

The installation rebooted itself at the end. I didn’t have to do any reboot!

At the weekend I will do an reinstallation. I did not found any other procedures to solve the problem.

Battery ageing protection implemented into “Settings > System > Battery”. This is to avoid the wear out of the battery. The user can set a limit (e.g. 90%) where the charging is stopped.

This is a good feature. No need for Battery Buddy anymore, i guess?

If you have backed up the file $HOME/.config/lipstick/applications.menu, you can find the folders and exact order for each application (that’s what I used to put mine back in place).

I wish i knew this. App grid was a mess after the update. After a while of rearranging i’m pretty sure some of the app icons are gone. (Yes, i waited for App Support to do it’s thing.) At least couple of MicroG related are not there anymore (Fakestore for example, and some other, can’t remember what). Though they are still installed according to Fdroid. And i’m not really sure if there are more missing. Never expected this to happen.

Also MicroG isn’t working properly anymore. Bunch of applications (like banking etc.) are nagging about missing Google Play Services. Signature spoofing seems to be working, and i guess most of the settings are properly set.

This makes me want to reflash the phone and start all over again. With no guarantee it’ll make any difference.

Nevertheless no other major complaints about updating. It did stuck at the 100% point of the progress bar, and i did have to perform forced power off.

I guess this is a good update, but holy crap if i have to spend hours and hours of reinstalling and configuring all the apps again.

Have you seen this post? It can be helpful.


I hope this solves your problem


Same with the Xperia 10ii. Also did then that keycombination to reboot. After reboot it was the 4.5 with appearantly no issues.
Started the android layer manually (i programmed it to not autostart on boot) took about a minute to start.
Everything look great. Starting to love Sailfish OS more and more.
Thanks Jolla!