[Release notes] Struven ketju

When I activate teh newly introduced volume bar on my XA2 Ultra, the distance between the ring tone volume bar and the new volume bar is bigger than the distance between the brightness bar and the ring tone volume bar. Maybe this can be improved in the future, because it looks a bit sluggish…

In total very nice update!


State of VoLTE?

After upgrading, i can see the VoLTE still being marked as beta. Which is fine, I guess, but given the Release notes do not mention VoLTE I’m wondering if anything has been done here?

In case it’s relevant: It’s not working for me - same as before upgrading to - and I have no idea how to further debug/help with this. Provider is Telekom in Germany, the configuration files seem to make sense but I’m not getting anything even after keeping it enabled for hours, it just keeps blinking.


Thanks for
Update process went through without problems on my X 10 II.
There was only one strange thing.
Yesterday I used threema for the first time again and noticed that all media files were gone.
In the chats there were only placeholders, even if I clicked on media overview in the menu.
Today I wanted to write a bug report, but all media files were visible again. Strange. I hope it stays like this.

Updated my Xperia 10 and the only problem was the phone didn’t restart automatically after the progress bar was full (yes, I waited like half an hour) and the phone didn’t register power button presses so I had to use the Vol Up + Power to restart the phone.

After couple of minutes Android apps came back to the app grid and to my horror they didn’t return to their previous places but at the end of the grid list and I had to visualise my muscle memory to get them to mostly right places.

After update banking apps complained about phone not supporting Google Play Services and either still worked or restarted when trying to login, but found out in other threads in this forum that updating FakeStore to version 0.1.0 (was 0.0.2 and F-Droid didn’t offer the update even when trying to refresh the repo, had to manually go to the FakeStore and update it) everything worked just like in the past without any nagging.

1 Like

Thanks for all who contributed to this released. I updated my X 10 iii, Gemini and X without any issues.
Many small improvements and paper cuts fixed. Hopefully, the echo in the 10III will be fixed, and I’m awaiting new features!

Well, BatteryBuddy has quite a bit more options to customize charging. Not only the upper limit but also the lower limit (when charging restarts), max charging current, etc.

I’ve noticed that, too. Looks ugly.


Thanks for the tip.

I updated Fakestore from 0.0.2 to 0.1.0, restarted Android App Support, but still the same complain about missing Google Play Services. I went through the settings, but everything were as they were when it worked. Then i noticed also Signal is saying the same.

I downgraded microG Services Core to an earlier version, restarted AAS, still the same. Uninstalled it and reinstalled the latest version again. Had to go through all the settings, since everything was reset. Restarted AAS, and then it started working. So that’s good.

So far i’m pretty happy with the latest update (yet noticed only minor issue with phone asking for USB mode when connected to a charger). I still would like to see all the missing features working, all cameras and such. But i’m patient, they’ll come around. Thanks to the devs for a good OS.

Edit: And of course all the other people at Jolla, not just the devs!

Updated my 10 III. Vodafone DE

Had to force a reboot.
Android Apps came back pretty fast.

Had to reinstall chum.
Had to move my offline maps for HereWego from SD card to internal memory. :frowning:
OSM Scout maps were also “gone”.

Phone, sms, threema, signal, telegram
WIFI, mobile data, GPS, hotspot, navigation work.

Thanks to the people at Jolla for this release

Problems with video playback in the stock browser is one thing, but using /etc/hosts on the Android side through /var/lib/lxc/aliendalvik/extra_config no longer working is a DEAL BREAKER for me. Anyone knows any solution for this?


Update from Xperia X and Xperia 10lll, was just perfect.

I couldn’t turn bluetooth on anymore (XA 2). Indicator in System was blinking continuously.

rfkill showed it was soft block.

[root@Beorn nemo]# rfkill
 0 bluetooth hci0     blocked unblocked
 1 wlan      phy0   unblocked unblocked

Unblocking and restarting bluetooth systemd daemon fixed the problem.

rfkill unblock 0 
systemctl restart bluetooth.service

Edit: No problem with Xperia X and bluetooth.


How’s Xperia 10 iii mk3 battery life since 4.5? Any improvement? Mine was sinking with 4.4 like Titanic…

1 Like

X 10 III Update from 4.4 to 4.5 without any problem.

  • uninstalled chum gui app before update because it said it could be a problem
  • manually switched microg fakestore from 0.0.2 to 0.1.0 in f-droid before update (as others have reported issues)
  • android apps appeared approx. 5 mins after the update and i couldn’t run any android app for another 5 mins. Just had to be patient
1 Like

Updated via OTA our Sony X Compact and XA2, both stuck at the End of the Progressbar but a restart with Power-Key and Volume-Up-Key did the trick. Both showing installed 4.5. and running without Problems so far.

My Daily Driver Sony XZ2 Compact (Community-Port) was updated via commandline with no problems, kudos to:

For this really nice and neat Port!


I also upgraded fakestore from 0.0.2 to 0.1.0 before the upgrade, and everything went smooth and quick.

Suggestion 1: recommend this fakestore manual upgrade inside the “how to upgrade” section of the release notes.

Suggestion 2: the feedback poll at the end of the release notes should be divided into early-access upgrades and after-official-release.

1 Like

same happened with Xperia 10III, also happened with the previous upgrade.

Here is the solution for getting hosts file working in android.


My XA2 returns the bluetooth to the blocked state efter a restart.

1 Like

For me it stays connected, but no sound. And the notification from headphones does not give the peep sound that it usually does when paired. Only unpairing and finding it again works. worked before update.

1 Like