SFOS 4.5 feedback thread

I also never got the feedback, that my voice is echoed during call and even tried it with a landline phone for myself. I read here that @vige had at least a temporary “magical fix” after using a bluetooth headset. Using a bluetooth headset for a test call was therefor one of the first things I did with my brand new flashed Xperia 10 III so I don’t know if it had the echo issue before.

@jovirkku What shall I do when all my Android icons are gone after the → update? My appsupport-root folder is empty. The home/.Android/data folder is empty. My Settings->Android App Support does not work (status is always only ‘starting’ after the boot procedure). Can you recommend some activities (maybe out of your referred doc ‘Removing Android App Support’)?

I’d like to report a bug introduced with 4.5. I have a sim from Orange PL with Xperia 10III. There is a problem with mobile data when network <4G. When network goes down to 3G or 3.5G (the latter started to appear after upgrade) there is no internet neither in native apps nor in android.
Seems like update to support 3.5G breaks internet.
I did an experiment, pinging in 4G. after network downgraded, pings worked for some time then stopped. I was moving in the city center and 4G appeared only after I disabled automatic network selection in mobile network options and manually selected Orange. Sometimes it upgrades automatically but after some significant amount of time.
Needless to say, it is extremally annoying not having internet, when I was really in the need… Seems like show stopper from my perspective with SFOS as daily driver.


Xperia 10 III
After the update Android apps can’t fully access (r+w) the sd card anymore.

Here, for example, has lost all downloaded maps. The sd card can be selected but upon saving the location an error is produced:
Memory Access Error
Your device won’t allow the app to store anything on the installed memory card.

Selecting Internal as location works, though. Maps can be downloaded. Thus, the respective permission has also been granted.

Other apps have the same issue. Only the internal memory works.
Any ideas how to fix that or what to look into or check?

It is possible to mount, unmount the card in the Android settings.

1 Like

Try to make the AppSupport migration script run again:

rm android_storage/.storage_migration_done

If that file to be removed does not exist, comment here.
So, if the above did not help, let’s collect some logs:


No one seems to have mentioned this so far so I might indeed be alone in this: After the update, I have been unable to search for updates - the software updater complains about not being able to connect to the internet - regardless of which regime I choose (Wifi-Only, Manually, always) or whether I am connected to a mobile or a wi-fi network.

Just checked that. I got an error too but searching again, it connected and told me: no updates available

Already tried searching again (i.e. after the initial error message immediately after clicking ‘Software Updates’ under 'Settings) before posting - still doesn’t work for me

That should not happen even if there are no further updates like now. A few things to check:

  • Using the browser, can you reach some websites?
  • Can you add a new city to the Weather app?
  • Is your Jolla account ok in Settings > Accounts?
  • Can you install apps in Jolla Store?
  • Are the date and time correct on your phone?
  • Do you have the licence enabled on your phone (can you see “Android AppSupport” in Jolla Store)?
  • Does the problem persist after rebooting the phone?

The update threw all my Android apps out of directories and now I cannot find anything as I have many screenfulls of them. I miss global search from iOS more than ever before.

Xperia 10 II



YES to ALL, EXCEPT for adding a new city to the weather app - However, I had always had this problem, so this is not exclusive to 4.5.

So now I reinstalled Sailfish to the new version 4.5 and now Android Support is working again…

4.5 doesn’t appear to have changed my mobile data problem:

1 Like

with xperia 10 android after upgrade:

message: upgrade falls try in other time, but the system indicate is

android support don’t start

isn’t way to add text name in address book, when you click in keyboard, the keyboard go hidden

Hi jovirkku. Thank you for your response. I just removed the android_storage/.storage_migration_done file and rebooted my Xperia X 10 II phone. Unfortunalty it did not help. The android apps are still not there and the .storage_migration_done file is created again. But it has 0 bytes. What can I do now. Shoud I wait for some minutes, hours? Or should I generate persistent log files via Collect Persistent Logs | Sailfish OS Documentation and send it to you or what should I do next?

Hejhej Jovirkku,

I have the same problem (Android support showing the proper WLAN but each with “No Internet” tag), being unable to access updates/stores (FDroid, Aurora) or apps that need logins (DB, banking, army, news aggregators) but letting Instagram and Whatsapp pass through (normal behaviour, no loss of data connection) since the update to EA. Also, there’s the same behaviour with mobile internet, but it doesn’t have the means to display missing internet connectivity. It also persists when only allowing 3G both for SFOS and Android layer.

The steps you mentioned above were all without flaw or fail, the problem starts with Android support.



Add-On: SFOS on Xperia XA 2 Plus, untrusted software allowed, full Android license since the beginning.

1 Like

update with xperia 10III went smoothly, no problems. but after the update my podcast app gpodder is missing the download button when accessing a podcast. :+1:

in general: still no bluetooth or nfc for android apps … too bad

Following this as exactly same issue with me & Xperia 10 II. Made backups of everything important so reflashing is a good clean-up possibility but quite bothersome all in all.

1 Like

The upgrade on Xperia X 10 II to passed without problems, in 12 minutes.
Android apps appeared after a couple of minutes, without rebooting the phone.
I checked the banking application right away – it works. I will check the rest as I use it.