[release notes] Koli 4.0.1

Who knows what was the point to update Android 8.1 to 9.0?
Not that much of a difference, seems like a waste of time…

Actually a lot changes underneath: https://developer.android.com/about/versions/pie/android-9.0

The newer the support the more Apps which will run and run better.


I like the new notification page, but before if I had a voicemail, I could tap on the notification and it would dial voicemail. Now, if I tap on the notification it doesn’t do anything - is this intentional?

Otherwise, I had no major issues with the upgrade and love the UX changes so far. I did have to copy the web browser bookmarks and database files as mentioned in the replies here but aside from that things have worked very well!

1 Like

Jolla not only removed bash, ps is now also the busybox ps, which is an extremly basic version and breaks a lot of ps related stuff. And why, just to gain some kilobytes of storage?


First I thought - nothing new. But, I like all the small ui chances!
The new browser is much better. Any idea why loading a web page takes so much time? But then, it is really smooth!
FireJail is also quite cool!

The update to with my Xperia Xa2 (single) worked without any problems.

Unfortunately, after the restart I had to find the following problems:

  1. Aliendalvik can no longer be started (Android apps
    no longer work)
  2. The “clock” app no longer starts
  3. The “calendar” app no longer starts

I haven’t dealt intensively with the update yet and will try to do it on the weekend.

My previous repair attempts have been limited to uninstalling and then reinstalling the Android app support. Unfortunately without success.

Edit: The Problem with Aliendalvik is solved. Thanks to Juanro49 for his hint: https://forum.sailfishos.org/t/4-0-1-15-aliendalvik-stop-working-and-doesnt-start-solved-removing-android-data/4635

The problem with the “Calendar”-app was easy to solve: a simple deinstallation and subsequent reinstallation helped. The entries were retained.

Unfortunately, this procedure is not possible with the “Clock”-app as it cannot be uninstalled.

I ended up just removing busybox-symlinks-bash for now via pkcon remove busybox-symlinks-bash. The system then just uses the regular bash that is already installed. Yes, I understand from the release notes that there’s security implications, but I’m willing to accept that risk so I can have a normal bash again. It would be nice if bash 5.1 could be packaged, as hopefully that would have most/all of the CVEs covered.


Yeah, that is unfortunate. I admit I didn’t notice the ps being different, but I probably would have sometime later today. For now I just removed the busybox-symlinks-bash package so I could have bash back, but ideally we’ll just see bash and ps get updated and reinstated in the future.

1 Like

If bash is problematic why it cant be replaced with something like zsh which is MIT licensed??

First: thank you for this release! Updating my XA2plus without sim went smooth. Next update will probably be the last, because there isn’t much space left. I also have an XA2, with sim, my phone. That is still in Torronsuo.
After a quick view: Again some loss of the famous Sailfish pulley menu in settings and in the event screen, to my regret.
Phone: I checked if there were changes in answering a call, but no. Because I just don’t succeed in swiping far enough, I miss calls. So my sim will stay in the phone with Torronsuo.
Event screen: notifications changed, not a big change, just another layout, so I expect to be adjusted to it soon. Text is smaller now, that’s a pity.
About permissions in mail and gallery: we have to give consent to all, no separate consent possible.
A bit of a disappointment is that nothing is said about GPS. Hopefully this will come next time. And another option for picking up a call.

1 Like

I can confirm on Xperia 10. Can be solved (also after update) by

pkcon remove harbour-dyncal

…and if done after Sailfish 4 update a reinstall of the calendar app followed by a reboot. Calendar entries will not be lost.


The hosts file is indeed mapped into sailfish-browser’s jail. Just type file:///etc/hosts into the address bar and its contents will show up. What’s missing is the corresponding nsswitch.conf. If you add that to Internet.permission, the hosts file should be back to work.

Also missing is /etc/resolv.conf. Hence the local connman proxy is used instead of a blocking DNS server unless configured inside connman.


I have a JBL 750BTNC Bluetooth headset, and it works fine. Well, music works rather flawlessly, and while phone calls do work, the quality is sub-par, because SFOS doesn’t have this/these codecs and/or profiles… It is a known issue :sweat_smile:

X 10 updated all OK. XA2, had problems with “Unable to determine update size” first and followed the guide at https://jolla.zendesk.com/hc/en-us/articles/217190827--Unable-to-determine-update-size-unable-to-update-how-to-fix but it didn’t help. Updating at the command line revealed, however, that the problem was actually that there wasn’t enough space on home partition to download the update. Cleared some space, then everything ok.

@martinh Thanks.

So you say nsswitch.conf, resolv.conf is missing for --private-etc=?
But hosts is listed?

Not really knowing much about firejail (yet) but is this not worth to be filed as a separate bug to make Jolla aware?
(will then also fix defender again)


Yep, I had that previously with the QC35’s too when the mic is used too, I expected that!

I continued the thread on the QC35 issue in the separate thread by @spark since it turned out to not be directly related to this update, to keep this thread focused :slight_smile:

Backup to onedrive still does not work : 3.4.0 Manual Backup to OneDrive

Yes. You can check the contents of a jail by running

$ firejail --list

to figure out the name of the jail (number at beginning of line) and now

$ firejail --fs.print=NAME

will list the contents, e.g.

$ firejail --fs.print=14840 | egrep "nsswitch|hosts"
Switching to pid 6150, the first child process inside the sandbox
clone /etc/hosts
clone /etc/hosts

Without nsswitch.conf the resolver will not even look at /etc/hosts as you can check by moving it away and running e.g.

$ strace nc localhost 99

resolv.conf is not that important since it usually points to localhost anyhow and nameservers can be overwritten per service with connmanctl or other dbus clients.

Probably, but that’s up to @martijntje, who spotted the problem.


I also noticed that bash 5.0.18 gets activated once you remove busybox-symlinks-bash.
That means Jolla no longer sticks to the bash 3 version which still has a non-GPLv3+ license.

This draws me to the conclusion they wanted to get rid of the old bash 3, but did not want to install anything using the GPLv3+ license, so they opted for the busybox bash as a default install.


Signal is borked after update . recorded audio is slow and distorted . also the option to disable screen timeout is gone, max is now ten minutes . i miss the option for never :frowning: beautiful update otherwise ! very nice gui improvements :slight_smile:

1 Like