How to get microG running on XA2 with SfOs 4.4

Hey ho. Starting with Jolla1 and user from the first time I ever solved all problems with Jolla/Sailfish by myself. I am not an adavanced user and do not coding but a daily driver with long time experience in using SfOs - and I love it.

But now I need really help from you experts, adavanced users and developers because I can’t get running microG. I need running some apps depending Google play services and I am going around for some time with my XA2 AND an iPhone - just for running the Play service Apps…

Now it’s time to come back to only one device - so need to get microG running.

It is correctly installed but I can not activate spoofing:

I can not find out any way to reach this screen and set these general android settings (what maybe is the missing action to grants signature spoofing permission)

Any idea what to do?

Hi, i’m quiet a user like you, on board since jolla 1 but without coding experience and i tried myself to make microg work lately. Not shure if this is helpful:

Go to Jolla Settings App > Android Support > Second Tick Box should be activated, something like “Deactivate Checking of Android Support Package”. This should allow inofficial Stuff to run like Signature Spoofing, at least it worked for me.

At your own risk and good Luck!

Yes, this is right. Signature spoofing must be enabled in the Android compatibility layer on the Jolla side, since it is a feature provided by Android to the (fake) Google Services, not a feature of the Services themselves. Therefore, it must be enabled in the Jolla Settings app, Android App Support section.

the self test on microG give back that the system is supporting spoofing (see first screenshot, first checkbox). That’s the activation on SFOS > Android Settings - so it’s done already.

But it do not grant permission and need any further action… So how can I set this?

Install “Hidden Settings” from Aurora Store. From that app, go to Settings to access the Android settings menu, and then to Privacy → Manage authorizations (or whatever, I have menus in Italian).

The Self-Check in microG settings is not just a self-check. Tap on the text to turn a setting on (or off).

3 Likes

dam’n - so simple. Thanks!

Android Apps depending on Play Services running now like expected with MicroG.

Many thanks again.

1 Like

Thanks for the info (this has indeed changed: it used to be done in the permissions settings of android, now that list is empty).

too bad the old forum is read-only and I can’t update the tutorial

1 Like

Where can i find the complete instruction for installing microG with a 4.4 clean install please ? ( XA2 )
A bit confused here … :sweat_smile:

Thanks :slight_smile:

Hi,
I just followed that instructions [How-To] MicroG in SFOS 3.1 - together.jolla.com
As I remember it served for SFOS 4.4 too

Thans for your answer :slight_smile:

So far, on the XA2, I had been using custom microG provided by Youtube Vanced. It did work, as I was able to run e.g. latest Here WeGo and Google Maps app.

Now that I got the 10 III, I want to install some Android GPS navigation apps on it, too, which also need microG.

The question is: does anyone know if there is any serious (functional) difference between the custom Vanced microG package and the “official” one from microg.org? The former is much smaller and it seems “lighter”.

I get it is a huge task but would you make an up to date tutorial for this forum? Is the older tutorial still the way to go to get this microG working? I’m asking as I would like to use the Postfinance Twint app on my XA2 Plus…

2 Likes

It’s still roughly the same approach. With a few gotchas, e.g.:

  • At the time I tried, microG only properly installed with the (slightly older) version of F-Droid that you can obtain when installing the Jolla official Android support. Thus the exact order of operations is:

    • Install Jolla’s official Support for Android Apps.
    • At the end of the installation procedure, Jolla’s installer lets you pick an app store between FDroid, Aptoid, and I forgot what else. Pick FDroid.
    • DO NOT update FDroid.
    • install microG (and plugins you might need like Nominatim) with the old version of FDroid that came with Jolla’s installer.
    • Go back in FDroid, check that microG is marked as “installed” (i.e.: FDroid properly recognises that it has installed FDroid).
    • NOW you can update FDroid from within itself.
    • Check again that FDroid still detect microG as being installed by itself.
    • Add microG to the blacklist of Aurora (even if you have checked the option to auto filter out FDroid applications from Aurora).
  • For the signature spoofing:

    instead of the old way in the permission list.

  • There’s a simpler way to access the android settings, too:
    there a patch called “show android settings” for patchmanager.

That’s where I got a problem probably. I have an updated FDroid for sure as the microG does not install. Other apps from FDroid do install and work though.
FDroid also has older versions of microG maybe that could do the trick. I will try later.
The annoyances of being on an “opensource” system really.

Maybe the Jolla Store version of F-Droid includes the microG repository already set up? I always had to add it by hand to be able to find microG via F-Droid.

Nope, the microG repo has to be added also on the jolla version of the fdroid store.
I’m ripe to jump the fence.

1 Like

One option is also to just download MicroG Services Core apk file from the project’s website and then configure it in addition to FakeStore installation. However, adding the repository to F-droid is the best choice.