Android Support/Alien Dalvik no longer working []

Doesn’t work well at all with Aliendalvik, very unstable, apps crash, I have the problem of the flickering black screen

same here, uninstalling Aliendalvik Control 9.3 and Android Support did not help so far. Android support buttons remain greyed, Aliendalvik Control buttons don’t act, and I have flickering black screen now and then.
but BANG after disabling Topmenu Control I get working android support :wink:
using aliendalvik control will trigger a bad flickering.

Uninstalling Android Support via Jolla store left it available in settings… so this did not uninstall, only it’s buttons are grey again.

Is there a foolproof way to really uninstall Android App support completely?

well, the brutal way to remove all android stuff
goes like this…
rm -rf /home/.android/*
rm -rf android_storage
after that I re-flashed SailfishOS 3.3. It did not work.

Same problem here on xa2 after upgrading to 3.4.0. Android support would not start and buttons in settings were greyed out. Alien dalvik control was never installed on this device.

What worked for me:

  • Uninstall Android support from the store
  • Reboot
  • Reinstall Android support (still not working)
  • Reboot with ‘start android app support on bootup’ on in settings.

Everything worked again and found my Android apps.

Same problem on xa2.
With alien dalvik control.
tried to uninstall/reinstall etc … didn’t work.

Reflash 3.3, then update to 3.4, then install android support and working fine.
Android apps are running smoother now :slight_smile:

I reflashed 3.0 then 3.2 then 3.4 no dalvik control: Didn’t work.

Got my XA2 working - but had to make a reset to factory settings (=3.1, update to 3.2, then direkt to 3.4).

That worked for me. Remove /home/.android - but I do not know if I rebooted once or twice.

Also for me, no Android support/Alien Dalvik after updating to 3.4 on XA2plus. Reinstalling Android support and Aliendalvik Control did not help. However, after rebooting I was able to enter to Android settings after hitting settings button on Aliendalvik Control. Flickering is popping up but Android settings is useable but no other Android app. They seem to crash… . Terminal output of “systemctl status aliendalvik” shows interesting message highlighted in red "Process: 10216 ExecStartPre=/usr/sbin/ (code=expired, status=203/EXEC)… also in folder /usr/bin/ (code=expired, status=203/EXEC) ==> seems like this script is the guilty one!? Would be somehow nice to find out the reason why Android Support is crashing.

1 Like

Amazing! This => deleting /home/ .android folder <== solved it even though I lost all my installed Android apps. Android Support works again :slight_smile: Thank you!!!

1 Like

@Ygriega & al:
Thank you for reporting. There is indeed a defect here. An internal bug has been filed and a solution found.

In the meantime, before the fix is rolled out, running these commands should help:

systemctl stop aliendalvik
rm -rf /home/.android/data/system/package_cache/1/Alien*
systemctl start aliendalvik

that’s works !!! THX

Yesterday, I performed a factory reset which reverted my phone to a 2019 version.
I upgraded the phone without android support twice to reach the current version.
With the current version I installed android support and everything is working fine again.

1 Like

Thanks for the update @jovirkku. Glad that you found the root cause…

1 Like

It doesn’t work for me, maybe a syntax error, can you be more precise, I don’t understand because AlienDalvik isn’t installed at my place, what to do after this procedure
thank you

@fredb: Well, if Android App Support (“aliendalvik”) is not installed in your phone, then skip the command to stop it. Try the rm command (to remove some conflicting/incorrect items) after which you should restart your phone.

1 Like

OK, I’ve finally understood, it works, thank you.

Done, all works now ! Thank you !

same isuue with XA2 recently updated from 3.3 to 3.4. After several reinstalls of android support and aliendalvik this is the only think that worked. THANKS!!

would you mark @jovirkku 's answer

as solution for other running into this?
(knowing this is not a solution but a workaround)

Hi, I may be doing something wrong but having run these commands, unfortunately the issue is persisting (XA2 single SIM).
I’m able to uninstall and reinstall Android Support in the store, however when I go into Android Support settings, the options to Start or Start on Bootup do not respond (the option being pressed is recognized). I get the responses seen on attached screenshot when entering commands, and have tried restarting between uninstalling and reinstalling to no avail. The flickering has gone but Android apps don’t finish loading. It’s like there’s something missing that it needs to get going again, hoping I didn’t delete the wrong thing but was pretty careful with the commands.

Edit-- Forgot to mention that when I try to open an Android app, it opens the Android Support page in the Jolla Store, whether it’s currently uninstalled or installed.
Thanks for any assistance with this, if a fix is incoming, I won’t mind waiting a few days. I’m able to get by surprisingly well (Pocket Casts web app is usable in landscape with updated browser) without Android so far.