Android Support/Alien Dalvik no longer working []

I’m fed up with the same thing, I’ve already had a lot of problems with these capricious starts, there’s really a problem with android support, someone really needs to find an alternative solution!

I think I stumbled upon similar issue like this. Updated my XA2 Dual-Sim to yesterday and aliendalvik crashed couple of times when trying to use Android apps but it started to work normally after couple of minutes. No issues any longer and whole device seems to be more stable than before

Ok I’ve installed Alien Dalvik, but not solution for me, it still doesn’t work
My Aurora and F-droid shops don’t work anymore either

You are my hero! It works now.

Got a tip from a sailor that brought back Android Support without reflashing. But: I needed to reinstall my Android apps. So, only do that in case you are willing to reinstall your Android apps!

  • Delete/move /home/.android. Devel-su will be required
  • Restart your device
  • If Android support is not launched automatically, start it from settings
  • The Android directory is now regenerated, that might take a while and the device may become unresponsive
  • Wait until the device becomes responsive again
  • Verify that Android support works again by calling apkd-launcher The Android settings dialog will come up
  • Re-install your Android apps

Same here, removed Aliendalvik-Control before updating, but didn’t reinstall Android app support. No success then. System log is:

[root@XperiaXA2 ~]# systemctl status aliendalvik
● aliendalvik.service - Alien Dalvik
   Loaded: loaded (/usr/lib/systemd/system/aliendalvik.service; disabled; vendor preset: enabled)
  Drop-In: /usr/lib/systemd/system/aliendalvik.service.d
   Active: active (running) since Wed 2020-09-30 18:48:53 CEST; 15s ago
  Process: 10885 ExecStopPost=/usr/sbin/ (code=exited, status=0/SUCCESS)
  Process: 10880 ExecStopPost=/usr/libexec/lxc/lxc-net stop (code=exited, status=0/SUCCESS)
  Process: 10953 ExecStartPre=/usr/libexec/lxc/lxc-net start (code=exited, status=0/SUCCESS)
  Process: 10948 ExecStartPre=/usr/sbin/ (code=exited, status=203/EXEC)
  Process: 10944 ExecStartPre=/usr/bin/ (code=exited, status=203/EXEC)
 Main PID: 10959 (start-aliendalv)
   Memory: 468.0K
      CPU: 1.214s
   CGroup: /system.slice/aliendalvik.service
           ├─10959 /bin/bash /usr/sbin/
           └─11042 lxc-start -n aliendalvik -F

Sep 30 18:48:34 XperiaXA2 systemd[1]: Starting Alien Dalvik...
Sep 30 18:48:51 XperiaXA2[10959]: purging old alien user: Eigentümer
Sep 30 18:48:52 XperiaXA2[10959]: Error: couldn't remove user id 0

Strangely on my device /usr/bin/ is missing and there’s a good reason, why removing user id 0 fails on a UN*X system.


I installed the newest AD Control and now all Android Apps work again. Should have known this before I uninstalled and re-installed some Android Apps. Also after re-install apps worked again. But this solution is more convenient. Thanks!!

1 Like

Android start stop buttons in settings are greyed out.

1 Like

It’s the same for me. The strange thing is that the Store shows a version from 2019…maybe that’s the problem…?

Same here …
I’ve even deleted the .android folder and reinstalled Android Support.

Update: I finally restored the phone to defaults and upgraded again. Everything’s working fine now under 3.4.

unfortunately it does not work for me. I reflashed and OTAd to via 3.2.0.x

I uninstalled Aliendalvik-Control because I had problems with the versions. The update to took place without Aliendalvik Control being installed.
After I had problems starting the Android apps, I also uninstalled and reinstalled Android support. This attempt was unsuccessful.
After uninstalling Storeman and reinstalling it, I installed Aliendalvik Control again.
After restarting the device, the Android apps also worked again.
As already mentioned: I don’t have a real explanation for this.
Unfortunately, I don’t have the skills for more detailed analyzes.
“user id 0” doesn’t mean much to me personally. It appears to be a user conflict. Does the new “multi-user system” have something to do with this?

Thanks, it’s working!

how to uninstall and reinstall Android support? I think I should do that, but how? Are we talking of Android App Support here, which is in in Settings?

Open Jolla Store, pull down My Apps, look for Android App Support. Long-tap it and take Delete.
It may be good to restart the phone at this point.

To install it, go to Jolla category of apps, look for Android App Support and pull down Install.

1 Like

Yes … I also talked about the Android app support.
But for me the point was not that.
The solution for me was “Aliendalvik-Control”!
The problem was only solved for me by installing the new “Aliendalvik-Control” version.
You can find Aliendalvik-Control from “coderus” on Openrepos.
I used Storeman to install it.

1 Like

thank you. I did update a brand new flashed SailfishOS 3.3, added the newest Aliendalvik-Control, but Android App support does not work. For this reason I asked… my next step is to uninstall everything alien dalvik and then to reinstall Android related apps one by one.

I did the hard way… flashing SailfishOs 3.3, then updating, then instaling Aliendalvik-Control. And MicroG. Worked so far (after I destroyed my old Sailfish :wink: ), but have still one problem:

  • Whatsapp does not see Google-Account for message backup/restore
  • New Signal app does not read-in contacts…

So despite the cool changes, in real life I am still not satisfied.

No this type of problems on Sony Xperia XA2 Ultra H3213. I’ve tried Signal, Slack,, OmaPosti, Tiima Mobiili, Eazybreak, Danske Mobiilipankki, Zoom, HSL, FreeShishen.

There are different Aliendalvik Control versions. There also seem to be incompatibilities here.
For this reason I installed the update to, after previously uninstalling Aliendalvik-Control.
Only “after” the update to did I reinstall Aliendalvik-Control, which then solved my problems with the Android apps (apparently).
For Sailfish you need Aliendalvik 9.3 Version,
for Sailfish 3.3… you need 9.2 Version.