VoLTE provider support

Shouldn’t the ‘Registration’ table column have the correct name ‘Registered’? There are two parameters in the properties: ‘Registration’ and ‘Registered’. ‘Registration’ is set to ‘auto’ by command, ‘Registered’ should be ‘true’, if VoLTE is working properly, right?

1 Like

You’re right, it should have been Registered. Thanks @lhodas for highlighting it, and @abranson for fixing it!

VoLTE itself seems to work fine with my Provider(Norma/Telekom DE) but my mobile data is messed up. If VoLTE is enabled, i loose internet access after every phone call, airplane mode, switching wifi off etc. Only disabling and enabling VoLTE fixes this problem.

Should i file a bug report?

Yes, please do @miau, that would be appreciated.

The 10 III Android 12, does not work 4G voice.
My Blackview Android 10 chinaphone works perfectly VoLTE and VoWiFi.
Neither is in the operators published whitelist, so it seems unlikely that it is a whitelist issue at the operators end.

Found this but the rest of the thread didn’t show the OP getting the phone working…

Most of the xperia phones that come into NZ are Hong Kong sourced, and the stock firmware doesn’t support volte. Changing to the SEA firmware makes the volte toggle switch available

Android version after OTA is “62.1.A.0.550 release-keys”

@flypig Is SF using the installed android or completely replacing it? As my version of Android appears to have disabled VoLTE, will SF also be disabled?

I have added extra table options for testing android volte and vowifi

There are elements of Android (drivers) that are still used by Sailfish OS, but in this case I wouldn’t be able to tell you whether the disabled VoLTE in Android would transfer over to the Sailfish side I’m afraid. I’ve asked internally in case anyone is able to help.

1 Like

@crun Did you check that VoLTE was enabled in the Android settings?

@flypig FWIW, I installed SFOS on my X10III without having a SIM card in it first, nor touching the VoLTE settings. VoLTE works fine!

(I did, however, upgrade to Android 12, stuff happened, downgrade to Android 11 using Emma, more stuff happened, and the the flashing worked.)

1 Like

It does not show up as an option. (not even greyed out).
Same as reported here , where replacing the fw doesn’t make it appear

Same here in France. VoLTE doesn’t appear in Android settings (and in SFOS doesn’t register).
However, VoWifi option was available in Android and can be activated.
Though, on my other Asus Android phone, VoLTE doesn’t appear either currently, so I am not sure if it’s carrier related or not. I’ll see if I can try another carrier sim (that is tested with a working VoLTE phone) and see if that changes anything.

1 Like

The VoLTE setting depends on the manufacturer modifications, too.

The question is: What are those modifications?

Different region firmwares don’t fix it.
It doesn’t appear to be a whitelisting issue
Generic Chinaphones work, brand new, latest Android Sony’s don’t.



VoLTE works in Austria with my provider A1 Mobil.

Registration: ok
Voice incoming: ok
Voice outgoing: ok
SMS incoming: ok
SMS outgoing: ok

4G indicator persists across all tests.

Unfortunately I can’t edit the wiki entry yet. I haven’t been registered in the forum long enough.
can someone else expand the wiki entry?


Thanks for addition @bardoftruth, I’ve added in a row on your behalf.

thanks! :slight_smile:

I have SIM cards for Magenta / T-Mobile Austria and Hutchison 3 Austria

With this I can test all major Austrian providers.
I hope I’ll get around to testing them later today.

Superb, thank you @bardoftruth! Post them here and I’ll add them in, if you’re not able to updated the wiki directly yourself.

Got VoLTE activated from my carrier and working on Android correctly.
On SFOS, it registered but a few issues : no Internet 4G at all, and receiving calls switches to 3G (but not outgoing). The rest is working fine.
I updated the line in the first post.

1 Like

I have now tested Hutchison 3 Austria.
VoLTE works (voice&sms incomnig&outgoing)

Sorry but I can’t test Magenta / T-Mobile Austria. VoLTE is not activated in my contract

I have already edited the wiki entry for Hutchison 3

1 Like

Glad you got the same result as me on Orange Fr. They’re the same network and should be the same config. I think there’s something wrong with that config in the firmwarethough, as I managed to get 4G incoming calls on the X10ii with a bit of hacking.

1 Like

HK users here, confirmed it works, edited wiki, let see any problem if keep long period

1 Like

BV9900 works?
Is there a SfOS release for the Blackview BV9900?