Accounts - Bug in 3.4 when using Backup

REPRODUCIBILITY (% or how often): 100%
HARDWARE (Jolla1, Tablet, XA2,…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): don’t tested


Accounts added from Backup don’t work. Sure, we need to re-enter the passwords, but nevertheless no connection ist possible. That affects:

(I don’t remember if Twitter was affected too. Other account types untested cause I don’t have such)

If the account is completely deleted and added new everything works like expected.


XA2 was on 3.4 with Android support problems. Factory reset


  1. Create Backup to SD from 3.4
  2. Reset phone to factory settings (gives System 3.1)
  3. Updating phone from system settings (in two steps: 3.2, then direct 3.4)
  4. enable encryption
  5. import backup from sd
  6. go into each account and fill in the specific password


Accounts importey from backup should work after adding password in settings.


Accounts don’t work


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)


One needs to sign-in to one’s accounts after restoring the backup.
The credentials may not have been restored.

@jovirkku sure, you need to fill in the password, cause passwords aren’t saved with the backup. But I see that I just wrote that in expected results and not under reproduce steps as well (will fix this soon).

Fact is: I restore the accounts via backup, go to accounts, enter the password for each account, save it and the account still doesn’t work. Just deleting and new account setup fixed that.

I tried the same and also the jolla account does not work any more, no matter if I re enter the password or delete it and set a “new account”. Password.and correct, I do get an other error message, when I enter them wrong. Error message: Login not possible with THIS Login and Password.

Same with e-mail accounts - for me, they do.not even synchronize after I delete.the account and have them new again.

Could this be a problem with the encryption.and storing of the passwords?

I have had the same problem. I use very long passwords in emails and the truth is that it is a mess to do everything again :confused:

@eztero What did you do to solve it?

Can confirm. I had reset my phone a few months ago, and the issue was already present in 3.1 (at least with email accounts).

The only solution i found was to delete the accounts and re-create them again.

1 Like

But this does not work for Jolla Account…

@tomas3000 This should fix it for you. I’ve traced the problem (or rather read it on here).

Sailfish has full tar. Sailfish X has Busybox tar, which can’t deal with the tar that ordinary Sailfish Backup creates.

It’s fairly easily fixable by first installing NielsDK’s tar:

For whatever reason, this makes it possible to create accounts again.


Nice find. I wonder if this is related, AFAIK busybox tar does not do gzip compression, or at least does not support the compression features of GNU tar.

Iirc this was also already discussed on TJC?

And it looks like there is no need for an openrepo usage:

Installed tar-1.28-1.15.1.armv7hl (installed) GNUimplementation of tar ((t)ape (ar)chiver)
Available tar-1.32+git1-1.5.1.jolla.armv7hl (jolla) A GNU file archiving program

Installed is nieldk’s tar (since years!) and second line shows that there is a full tar also available in SFOS repo.
(but I do not get an update notification for tar?)
So installing via

devel-su pkcon install tar

should fix it also?

There is a Jolla-provided GNU tar version available.

You can:

pkcon remove busybox-symlinks-tar ; pkcon install tar

without using an OpenRepos version.
Not sure how much this will break though.

Again, I’m only talking about restoring a Sailfish backup on to Sailfish X. Ordinary Sailfish has full tar already, which is partly why the problem arises.

It’s not relevant to the OP’s problem at all.