[4.3.0.12] Jolla camera (also torch) does not start at all - as well as videos do not play

Possibly related…possibly not, but, I lost the option for Flash on when shooting video, this was on my Jolla1’s camera which occurred after updating the OS several releases back. A reset of the dconf camera path fixed the problem.

dconf reset -f /apps/jolla-camera/

Out of curiosity, I did a dump from dconf on my Xperia 10 ii, I wonder if it may reveal problems for other users by comparing a dconf dump from their device.

dconf dump /apps/jolla-camera/ > xperia10iidconfdump.txt

The above line of code, writes a text file containing the dconf dump of camera settings, name it what you like as long as it ends in .txt, then you can read it or send it elsewhere for further scrutiny.

backCameraLabels=['1.0', '2.0', '0.6']
captureMode='video'
deviceId='1'
exposureCompensation=1
landscapeCaptureButtonLocation=5
portraitCaptureButtonLocation=3
previousBackFacingDeviceId='1'
previousStoragePathStatus=0
qrFilterEnabled=true
saveLocationInfo=false
whiteBalance=0

[back/image]
aspectRatio=1
flash=1

[back/video]
aspectRatio=1
flash=2
viewfinderGrid='none'

[front/image]
aspectRatio=0

[primary/image]
captureMode=1
exposureMode=1
exposureModeValues=[1, 2, 3, 6, 23]
flash=2
iso=3200
meteringMode=1
meteringModeValues=[1, 2, 3]
timer=0
viewfinderGrid='none'
viewfinderGridValues=['none', 'thirds', 'ambience']

[primary/video]
captureMode=2

exposureMode=1
exposureModeValues=[1, 3, 6]
flash=2
iso=0
meteringMode=1
meteringModeValues=[1, 2, 3]
timer=0
viewfinderGrid='none'
viewfinderGridValues=['none', 'thirds', 'ambience']

[secondary/image]
captureMode=1
exposureMode=1
exposureModeValues=[1, 2, 3, 6, 23]
flash=2
iso=0
meteringMode=1
meteringModeValues=[1, 2, 3]
timer=0
viewfinderGrid='none'
viewfinderGridValues=['none', 'thirds', 'ambience']

[secondary/video]
captureMode=2
exposureMode=1
exposureModeValues=[1, 3, 6]
flash=2
iso=0
meteringMode=1
meteringModeValues=[1, 2, 3]
timer=0
viewfinderGrid='none'
viewfinderGridValues=['none', 'thirds', 'ambience']

end of dump.txt

Just, where it belongs!
So nothing to worry/do.

That is another story and (looking-for-next-fanboy-bash-or-censoring:) another real mismanagement of how updates are spit out to ‘normal users’. With a mistake that camera, torch, videos (and more?) were not working you (the ‘normal user’) was left alone for over two weeks (@deusexbeer many thanks for bringing up the workaround!, @abranson, thanks for correction). And even then you need cli experiences and root rights to correct.
Not to speek about that a ‘fix’ would only come maybe with the next release in 3-6 months!

You should read my comment

Only if added manually you need to remove.
If it is in global, everything fine.

Mentaljam-obs is related to Storeman (inside global).

And ssu rr removes only repos from user section.

Ok, so that explains that.
But why does the work-around not work in my case?
Yes I know, that’s an unfair question. :grin:

By the way: do you even know any ‘normal user’ that uses Sailfish OS?
My guess is that (successfully) flashing SFOS on your device immediately removes one from that category. Notwithstanding that, it should just work and if not, be fixed quickly.

Maybe because -as you did not read above - you also did not read that?

This forum -as well as the former one- is full of posts/questions/help calls of people not aware of necessity to become root in cli (have enabled developer mode, set up ssh …) to get this thing running. So yes.

And to be honest -not meant disrespectful!- is this here not the best example?

Yes. Flashing is always a solution (as often proposed by put-in-some-word-here. NOT!

YES.

Did you update/verify the system after the repository fix? E.g. with sofs-upgrade SFOS does not fix itself unfortunately

Thank you for your kind help. If I try sfos-upgrade I get:
#sfos-upgrade
Notice: Less than 1 GiB (864140 KiB) free space on the root filesystem!

Now what?

Another missed read?

I humbly apologize for not having followed your advice but rather that of @abranson , who used the word ‘we’ (“There’s a bug in ssu that we didn’t think affected public releases…”), making me think he had a part in producing SFOS.
Please don’t feel offended by going by his advice and not yours.
I’m just trying to enjoy a non-google/apple phone even with my amateurish level of understanding and I came here for help in realizing that ideal.
I do not know what exactly it is that I said to p*ss you off like that but take my word for it that it was absolutely not meant to have that effect.
Thanks for your help too.

I thought I deleted that post…

And I am absolutely not p*ssed off by you
(sorry if this left you with such feeling) but the way these updates are sent out to users like you. And the way users like you are left alone with letting them solve that on their own using root privileges (possibly not even knowing what they are typing or blindly copying).

Ok.
After getting that low-space warning in sfos-upgrade I chose zypper ref, zypper dup and that updated about 168 packages (I wonder why as my 4.3.0.12 update ended without error messages) and the camera works. Apparently you know better than the guy that I thought was from Jolla.
Thanks.

Regarding the ‘discussion’ above I summarize @deusexbeer, @abranson, @peterleinchen advices and put the solution pointer to this here:

devel-su; 
ssu rr adaptation-common; 
rm -r /var/cache/ssu/; 
ssu ur; 
pkcon refresh; 
version --dup; 
#sync; reboot;
2 Likes

That absolutely sounds like a not completed update despite the absence of any error message. (it were about a handful of packages missing only)
But I am pretty sure you will not get any explanation on that by Jolla or other peeps thinking this update mechanism or kind of OS is ready for end users…

No, definitely not!
But, many thanks for the flowers :wink:

You are welcome.

@abranson’s instructions worked for me, too; the adaption-common repository was there again after these commands.

After that a version --dup updated a few packages, and after a reboot the camera was usable on my Gemini again.

1 Like

I had the same camera/torch problem after a series of updates from 4.0.1.48 Koli step by step untill 4.3.0.12 Suomenlinna (2021-11-14).
Hardware: Sony XPeria XA2 (Apparaataanpassingen: 0.0.9.8)
(ps: although camera worked in Signal).
Learning from your post I first checked the repo list and noticed the “adaptation-common” was just not there.
Followed the rest of the commands and that fixed the problem.
Thanks a lot, it saved my machine from the trash…

I just run across this same thing.

Hardware: Sony Xperia 10+ Dual sim. Two sims and 128GB microsd (formatted to ext4 and encrypted).

My Xperia 10 was bent and had all kinds of issues, so I pulled out spare, flashed it with the bought SailfishX 3.3.something, installed some default apps (all Jolla’s), then started upgrade up to Suomenlinna. Camera app just dies after a wait. I used peterleinchen’s set of commands and that did it. Now it works.

So far I have used developer tools just for the fun of it. Mostly used ssh/scp to access the phone and update my music library. This was the first time I actually really needed those tools to get the phone up and running.

Thanks to all you more knowledgeable for solution. I had Suomenlinna also on Xperia 10 dual sim (no plus). There everything worked. Weird.

Hello, Same here and have been occasionally with older software releases too. reboot at least is needed to fix.
symptoms I have had with camera & flash.

  • flash not lit, also torch is out of course
  • cameara very bad in darb environment or in bright light.
    pictures either blueish or green.

Video:

  • slow and stuttering
  • screen may start flashing during record and then after a while it sometimes turn green.
  • phone may even hang for a while if video recording is continued in that conditons longer.
    other minor strange anomalies that i will not list…

I have not made any tweaks to my phone nor used any other than jolla repos etc. Just used sailfish as it is.

The behaviour you describe is different (camera works but quality is bad vs. camera crashes), so please create a separate thread for this issue, or continue another one which more accurately matches the problem you experience

Thanks, deusexbeer, for the fix. I did your “update” instructions in reverse to make sure “zypper” was installed and there were no errors on “ssu ur”. I got it all right on the first try and everything works again. Have a very nice day. :slight_smile: