[4.0.1.45][XA2 plus dual sim] - sim not selectable

REPRODUCIBILITY (100%):
BUILD ID = 4.0.1.45
HARDWARE (Jolla1, Tablet, XA2,…): XA2 Plus Dual Sim
UI LANGUAGE: English
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

Inside the “Phone” application, when you select a contact, the drop down window for choosing the sim appears and immediately disappears, so it’s impossible make a phone call.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. open “Phone” app
  2. go on “History” or “People” tab
  3. select a contact for making a call

EXPECTED RESULT:

select the sim and make a call

ACTUAL RESULT:

the phone cannot easily make a call (you must open the contact and then select the sim).

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

4 Likes

I can confirm this - same behaviour on my Xperia XA2 Plus DualSim

Thank you for the post. We have filed a bug report for this.

1 Like

Same on my XA2 Dual SIM with german layout.

Please fix this asap. Phone is almost unusable with this bug

Hello Jolla! This is SERIOUS! We cannot use our dual sim phone as a phone!

2 Likes

This is a (rather complicated!) procedure to make calls with selection of the SIM card.
First my settings:

  • In ‘Settings (System) - SIM-cards - Use SIM-card’: set to ’Always ask’
  • in ‘Settings (Apps) - Phone’: disable Quick call

Now when you select a call history entry in ‘Phone (History)’ the contacts page opens. There you can select the phone number to call. Before to start the call it asks you to select the SIM card.

2 Likes

Nice find of another workaround one needs to remember for the next months.

Addituon: it only works when you click the upper saved contact phone number, not the activity (last called / be-called-from number)

Same here, XA2 plus dual-sim, SFOS 4.0.1.48.